segment event transaction semantics are wrong

Bug #1675910 reported by Kevin Benton on 2017-03-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
High
Kevin Benton

Bug Description

_delete_segments_for_network is currently being called inside of a transaction, which results in all of the BEFORE/PRECOMMIT/AFTER events for the segments themselves being inside of a transaction. This makes them all effectively PRECOMMIT in the database lifecycle which violates the semantics we've assigned to them.

Tags: db Edit Tag help
Changed in neutron:
assignee: nobody → Kevin Benton (kevinbenton)
Changed in neutron:
status: New → In Progress
Changed in neutron:
importance: Undecided → High

Reviewed: https://review.openstack.org/429441
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=12d24abba75ab3b926edbac389437bacc23914dd
Submitter: Jenkins
Branch: master

commit 12d24abba75ab3b926edbac389437bacc23914dd
Author: Kevin Benton <email address hidden>
Date: Sun Feb 5 17:56:25 2017 -0800

    Delete segments on BEFORE_DELETE instead of PRECOMMIT

    Deleting segments results in BEFORE/PRECOMMIT/AFTER events
    itself so it shouldn't performed while already inside a transaction
    to delete a network.

    Closes-Bug: #1675910
    Change-Id: I6c8070e1dc2216ea909288ce1133321e8eda1daa

Changed in neutron:
status: In Progress → Fix Released
tags: added: db

Change abandoned by Ihar Hrachyshka (<email address hidden>) on branch: stable/ocata
Review: https://review.openstack.org/450443
Reason: Not sure I want to backport all those changes for a semantics fix that doesn't immidiately hits someone.

This issue was fixed in the openstack/neutron 11.0.0.0b1 development milestone.

Reopened since we reverted the fix.

Changed in neutron:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers