OVS trunk management does not tolerate agent failures

Bug #1623708 reported by Armando Migliaccio on 2016-09-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Brian Haley

Bug Description

It is clear that patch [1] will be unable to complete in time for RC1. This bug report is tracking the effort to complete it post RC1.

We need to revise the OVSDBHandler module to make sure we can tolerate loss of events (OVSDB and Remote) in case of agent failures.

[1] https://review.openstack.org/#/c/365176/

description: updated
Changed in neutron:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Rossella Sblendido (rossella-o)
Changed in neutron:
milestone: none → newton-rc2
tags: added: newton-rc-potential
Changed in neutron:
status: Confirmed → In Progress
tags: added: trunk

Where is the patch?

Fix proposed to branch: master
Review: https://review.openstack.org/375132

Changed in neutron:
assignee: Rossella Sblendido (rossella-o) → Armando Migliaccio (armando-migliaccio)
Changed in neutron:
assignee: Armando Migliaccio (armando-migliaccio) → Rossella Sblendido (rossella-o)
Changed in neutron:
assignee: Rossella Sblendido (rossella-o) → Armando Migliaccio (armando-migliaccio)

Reviewed: https://review.openstack.org/365176
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=08f2af18f996c9ec89ddb6554a1132aa9605b5af
Submitter: Jenkins
Branch: master

commit 08f2af18f996c9ec89ddb6554a1132aa9605b5af
Author: rossella <email address hidden>
Date: Fri Sep 2 19:40:52 2016 +0200

    Handle add/remove subports events loss due to agent failures

    Upon restart the agent reconciles the logical with the physical
    state by removing/adding physical subports that are used to
    be/are current present in the logical view.

    This patch adds a functional test to demonstrate that there's
    no need to handle the resync in the trunk driver, since the ovs
    agent already takes care of it.

    Change-Id: I164153c79313f2ae7a1fca0414736d5987656185
    Partially-implements: blueprint vlan-aware-vms
    Partial-bug: #1623708

Changed in neutron:
assignee: Armando Migliaccio (armando-migliaccio) → Brian Haley (brian-haley)

Reviewed: https://review.openstack.org/376023
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=766fb5f252e8ac8d80167a6e70f99d4fc14a63b1
Submitter: Jenkins
Branch: stable/newton

commit 766fb5f252e8ac8d80167a6e70f99d4fc14a63b1
Author: rossella <email address hidden>
Date: Fri Sep 2 19:40:52 2016 +0200

    Handle add/remove subports events loss due to agent failures

    Upon restart the agent reconciles the logical with the physical
    state by removing/adding physical subports that are used to
    be/are current present in the logical view.

    This patch adds a functional test to demonstrate that there's
    no need to handle the resync in the trunk driver, since the ovs
    agent already takes care of it.

    Change-Id: I164153c79313f2ae7a1fca0414736d5987656185
    Partially-implements: blueprint vlan-aware-vms
    Partial-bug: #1623708
    (cherry picked from commit 08f2af18f996c9ec89ddb6554a1132aa9605b5af)

tags: added: in-stable-newton

Reviewed: https://review.openstack.org/375132
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=4148102f736f7191dd5bf1c2c41505c338c6dc56
Submitter: Jenkins
Branch: master

commit 4148102f736f7191dd5bf1c2c41505c338c6dc56
Author: Armando Migliaccio <email address hidden>
Date: Thu Sep 22 13:15:11 2016 -0700

    Process OVS trunk bridges associated to VM deletes

    If a VM is deleted while the OVS agent is down, upon
    restart the OVS trunk bridge is deleted successfully
    but the patch ports integration bridge side are left
    behind.

    This patch makes sure the bridge as well as its peers
    are cleaned up.

    Closes-bug: #1623708

    Change-Id: I3f010755fdb6501753d20357ad2cd0d6c02cf22a

Changed in neutron:
status: In Progress → Fix Released

Reviewed: https://review.openstack.org/377797
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=5514ba54ee9b2614444080da29230d9d7502cb5a
Submitter: Jenkins
Branch: stable/newton

commit 5514ba54ee9b2614444080da29230d9d7502cb5a
Author: Armando Migliaccio <email address hidden>
Date: Thu Sep 22 13:15:11 2016 -0700

    Process OVS trunk bridges associated to VM deletes

    If a VM is deleted while the OVS agent is down, upon
    restart the OVS trunk bridge is deleted successfully
    but the patch ports integration bridge side are left
    behind.

    This patch makes sure the bridge as well as its peers
    are cleaned up.

    Closes-bug: #1623708

    (cherry picked from commit 4148102f736f7191dd5bf1c2c41505c338c6dc56)

    Change-Id: I3f010755fdb6501753d20357ad2cd0d6c02cf22a

This issue was fixed in the openstack/neutron 9.0.0.0rc2 release candidate.

tags: removed: newton-rc-potential

This issue was fixed in the openstack/neutron 10.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints