SRIOV - PF / VM that assign to PF does not get vlan tag

Bug #1614092 reported by Eran Kuris on 2016-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Low
Unassigned
neutron
Undecided
Unassigned

Bug Description

During RFE testing Manage SR-IOV PFs as Neutron ports, I found VM booted with Neutron port vnic_type direct-physical but it does not get access to DHCP server.
The problem is that the PF / VM does not get VLAN tag with the internal vlan.
Workaround :
Enter to the VM via console and set vlan interface.

version RHOS 10
python-neutronclient-4.2.1-0.20160721230146.3b1c538.el7ost.noarch
openstack-neutron-common-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-fwaas-9.0.0-0.20160720211704.c3e491c.el7ost.noarch
openstack-neutron-metering-agent-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-openvswitch-9.0.0-0.20160726001729.6a23add.el7ost.noarch
puppet-neutron-9.1.0-0.20160725142451.4061b39.el7ost.noarch
python-neutron-lib-0.2.1-0.20160726025313.405f896.el7ost.noarch
openstack-neutron-ml2-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-sriov-nic-agent-9.0.0-0.20160726001729.6a23add.el7ost.noarch

tags: added: sriov-pci-pt
Changed in neutron:
importance: Undecided → Low

Steps to repro would be nice.

Changed in neutron:
status: New → Confirmed
assignee: nobody → Moshe Levi (moshele)

@Moshe: any chance you can triage?

Moshe Levi (moshele) wrote :

Ok, In SR-IOV the vlan tagging is done by libvirt so this may be a nova bug.
I will add this bug to the SR-IOV meeting agenda

Thanks Moshe!!

Changed in neutron:
status: Confirmed → Invalid
assignee: Moshe Levi (moshele) → nobody
Changed in nova:
status: New → Confirmed
importance: Undecided → Low
Changed in neutron:
importance: Low → Undecided
Eran Kuris (ekuris) wrote :

Steps to Reproduce:
1.deploy SRIOV env
2.create port vnic type : direct- physical
3. boot vm
4. the vm is active but no iP addres - no connectivity to DHCP server

Moshe Levi (moshele) wrote :

@Eran,

Please discard my previous comment.
It is not possible do config the vlan because you pass all the PF to the guest.
The you should create the vlan by himself or cloud init.
I am not aware of easy solution for this.

Changed in nova:
status: Confirmed → Won't Fix
status: Won't Fix → Incomplete
Moshe Levi (moshele) on 2016-08-22
Changed in nova:
status: Incomplete → Confirmed
Matt Riedemann (mriedem) wrote :

Isn't this issue what this blueprint in nova is aiming to fix?

https://blueprints.launchpad.net/nova/+spec/sriov-pf-passthrough-neutron-port-vlan

ofer blaut (oblaut) wrote :

yes, seems like the bug was opened few weeks before the blueprint was suggested.

We can mark it as resolved in Ocata

As noted, this is resolved in Ocata. There is an issue with this currently but that's being tracked in #1743458

Changed in nova:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers