SRIOV- when numvfs=0 SRIOV agent is failed to start

Bug #1614086 reported by Eran Kuris on 2016-08-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Low
edan david

Bug Description

Deployed SRIOV ENV with X VFs (for example 4 ). After that I wanted to move the VFs.
When setting SRIOV system with numvfs=0 and restart SRIOV agent it failed to start
# echo 0> sys/class/net/enp5s0f1/device/sriov_numvfs
# systemctl restart neutron-sriov-nic-agent
# systemctl status neutron-sriov-nic-agent

version - RHOS10
python-neutron-lbaas-9.0.0-0.20160722053816.0c73910.el7ost.noarch
python-neutronclient-4.2.1-0.20160721230146.3b1c538.el7ost.noarch
openstack-neutron-common-9.0.0-0.20160726001729.6a23add.el7ost.noarch
python-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-fwaas-9.0.0-0.20160720211704.c3e491c.el7ost.noarch
openstack-neutron-metering-agent-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-openvswitch-9.0.0-0.20160726001729.6a23add.el7ost.noarch
puppet-neutron-9.1.0-0.20160725142451.4061b39.el7ost.noarch
python-neutron-lib-0.2.1-0.20160726025313.405f896.el7ost.noarch
python-neutron-fwaas-9.0.0-0.20160720211704.c3e491c.el7ost.noarch
openstack-neutron-lbaas-9.0.0-0.20160722053816.0c73910.el7ost.noarch
openstack-neutron-ml2-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-9.0.0-0.20160726001729.6a23add.el7ost.noarch
openstack-neutron-sriov-nic-agent-9.0.0-0.20160726001729.6a23add.el7ost.noarch

attached the log file

Eran Kuris (ekuris) wrote :

@Moshe: any chance you can triage?

Changed in neutron:
status: New → Confirmed
assignee: nobody → Moshe Levi (moshele)
importance: Undecided → High
Moshe Levi (moshele) wrote :

Sure I will try to reproduce it tomorrow

Thanks Moshe!!

Moshe Levi (moshele) wrote :

@Eran,
When doing direct-physical you don't need to configure the PF in physical_device_mappings
https://github.com/openstack/neutron/blob/master/neutron/plugins/ml2/drivers/mech_sriov/agent/common/config.py#L63-L73. This is because we are not using the SR-IOV agent for that vnic_type
see https://github.com/openstack/neutron/blob/master/neutron/plugins/ml2/drivers/mech_sriov/mech_driver/mech_driver.py#L116-L128.

I can remove the validation in the agent, but I don't see added value in doing that.

@Armando,
Can you reduce the Importance to Low

Changed in neutron:
status: Confirmed → Incomplete
Eran Kuris (ekuris) wrote :

@Moshe
I understand you but I am still thinking the it usability bug that we suppose to prevent from the user to config something that can fail the agent.

It's downgraded to low because there's a workaround.

Changed in neutron:
importance: High → Low
Moshe Levi (moshele) wrote :

Ok we will fix it

Fix proposed to branch: master
Review: https://review.openstack.org/357244

Changed in neutron:
assignee: Moshe Levi (moshele) → edan david (edand)
status: Incomplete → In Progress
Changed in neutron:
assignee: edan david (edand) → Moshe Levi (moshele)
edan david (edand) on 2016-08-24
Changed in neutron:
assignee: Moshe Levi (moshele) → edan david (edand)

Reviewed: https://review.openstack.org/357244
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=f2b33b67272962abd7d6e61ab3d2b7aca3428dc5
Submitter: Jenkins
Branch: master

commit f2b33b67272962abd7d6e61ab3d2b7aca3428dc5
Author: Edan David <email address hidden>
Date: Thu Aug 18 16:56:56 2016 +0300

    Allow SR-IOV agent to start when number of vf is 0

    Remove number of vf validation from scan_vf_devices method
    in the eswitch manager module, to allow the SR-IOV agent
    to load when using PF passthrough.

    Closes-Bug: #1614086

    Change-Id: Iff5bf3a5542d5b19f45637e954a72a14402a30ae

Changed in neutron:
status: In Progress → Fix Released

This issue was fixed in the openstack/neutron 9.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/367153
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=51246525d7ebe38e0b6baa87ea4847968e254d48
Submitter: Jenkins
Branch: stable/mitaka

commit 51246525d7ebe38e0b6baa87ea4847968e254d48
Author: Edan David <email address hidden>
Date: Thu Aug 18 16:56:56 2016 +0300

    Allow SR-IOV agent to start when number of vf is 0

    Remove number of vf validation from scan_vf_devices method
    in the eswitch manager module, to allow the SR-IOV agent
    to load when using PF passthrough.

    Closes-Bug: #1614086

    Change-Id: Iff5bf3a5542d5b19f45637e954a72a14402a30ae
    (cherry picked from commit f2b33b67272962abd7d6e61ab3d2b7aca3428dc5)

tags: added: in-stable-mitaka

This issue was fixed in the openstack/neutron 8.3.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments