No router namespace after creating legacy router

Bug #1574092 reported by Inessa Vasilevskaya on 2016-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
High
Inessa Vasilevskaya

Bug Description

In case there are some temporary MQ connectivity problems during router creation, notification sent by l3_notifier via rpc cast gets lost. This leads to the absence of qrouter namespace on controllers.

The issue was first faced on mos HA (3 controllers) build - https://bugs.launchpad.net/mos/10.0.x/+bug/1529820

Changed in neutron:
assignee: nobody → Inessa Vasilevskaya (ivasilevskaya)
Changed in neutron:
status: New → In Progress
Brian Haley (brian-haley) wrote :

For some reason this didn't get updated with the review Id:

https://review.openstack.org/#/c/303823/

Changed in neutron:
importance: Undecided → Low

This bug is > 180 days without activity. We are unsetting assignee and milestone and setting status to Incomplete in order to allow its expiry in 60 days.

If the bug is still valid, then update the bug status.

Changed in neutron:
assignee: Inessa Vasilevskaya (ivasilevskaya) → nobody
status: In Progress → Incomplete

Wouldn't a period router resync help address the issue eventually?

Changed in neutron:
status: Incomplete → Confirmed
importance: Low → High
assignee: nobody → Inessa Vasilevskaya (ivasilevskaya)
tags: added: l3-ha

Change abandoned by Inessa Vasilevskaya (<email address hidden>) on branch: master
Review: https://review.openstack.org/303823
Reason: not worth the complexity introduced

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers