Fullstack tests do not configure root_helper, use the default of 'sudo'

Bug #1557168 reported by Assaf Muller
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Low
Ihar Hrachyshka

Bug Description

Fullstack tests should be similar to non-test environments, especially when it's easy. We should use rootwrap and rootwrap-daemon and not plain sudo.

Revision history for this message
Miguel Angel Ajo (mangelajo) wrote :

I agree, otherwise we would miss implications of working via rootwrap / rootwrap daemon.

Revision history for this message
Armando Migliaccio (armando-migliaccio) wrote :

This bug is > 180 days without activity. We are unsetting assignee and milestone and setting status to Incomplete in order to allow its expiry in 60 days.

If the bug is still valid, then update the bug status.

Changed in neutron:
assignee: Assaf Muller (amuller) → nobody
status: In Progress → Incomplete
tags: added: low-hanging-fruit
Changed in neutron:
status: Incomplete → Confirmed
Hunt Xu (huntxu)
Changed in neutron:
assignee: nobody → Hunt Xu (huntxu)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/459110

Changed in neutron:
status: Confirmed → In Progress
Changed in neutron:
assignee: Hunt Xu (huntxu) → Ihar Hrachyshka (ihar-hrachyshka)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/459110
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=927646e03a2b89c4e2e5de67e867b82e1b2d59ad
Submitter: Jenkins
Branch: master

commit 927646e03a2b89c4e2e5de67e867b82e1b2d59ad
Author: Hunt Xu <email address hidden>
Date: Sun Apr 23 22:02:40 2017 +0800

    Configure root_helper and root_helper_daemon in fullstack tests

    Fullstack tests are similar to non-test environments, so rootwrap and
    rootwrap-daemon should be used instead of plain sudo.

    L3 agents and DHCP agents used in fullstack tests should be guaranteed
    to be eventlet monkey patched to avoid race conditions when two threads
    are trying to issue commands via rootwrap daemon at the same time.

    Closes-Bug: #1557168

    Change-Id: Ida5a45420a8f58c1f5a36eb3fc546a7ea053a661
    Signed-off-by: Hunt Xu <email address hidden>

Changed in neutron:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to neutron (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/471097

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to neutron (master)

Reviewed: https://review.openstack.org/471097
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=a99897ffb3e3a1247006b21103b54a71123a6b50
Submitter: Jenkins
Branch: master

commit a99897ffb3e3a1247006b21103b54a71123a6b50
Author: Ihar Hrachyshka <email address hidden>
Date: Mon Jun 5 18:54:39 2017 +0000

    Use rootwrap for fullstack test runner

    We plan to switch to devstack-gate for fullstack job, and it revokes
    direct sudo calls before executing tests, so we can't rely on sudo
    working anymore.

    This also moves functional-testing.filters to a more generic filename
    (testing.filters) because the filters are now deployed and used by
    fullstack target too.

    Related-Bug: #1557168
    Related-Bug: #1693689

    Change-Id: I1718ea51836adbb8ef8dea79822a722dcf111127

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/neutron 11.0.0.0b2

This issue was fixed in the openstack/neutron 11.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers