stable tarball contains master version

Bug #1519750 reported by Bernhard M. Wiedemann on 2015-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
High
Kyle Mestery

Bug Description

somewhat similar to https://bugs.launchpad.net/aodh/+bug/1515507

curl -s http://tarballs.openstack.org/neutron/neutron-stable-kilo.tar.gz|tar vzt |head -5
drwxrwxr-x jenkins/jenkins 0 2015-11-24 22:46 neutron-8.0.0.dev486/
drwxrwxr-x jenkins/jenkins 0 2015-11-24 22:46 neutron-8.0.0.dev486/releasenotes/
drwxrwxr-x jenkins/jenkins 0 2015-11-24 22:46 neutron-8.0.0.dev486/releasenotes/source/
-rw-rw-r-- jenkins/jenkins 146 2015-11-24 22:44 neutron-8.0.0.dev486/releasenotes/source/liberty.rst
drwxrwxr-x jenkins/jenkins 0 2015-11-24 22:46 neutron-8.0.0.dev486/releasenotes/source/_static/

yesterday it still contained the correct neutron-2015.1.3.dev52

Kyle Mestery (mestery) wrote :

This happens for liberty as well:

Kyles-MacBook-Pro-3:crap mestery$ tar tvzf neutron-stable-liberty.tar.gz | head -5
drwxrwxr-x 0 jenkins jenkins 0 Nov 24 21:59 neutron-8.0.0.dev488/
drwxrwxr-x 0 jenkins jenkins 0 Nov 24 21:59 neutron-8.0.0.dev488/releasenotes/
drwxrwxr-x 0 jenkins jenkins 0 Nov 24 21:59 neutron-8.0.0.dev488/releasenotes/source/
-rw-rw-r-- 0 jenkins jenkins 146 Nov 24 21:58 neutron-8.0.0.dev488/releasenotes/source/liberty.rst
drwxrwxr-x 0 jenkins jenkins 0 Nov 24 21:59 neutron-8.0.0.dev488/releasenotes/source/_static/
Kyles-MacBook-Pro-3:crap mestery$

However, for Juno, it's ok:

Kyles-MacBook-Pro-3:crap mestery$ tar tvzf neutron-stable-juno.tar.gz | head -5
drwxrwxr-x 0 jenkins jenkins 0 Nov 2 16:18 neutron-2014.2.4.dev106/
-rw-rw-r-- 0 jenkins jenkins 369 Nov 2 16:17 neutron-2014.2.4.dev106/MANIFEST.in
drwxrwxr-x 0 jenkins jenkins 0 Nov 2 16:18 neutron-2014.2.4.dev106/neutron.egg-info/
-rw-rw-r-- 0 jenkins jenkins 47 Nov 2 16:18 neutron-2014.2.4.dev106/neutron.egg-info/pbr.json
-rw-rw-r-- 0 jenkins jenkins 6248 Nov 2 16:18 neutron-2014.2.4.dev106/neutron.egg-info/entry_points.txt
Kyles-MacBook-Pro-3:crap mestery$

This is because Juno hasn't been updated for a while, so something is definitely messing with these.

Changed in neutron:
assignee: nobody → Kyle Mestery (mestery)
status: New → Confirmed
importance: Undecided → High
Kyle Mestery (mestery) wrote :

According to channel logs [1] in #openstack-infra, this may be an infra issue related to this patch [2].

[1] http://eavesdrop.openstack.org/irclogs/%23openstack-infra/%23openstack-infra.2015-11-25.log.html#t2015-11-25T15:03:44
[2] https://review.openstack.org/#/c/247306/

seems to be fixed for libery already which contains neutron-7.0.1.dev118 today.
So chances are, it will be good after the next Kilo update.

Kyle Mestery (mestery) wrote :

Addressed and fixed by this review [1].

[1] https://review.openstack.org/249986

Changed in neutron:
status: Confirmed → Fix Released
milestone: none → mitaka-1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers