API tests skipped at the gate

Bug #1518632 reported by Assaf Muller on 2015-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Critical
Ihar Hrachyshka

Bug Description

The tests are skipped with 'SKIPPED: Neutron support is required'.

We've been skipping the tests because of https://review.openstack.org/#/c/244259/.

That patch was reverted here: https://review.openstack.org/#/c/244277/,
and then reverted again: https://review.openstack.org/#/c/244520/, and ever since (The 13th) we've been skipping the API tests.

Assaf Muller (amuller) wrote :

But I also see the tests being run successfully sometimes after the 11th. No pattern detected yet.

Assaf Muller (amuller) wrote :
Assaf Muller (amuller) wrote :

Looks like that patch was reverted here: https://review.openstack.org/#/c/244277/,
and then reverted again: https://review.openstack.org/#/c/244520/, and ever since (The 13th) we've been skipping the API tests.

description: updated
Henry Gessau (gessau) on 2015-11-21
Changed in neutron:
status: New → Confirmed
milestone: none → mitaka-1
Changed in neutron:
assignee: nobody → Ihar Hrachyshka (ihar-hrachyshka)

Fix proposed to branch: master
Review: https://review.openstack.org/249234

Changed in neutron:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/249234
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=143b3dc2864bec1f92eeed44a351e420ae68fd58
Submitter: Jenkins
Branch: master

commit 143b3dc2864bec1f92eeed44a351e420ae68fd58
Author: Ihar Hrachyshka <email address hidden>
Date: Tue Nov 24 15:13:00 2015 +0100

    tox: pass TEMPEST_CONFIG_DIR envvar into api target environment

    Currently, API job skips all tests because TEMPEST_CONFIG_DIR is not set
    properly. The environment variable was hardcoded to
    /opt/stack/tempest/etc before, and since that's the location for tempest
    configuration files that was used in gate, it worked fine there.

    But after we were forced to remove the hardcoded value from the file due
    to regression in tox 2.2.0+ (If3742b6eabe295a5aaeb4901c55909a70c451698),
    it was neither hardcoded, nor passed from the external gate environment.

    Note that since tox 2.0.0, the tool does not pass all envvars into tox
    targets, but require explicit specification of the list of variables
    that should be allowed into the target environment, using passenv
    directive.

    So that's what the patch does: it allows TEMPEST_CONFIG_DIR to get into
    api tox target, which should be enough to make the API job avoid
    skipping all tests.

    Users are still required to set TEMPEST_CONFIG_DIR variable locally if
    they want to execute the suite locally.

    Closes-Bug: #1518632
    Change-Id: Ia7dcc6785390a6012c7ba16a14573aa44f2b6fb5

Changed in neutron:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/249383
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=80aa77be9833898b2ab8f44d084b4731fa4e8daf
Submitter: Jenkins
Branch: stable/kilo

commit 80aa77be9833898b2ab8f44d084b4731fa4e8daf
Author: Ihar Hrachyshka <email address hidden>
Date: Tue Nov 24 15:13:00 2015 +0100

    tox: pass TEMPEST_CONFIG_DIR envvar into api target environment

    Currently, API job skips all tests because TEMPEST_CONFIG_DIR is not set
    properly. The environment variable was hardcoded to
    /opt/stack/tempest/etc before, and since that's the location for tempest
    configuration files that was used in gate, it worked fine there.

    But after we were forced to remove the hardcoded value from the file due
    to regression in tox 2.2.0+ (If3742b6eabe295a5aaeb4901c55909a70c451698),
    it was neither hardcoded, nor passed from the external gate environment.

    Note that since tox 2.0.0, the tool does not pass all envvars into tox
    targets, but require explicit specification of the list of variables
    that should be allowed into the target environment, using passenv
    directive.

    So that's what the patch does: it allows TEMPEST_CONFIG_DIR to get into
    api tox target, which should be enough to make the API job avoid
    skipping all tests.

    Users are still required to set TEMPEST_CONFIG_DIR variable locally if
    they want to execute the suite locally.

    Conflicts:
     tox.ini

    Closes-Bug: #1518632
    Change-Id: Ia7dcc6785390a6012c7ba16a14573aa44f2b6fb5
    (cherry picked from commit 143b3dc2864bec1f92eeed44a351e420ae68fd58)

tags: added: in-stable-kilo
tags: added: in-stable-liberty

Reviewed: https://review.openstack.org/249382
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=4104187cb5bfdfcb091afe6a26954633c74f08cb
Submitter: Jenkins
Branch: stable/liberty

commit 4104187cb5bfdfcb091afe6a26954633c74f08cb
Author: Ihar Hrachyshka <email address hidden>
Date: Tue Nov 24 15:13:00 2015 +0100

    tox: pass TEMPEST_CONFIG_DIR envvar into api target environment

    Currently, API job skips all tests because TEMPEST_CONFIG_DIR is not set
    properly. The environment variable was hardcoded to
    /opt/stack/tempest/etc before, and since that's the location for tempest
    configuration files that was used in gate, it worked fine there.

    But after we were forced to remove the hardcoded value from the file due
    to regression in tox 2.2.0+ (If3742b6eabe295a5aaeb4901c55909a70c451698),
    it was neither hardcoded, nor passed from the external gate environment.

    Note that since tox 2.0.0, the tool does not pass all envvars into tox
    targets, but require explicit specification of the list of variables
    that should be allowed into the target environment, using passenv
    directive.

    So that's what the patch does: it allows TEMPEST_CONFIG_DIR to get into
    api tox target, which should be enough to make the API job avoid
    skipping all tests.

    Users are still required to set TEMPEST_CONFIG_DIR variable locally if
    they want to execute the suite locally.

    Closes-Bug: #1518632
    Change-Id: Ia7dcc6785390a6012c7ba16a14573aa44f2b6fb5
    (cherry picked from commit 143b3dc2864bec1f92eeed44a351e420ae68fd58)

Reviewed: https://review.openstack.org/249448
Committed: https://git.openstack.org/cgit/openstack/neutron-lbaas/commit/?id=e2d0ffc25aeffc3c125f919166b5a0102af49f08
Submitter: Jenkins
Branch: master

commit e2d0ffc25aeffc3c125f919166b5a0102af49f08
Author: armando-migliaccio <email address hidden>
Date: Tue Nov 24 13:56:47 2015 -0800

    Allow API tests to run in the gate

    For more info, check [1].

    [1] Ia7dcc6785390a6012c7ba16a14573aa44f2b6fb5

    Related-bug: 1518632

    Change-Id: I89ef8117209357265667f8ace4ea6ab2c998ee0c
    Co-authored-by: Ihar Hrachyshka <email address hidden>

Reviewed: https://review.openstack.org/249487
Committed: https://git.openstack.org/cgit/openstack/neutron-lbaas/commit/?id=4922f963409c345be997706c56d395feccae771d
Submitter: Jenkins
Branch: stable/liberty

commit 4922f963409c345be997706c56d395feccae771d
Author: armando-migliaccio <email address hidden>
Date: Tue Nov 24 13:56:47 2015 -0800

    Allow API tests to run in the gate

    For more info, check [1].

    [1] Ia7dcc6785390a6012c7ba16a14573aa44f2b6fb5

    Related-bug: 1518632

    (cherry picked from commit e2d0ffc25aeffc3c125f919166b5a0102af49f08)

    Change-Id: I89ef8117209357265667f8ace4ea6ab2c998ee0c
    Co-authored-by: Ihar Hrachyshka <email address hidden>

This issue was fixed in the openstack/neutron 8.0.0.0b1 development milestone.

Changed in neutron:
status: Fix Committed → Fix Released

This issue was fixed in the openstack/neutron 7.0.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers