neutron.tests.unit.debug.test_shell.ShellTest.test_endpoint_option fails due to neutronclient change

Bug #1517579 reported by Amir Sadoughi
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Manjeet Singh Bhatia

Bug Description

This failure is a result of https://review.openstack.org/#/c/236325/ renaming the endpoint option default from publicURL to public. However this hasn't affected upstream CI yet because this code is newer than the 3.1.0 release.

======================================================================
FAIL: neutron.tests.unit.debug.test_shell.ShellTest.test_endpoint_option
neutron.tests.unit.debug.test_shell.ShellTest.test_endpoint_option
----------------------------------------------------------------------
_StringException: Empty attachments:
  pythonlogging:''
  pythonlogging:'neutron.api.extensions'
  stderr
  stdout

Traceback (most recent call last):
  File "neutron/tests/unit/debug/test_shell.py", line 94, in test_endpoint_option
    self.assertEqual('publicURL', namespace.os_endpoint_type)
  File "/home/jenkins/workspace/Merge-neutron-Ply/virtualenv/local/lib/python2.7/site-packages/testtools/testcase.py", line 350, in assertEqual
    self.assertThat(observed, matcher, message)
  File "/home/jenkins/workspace/Merge-neutron-Ply/virtualenv/local/lib/python2.7/site-packages/testtools/testcase.py", line 435, in assertThat
    raise mismatch_error
testtools.matchers._impl.MismatchError: 'publicURL' != 'public'

Changed in neutron:
assignee: nobody → Manjeet Singh Bhatia (manjeet-s-bhatia)
Revision history for this message
Manjeet Singh Bhatia (manjeet-s-bhatia) wrote :

I tried this test with new python - neutronclient installed on my machine. this test passed
any thing am I doing wrong ?

Revision history for this message
Gary Kotton (garyk) wrote :

The lines:
        namespace = parser.parse_args([])
        self.assertEqual('publicURL', namespace.os_endpoint_type)
Are what are problematic.

Consider checking if the namespace.os_endpoint_type is either 'public' or 'publicURL'

Changed in neutron:
importance: Undecided → Medium
status: New → Confirmed
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/247661

Changed in neutron:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/247661
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=661f1b5e8019f3c2521208925b833f2d9113cce7
Submitter: Jenkins
Branch: master

commit 661f1b5e8019f3c2521208925b833f2d9113cce7
Author: Manjeet Singh Bhatia <email address hidden>
Date: Thu Nov 19 15:51:05 2015 +0000

    Fix the end point test for client

    Due to recent change in neutronclient the endpoint value got changes
    in following patch.

    https://review.openstack.org/#/c/236325/

    This patch will test both public or publicURL endpoints.

    Change-Id: I0dffb06c5151203e9fe2ab041a7beb028a39aac0
    Closes-bug: #1517579

Changed in neutron:
status: In Progress → Fix Committed
Changed in neutron:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers