VPNaaS: Modify neutron API users to detect multiple local subnet feature

Bug #1515670 reported by Paul Michali
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Fix Released
High
Akihiro Motoki

Bug Description

In review of 231133, Akihiro mentioned follow up work for the neutron API consumers, so that Horizon can detect whether or not the new multiple local subnet feature, with endpoint groups, is available.

At the moment, multiple local subnet feature has been implemented in VPNaaS API, but API consumers need to try VPNaaS API to detect multiple local subnet feature is available or not. It is better to detect the feature without trying to call VPNaaS API.

The suggested approach is to add an extension which represents this feature.

Placeholder for that work.

Tags: vpnaas
Revision history for this message
Paul Michali (pcm) wrote :

I cant seem to figure out how to assign this to Akihiro. Maybe I don't have permissions.

Akihiro Motoki (amotoki)
Changed in neutron:
assignee: nobody → Akihiro Motoki (amotoki)
importance: Undecided → High
Gary Kotton (garyk)
no longer affects: neutron
Changed in python-neutronclient:
importance: Undecided → High
assignee: nobody → Akihiro Motoki (amotoki)
Revision history for this message
Akihiro Motoki (amotoki) wrote :

The original description was a bit confusing.
It is not directly to neutroncleint and it is related to neutron-vpnaas itself.
I will update the description.

summary: - VPNaaS: Modify neutron-client to allow Horizon to detect multiple local
- subnet feature
+ VPNaaS: Modify neutron API users to detect multiple local subnet feature
description: updated
affects: python-neutronclient → neutron
Changed in neutron:
status: New → Confirmed
Akihiro Motoki (amotoki)
Changed in neutron:
milestone: none → mitaka-2
Changed in neutron:
milestone: mitaka-2 → mitaka-1
Changed in neutron:
milestone: mitaka-1 → mitaka-2
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron-vpnaas (master)

Fix proposed to branch: master
Review: https://review.openstack.org/261109

Changed in neutron:
status: Confirmed → In Progress
Changed in neutron:
milestone: mitaka-2 → mitaka-3
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron-vpnaas (master)

Reviewed: https://review.openstack.org/261109
Committed: https://git.openstack.org/cgit/openstack/neutron-vpnaas/commit/?id=1afd7fc22acc36ae40af6b573940f02ea970a20f
Submitter: Jenkins
Branch: master

commit 1afd7fc22acc36ae40af6b573940f02ea970a20f
Author: Akihiro Motoki <email address hidden>
Date: Thu Dec 24 06:34:52 2015 +0900

    Make VPN endpoint groups aware from API

    There is no way to check whether the VPN endpoint groups feature
    is available without sending an API request at now.
    This commit split VPN endpoint groups feature as an extension.
    By doing so, API consumers including Horizon can know the feature
    is available through Neutron extension list API.

    Note that this commit touches only the API layer and does not
    touch the DB layer because the endpoint groups feature is
    the first citizen of VPNaaS API.

    Closes-Bug: #1515670
    Change-Id: I82a3ab60b5a50eee2b4a84b54829a323cd2b3fb1

Changed in neutron:
status: In Progress → Fix Released
Revision history for this message
Thierry Carrez (ttx) wrote : Fix included in openstack/neutron-vpnaas 8.0.0.0b3

This issue was fixed in the openstack/neutron-vpnaas 8.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers