Support keystone V3 API

Bug #1503428 reported by Kyle Mestery on 2015-10-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Henry Gessau

Bug Description

The python-neutronclient has keystone V3 support as of Juno [1], it's unclear if we need to do anything for the server. Filing this bug to track this so we don't forget to address this during Mitaka.

[1] https://github.com/openstack/neutron-specs/blob/master/specs/juno/keystone-v3-api-support.rst

tags: added: rfe
tags: added: oslo
Changed in neutron:
milestone: none → mitaka-1
importance: Undecided → Medium
Kyle Mestery (mestery) wrote :

Ihar, I don't think this needs an RFE tag according to my discussion with our PTL. Removing it for now unless Armando adds it back.

tags: removed: rfe

I am thinking that this should be treated as a regular bug. If Keystone v2 is being deprecated (or in the process to) it's best to get to v3 asap. I am not sure what conversation we'd need to have...it sounds like a no-brainer.

tags: added: needs-attention

We'd need someone who can verify what's the current status and do the work.

tags: added: low-hanging-fruit
Monty Taylor (mordred) wrote :

I'm working on this, it turns out.

Changed in neutron:
assignee: nobody → Monty Taylor (mordred)

Rock. On.

Changed in neutron:
status: New → Confirmed
Changed in neutron:
milestone: mitaka-1 → mitaka-2

Fix proposed to branch: master
Review: https://review.openstack.org/253782

Changed in neutron:
status: Confirmed → In Progress
Changed in neutron:
assignee: Monty Taylor (mordred) → Armando Migliaccio (armando-migliaccio)
Changed in neutron:
assignee: Armando Migliaccio (armando-migliaccio) → Morgan Fainberg (mdrnstm)
Changed in neutron:
assignee: Morgan Fainberg (mdrnstm) → Monty Taylor (mordred)
Changed in neutron:
assignee: Monty Taylor (mordred) → Akihiro Motoki (amotoki)
Changed in neutron:
assignee: Akihiro Motoki (amotoki) → Henry Gessau (gessau)

Reviewed: https://review.openstack.org/253782
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=9670dbd93ce7246282ca4343c3f701e8c20a232b
Submitter: Jenkins
Branch: master

commit 9670dbd93ce7246282ca4343c3f701e8c20a232b
Author: Monty Taylor <email address hidden>
Date: Fri Dec 4 23:54:22 2015 -0500

    Pull project out of request in addition to tenant

    Keystone V3 renamed tenant to project. In order to deal with keystone
    V3, start pulling X-Project-Id from the headers.

    Since keystonemiddleware authtoken sets both X-Project-* and
    X-Tenant-*, we don't need to look up X-Tenant-*.

    Don't do anything with renaming the internal variables - that will come
    later.

    Change-Id: I5e27cf6a54fb603b81d41b8b4f085d59354627fb
    Depends-On: I1f754a9a949ef92f4e427a91bbd1b1e73e86c8c4
    Closes-Bug: #1503428

Changed in neutron:
status: In Progress → Fix Released

This issue was fixed in the openstack/neutron 8.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints