RDNSS Option should be included in ICMPv6 Router Advertisements

Bug #1495465 reported by Tore Anderson on 2015-09-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Low
Sridhar Gaddam
Nominated for Mitaka by Sean M. Collins

Bug Description

The ICMPv6 Router Advertisements on an IPv6 subnet handled by Neutron does not contain the Recursive DNS Server Option, even though the subnet has been created with an appropriate "dns_nameservers" parameter. This means that instances on a subnet using SLAAC does not learn any DNS servers, and thus cannot resolve any hostnames after being provisioned. That is likely to break lots of things, such as further provisioning of applications to the instance.

The RDNSS option is documented in RFC 6106. It can be configured in radvd.conf using the following syntax:

interface qr-foo {
  RDNSS server1 [server2 ...] {
    # this is optional, but prevents problems noted in the second bullet of
    # https://tools.ietf.org/html/draft-ietf-6man-rdnss-rfc6106bis-02#appendix-B
    AdvRDNSSLifetime infinity;
  };
};

Observed on OpenStack Kilo.

Note: It might be that using DHCPv6 in some capacity would work around this issue. I have not yet tested this, though.

Sean M. Collins (scollins) wrote :

Confirming this - I think this is something we need to add to our radvd orchestration code.

Changed in neutron:
status: New → Confirmed
tags: added: ipv6
Changed in neutron:
assignee: nobody → Sridhar Gaddam (sridhargaddam)

Fix proposed to branch: master
Review: https://review.openstack.org/236805

Changed in neutron:
status: Confirmed → In Progress
Sean M. Collins (scollins) wrote :

Adding this to Mitaka-1 since there is a patch up for this, and it's a relatively simple change to implement this feature.

Changed in neutron:
importance: Undecided → Medium
milestone: none → mitaka-1
Changed in neutron:
importance: Medium → Low

Reviewed: https://review.openstack.org/236805
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=a3e102934cee01c14d5327ae7520555bc12affdd
Submitter: Jenkins
Branch: master

commit a3e102934cee01c14d5327ae7520555bc12affdd
Author: sridhargaddam <email address hidden>
Date: Mon Oct 19 05:32:16 2015 +0000

    Support for IPv6 RDNSS Option in Router Advts

    RFC6106 standardizes IPv6 Router Advertisements to support
    Recursive DNS server information. RDNSS info allows an IPv6
    host to configure the DNS information via RA messages without
    needing DHCPv6 for the DNS configuration.

    This patch configures RADVD daemon to include RDNSS entries in
    the Router Advertisements when the IPv6 subnet has dns_nameservers.

    Closes-Bug: #1495465
    Change-Id: Ia516d40b1c7a83cd7046b2b7f42d1204f44288a9

Changed in neutron:
status: In Progress → Fix Committed
Changed in neutron:
status: Fix Committed → Fix Released

FYI: Probably not backportable since it requires specific version of radvd (1.8+).

Sridhar Gaddam (sridhargaddam) wrote :

@Ihar, radvd seems to have RDNSS support since a long time - http://www.litech.org/radvd/

This issue was fixed in the openstack/neutron 8.0.0.0b2 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers