Agent terminates services when turning admin_state_up False

Bug #1408488 reported by Itsuro Oda on 2015-01-07
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
neutron
High
Itsuro Oda

Bug Description

Currently turning admin_state_up of a dhcp/l3 agent to False causes stopping all services on it.
Admin_state_up should be affected only scheduling and should not terminate existing services.

Itsuro Oda (oda-g) wrote :

If blueprint is appropriate for fixing this problem, please let me know.
Anyway, I will make a fix with keeping current behavior available.

tags: added: l3-ipam-dhcp
Changed in neutron:
assignee: nobody → Itsuro Oda (oda-g)
Carl Baldwin (carl-baldwin) wrote :

I was going to describe how I thought this should be done here. However, I just read Jack McCann's description on the ML [1]. It meets or exceeds what I would have put here.

[1] http://lists.openstack.org/pipermail/openstack-dev/2015-January/054007.html

Changed in neutron:
importance: Undecided → High
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/147032

Changed in neutron:
status: Confirmed → In Progress
Itsuro Oda (oda-g) wrote :

Root cause of this problem is that RPC of get information from agents (get_active_networks/sync_routers) does not return resources on agents with admin_state_up False.
I fixed this simply. I think there is no bad effect for existing functions by this change.
To keep current behavior available I added config parameters to select behavior.
I don't prefer the serious matter such as API addition to fix this problem.

Kyle Mestery (mestery) on 2015-03-25
Changed in neutron:
milestone: none → kilo-rc1

Reviewed: https://review.openstack.org/147032
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=766c2738ae16ebbae37f26b17e261f0112616bb5
Submitter: Jenkins
Branch: master

commit 766c2738ae16ebbae37f26b17e261f0112616bb5
Author: Itsuro Oda <email address hidden>
Date: Fri Jan 9 08:47:56 2015 +0900

    Enable services on agents with admin_state_up False

    Previously when admin_state_up of an agent is turned to False,
    all services on it will be disabled.
    This fix makes existing services on agents with admin_state_up
    False keep available.
    To keep current behavior available the following configuration
    parameter added.

    * enable_services_on_agents_with_admin_state_down

    If the parameter is True, existing services on agents with admin_state_up
    False keep available. No more service will be scheduled to the agent
    automatically. But adding a service to the agent manually is available.
    i.e. admin_state_up: False means to stop automatic scheduling under the
    parameter is True.
    The default of the parameter is False (current behavior).

    Change-Id: Ifba606a5c1f3f07d717c7695a7a64e16238c2057
    Closes-Bug: #1408488

Changed in neutron:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-04-09
Changed in neutron:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in neutron:
milestone: kilo-rc1 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers