remove XML support

Bug #1380787 reported by Mark McClain
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Fix Released
High
Mark McClain
python-neutronclient
Fix Released
High
Elena Ezhova

Bug Description

XML support has been deprecated for Icehouse[1] and Juno[2]. It is time to remove it in Kilo.

[1] https://wiki.openstack.org/wiki/ReleaseNotes/Icehouse#Upgrade_Notes_6
[2] https://wiki.openstack.org/wiki/ReleaseNotes/Juno#Upgrade_Notes_6

Revision history for this message
Kyle Mestery (mestery) wrote :

Looking forward to this landing early in Kilo.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/128095

Revision history for this message
Wei Wang (damon-devops) wrote :

The CIs not friendly to this patch :-)

Revision history for this message
Mark McClain (markmcclain) wrote :

@damon-devops: Correct once Juno is released we'll be updating devstack and tempest to make it pass CI.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/128095
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=1b4ad95758c6cff7bc9a461f445c4b4e67964434
Submitter: Jenkins
Branch: master

commit 1b4ad95758c6cff7bc9a461f445c4b4e67964434
Author: Mark McClain <email address hidden>
Date: Mon Oct 13 20:38:43 2014 +0000

    Remove XML support

    XML support in Neutron has always been a second class feature to the
    JSON API and broken for many extensions and outputs. The XML API been marked as
    deprecated for the Icehouse and Juno release and is ready for removal in
    Kilo.

    Change-Id: I611aa9382ba3bfb08b2970c63e83b0fdd3d2e8a4
    Closes-Bug: #1380787

Changed in neutron:
status: In Progress → Fix Committed
Revision history for this message
Elena Ezhova (eezhova) wrote :

As XML support has been removed in Neutron, should not the same be done for neutronclient?

Elena Ezhova (eezhova)
Changed in python-neutronclient:
assignee: nobody → Elena Ezhova (eezhova)
Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :

Wait, I don't think we should drop that feature in client. It's supposed to be backwards compatible, no?

Elena Ezhova (eezhova)
no longer affects: python-neutronclient
Revision history for this message
Elena Ezhova (eezhova) wrote :

In this case, for how long should python-neutronclient support XML? Couldn't someone who wants to use neutron with XML support (Juno or older) simply specify the older version of neutronclient?

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to neutron (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/141785

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix merged to neutron (master)

Reviewed: https://review.openstack.org/141785
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=d481cdd3d9ea07a31c2480286d9b7f247049ba5d
Submitter: Jenkins
Branch: master

commit d481cdd3d9ea07a31c2480286d9b7f247049ba5d
Author: Elena Ezhova <email address hidden>
Date: Mon Dec 15 15:44:34 2014 +0300

    Cleanup req_format in test_api_v2_resource

    Since XML support has been removed test cases in test_api_v2_resource
    no longer need to specify req_format.

    Change-Id: Ic6572abc3121535e19d21e9a34d70bb42b9782de
    Related-Bug: #1380787

Thierry Carrez (ttx)
Changed in neutron:
status: Fix Committed → Fix Released
Revision history for this message
Oleg Bondarev (obondarev) wrote :

@Ihar, I'm not sure what's the point of supporting XML in client while it's not supported by server. I think the bug should affect client as well.

Elena Ezhova (eezhova)
Changed in python-neutronclient:
assignee: nobody → Elena Ezhova (eezhova)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Related fix proposed to python-neutronclient (master)

Related fix proposed to branch: master
Review: https://review.openstack.org/144439

Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :

@Oleg, clients do not have stable branches and target multiple versions of neutron from the same code base.

Revision history for this message
Oleg Bondarev (obondarev) wrote :

@Ihar, I see, thanks for clarification. Then when do you think we can remove XML support from client? Also do you think it's a common use case when someone updates neutron client while not updating neutron server? What might be the motivation behind this?

I'm not sure about the policy here: should neutron client be backward compatible with all versions of neutron server? I doubt it is so at the moment. I'd like we have more opinions on this.

Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :

In theory, we should be fully backwards compatible. Of course it's not realistic to expect client to maintain backwards compatibility for eternity, so we should probably work on setting some explicit expectations, if not already.

I believe that at the very least, clients should support all supported versions (currently Icehouse, Juno, plus master). XML server support is dropped in master only, right? So this will need to wait.

There are multiple reasons why users may want to bump their client version without updating server. First, they may be just cloud users and are not in charge of server at all. Users may also get client update thru repositories of their distribution of choice. They may also be interested in interacting with multiple clouds of different server versions with the same client.

Revision history for this message
Elena Ezhova (eezhova) wrote :

@Ihar, thanks for clarifying your position, it much sense for me now! So, if I understood you correctly, XML removal would have to wait till M release. If that is so, I'll abandon the change for now.

Revision history for this message
Elena Ezhova (eezhova) wrote :

*it makes much sense

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Change abandoned on python-neutronclient (master)

Change abandoned by Elena Ezhova (<email address hidden>) on branch: master
Review: https://review.openstack.org/144439
Reason: As was decided in comments on the bug, this change would have to wait.

Revision history for this message
Ihar Hrachyshka (ihar-hrachyshka) wrote :

I don't know whether M will be a good fit either. It's just the earliest time possible to drop it without breaking gate. Further discussion is needed on whether it may be applied in M or will need to wait for another cycle or two.

Thierry Carrez (ttx)
Changed in neutron:
milestone: kilo-1 → 2015.1.0
Revision history for this message
Akihiro Motoki (amotoki) wrote :

In neutronclient side, it is important but we need to have a consensus on time to drop XML support.

Changed in python-neutronclient:
status: New → Confirmed
importance: Undecided → High
Revision history for this message
Elena Ezhova (eezhova) wrote :

If there is a consensus, I'll continue the work I started two cycles ago.

Revision history for this message
Akihiro Motoki (amotoki) wrote :

According to the thread http://lists.openstack.org/pipermail/openstack-dev/2015-December/thread.html#81266
we can drop XML support from neutornclient now.
If we don't have an reasonable objection in one or two days , let's start.

Changed in python-neutronclient:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to python-neutronclient (master)

Reviewed: https://review.openstack.org/144439
Committed: https://git.openstack.org/cgit/openstack/python-neutronclient/commit/?id=54a4aea969fe06422f64005652ce23ac7b616d98
Submitter: Jenkins
Branch: master

commit 54a4aea969fe06422f64005652ce23ac7b616d98
Author: Elena Ezhova <email address hidden>
Date: Fri Dec 4 16:45:47 2015 +0300

    Remove XML support

    As XML support has been removed from neutron, there is no need
    to keep it in client.

    Dropped XML serializer and deserializer and deprecated "request-format"
    CLI option, making JSON the default and the only supported request
    format.

    DocImpact

    Change-Id: I88b0fdd65a649694252d5ff43a174e75026df5b1
    Closes-Bug: #1380787

Changed in python-neutronclient:
status: In Progress → Fix Released
Revision history for this message
Doug Hellmann (doug-hellmann) wrote : Fix included in openstack/python-neutronclient 4.0.0

This issue was fixed in the openstack/python-neutronclient 4.0.0 release.

Akihiro Motoki (amotoki)
Changed in python-neutronclient:
milestone: none → 4.0.0
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers