StaleDataError while updating ml2_dvr_port_bindings

Bug #1372141 reported by Armando Migliaccio on 2014-09-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Unassigned
Changed in neutron:
assignee: nobody → Armando Migliaccio (armando-migliaccio)
Changed in neutron:
importance: Undecided → Medium
description: updated
Changed in neutron:
status: New → Confirmed
Shiv Haris (shh) on 2014-10-15
Changed in neutron:
milestone: none → kilo-1
Wei Wang (damon-devops) wrote :

Is this related with bug #1381536?

Kyle Mestery (mestery) on 2014-12-16
Changed in neutron:
milestone: kilo-1 → kilo-2

@Wei Wang: there are multiple issues that manifest themselves in the same way, so the traceback can be the same, but the underlying problem may be different.

If my understanding is correct, this issue manifests itself when there is an interleaving router delete while binding a port:

An analysis from the logs [1] revealed these sequence of actions:

It's shown that this issue manifests itself when:

a) _ensure_host_set_on_ports is called on a router (in the example: 9706e742-84e2-4fed-b040-c577dd5622cb)
b) the router is deleted shortly after (in around 2014-12-24_00_40_32_020)
c) ports get disposed
d) the bind operations comes afterwards (in around 2014-12-24_00_40_32_607)

[1] http://logs.openstack.org/76/134676/13/check/check-tempest-dsvm-neutron-dvr/caa7479/logs/screen-q-svc.txt.gz?#_2014-12-24_00_40_31_113

Fix proposed to branch: master
Review: https://review.openstack.org/143761

Changed in neutron:
status: Confirmed → In Progress
Kyle Mestery (mestery) on 2015-02-03
Changed in neutron:
milestone: kilo-2 → kilo-3

It's likely that https://review.openstack.org/#/c/151913/ killed the issue

Changed in neutron:
status: In Progress → Incomplete
milestone: kilo-3 → none

It can no longer be verified.

Zengfa Gao (zfgao) wrote :

For bug 1398446, we saw StaleDataError with ml2_dvr_port_bindings too. I cannot reproduce it either. When I was able to reproduce, it's several compute nodes, we create/remove instance/floatingIP at the same times.

Ryan Moats (rmoats) wrote :

A check of the logstash query above shows that there were 79 hits in the last 7 days, so marking this bug as confirmed (in the sense that it's been seen again)

Changed in neutron:
status: Incomplete → Confirmed
Ryan Moats (rmoats) wrote :

all of the above hits referred to come from the dvr-multinode-full job, but the interesting thing is that they don't cause the job to fail... from the 79 hits, most had a success result from the job

Changed in neutron:
assignee: Armando Migliaccio (armando-migliaccio) → nobody
Ryan Moats (rmoats) wrote :

Not seeing any occurance of this from a DVR job in logstash over the last 7 days - I think we can mark this as fix released...

We never merged anything to fix the issue, the issue did come and go; as of now it's not there...so I'd rather mark it invalid.

Changed in neutron:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers