mac_address port attribute is read-only

Bug #1341268 reported by Robert Collins on 2014-07-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Medium
Chuck Carlino

Bug Description

Ironic uses Neutron for IPAM - IP address allocation and DHCP, same as nova with e.g. KVM or Xen. Unlike a virtual machine hypervisor, Ironics real machines sometimes develop hardware faults, and parts need to be replaced - and when that happens the port MAC changes. Having the port's mac address be read-only makes this much more intrusive than it would otherwise be - we have to tear down and rebuild the whole machine, rather than just replace the card and tell Neutron the new MAC.

Chuck Carlino (ccarlino) on 2014-07-13
Changed in neutron:
assignee: nobody → Chuck Carlino (ccarlino)
Gary Kotton (garyk) wrote :

Hi,
You are able to create a neutron port with a specific MAC address. Have you explored this option via nova/ironic?
Thanks
Gary

tags: added: api l3-ipam-dhcp
Changed in neutron:
importance: Undecided → Medium
yong sheng gong (gongysh) wrote :

agree with garyk, if we can create a new port with a specified mac, why should we make the port updatable?

Changed in neutron:
status: New → Opinion

Is there a race for the IP address?

Chuck

On Jul 13, 2014, at 10:20 PM, yong sheng gong <email address hidden>
 wrote:

> agree with garyk, if we can create a new port with a specified mac, why
> should we make the port updatable?
>
> ** Changed in: neutron
> Status: New => Opinion
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1341268
>
> Title:
> mac_address port attribute is read-only
>
> Status in OpenStack Neutron (virtual network service):
> Opinion
>
> Bug description:
> Ironic uses Neutron for IPAM - IP address allocation and DHCP, same as
> nova with e.g. KVM or Xen. Unlike a virtual machine hypervisor,
> Ironics real machines sometimes develop hardware faults, and parts
> need to be replaced - and when that happens the port MAC changes.
> Having the port's mac address be read-only makes this much more
> intrusive than it would otherwise be - we have to tear down and
> rebuild the whole machine, rather than just replace the card and tell
> Neutron the new MAC.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/neutron/+bug/1341268/+subscriptions

Chuck Carlino (ccarlino) wrote :

Sorry about the form of my last comment. I'll not respond via email in the future.

Chuck Carlino (ccarlino) wrote :

The problem is a race where after the address is removed from the old port and before it's assigned to the new port, it could be allocated to another port.

Changed in neutron:
status: Opinion → In Progress

Reviewed: https://review.openstack.org/112129
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=cf99eb988e05c56d3842ac388dfe9ada5aa8af86
Submitter: Jenkins
Branch: master

commit cf99eb988e05c56d3842ac388dfe9ada5aa8af86
Author: ChuckC <email address hidden>
Date: Mon Aug 4 16:52:36 2014 -0700

    Allow port mac_address to be modified

    With ironic servers, a NIC can fail and be replaced with one that has a
    different mac. The corresponding neutron port needs to be updated with
    the new mac address so the NIC can be guaranteed to retain the same IP
    address.

    This change enables this feature in the ml2 plugin. There may need to
    be changes to other plugins to disable or complete the implementation of
    this feature.

    Closes-Bug: #1341268
    Partially-implements: blueprint allow-mac-to-be-updated
    APIImpact: Ports
    DocImpact: minor port update api change
    Change-Id: I1864c0882cda7eddc9ced519ed3f96c91b2b63f3

Changed in neutron:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2015-02-05
Changed in neutron:
milestone: none → kilo-2
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2015-04-30
Changed in neutron:
milestone: kilo-2 → 2015.1.0
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints