Tempest fails to delete firewall in 300 seconds

Bug #1328162 reported by Eugene Nikanorov
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
neutron
Fix Released
High
Eugene Nikanorov
Icehouse
Fix Released
Undecided
Unassigned

Bug Description

Similar to bug #1314313 but this is another failure.

In some tempest runs a test fails to delete firewall within 300 seconds.

That happens because at the point firewall agent sends deleting confirmation to neutron server, firewall object is already updated to a state unexpected by deleting method.

Example of the issue:

http://logs.openstack.org/18/97218/2/gate/gate-tempest-dsvm-neutron/e03d166/console.html#_2014-06-07_10_33_34_506

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (master)

Fix proposed to branch: master
Review: https://review.openstack.org/98956

Changed in neutron:
status: Confirmed → In Progress
Kyle Mestery (mestery)
Changed in neutron:
milestone: none → juno-1
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (master)

Reviewed: https://review.openstack.org/98956
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=58e6bb5893186517edafe1a4d51710c1362bc9cc
Submitter: Jenkins
Branch: master

commit 58e6bb5893186517edafe1a4d51710c1362bc9cc
Author: Eugene Nikanorov <email address hidden>
Date: Tue Jun 10 07:55:40 2014 +0400

    Fix race condition with firewall deletion

    In some cases when firewall is created and then deleted in short
    period of time, there could be a race condition of firewall status
    changes. Agent may change firewall status from PENDING_DELETE to ACTIVE
    because the agent has just set it up on the backend.
    Delete request then is not properly served and firewall remains in ERROR
    state and can't be deleted at all.

    To fix this changing status from PENDING_DELETE is not allowed.
    Deleting firewall in ERROR state is allowed.

    Change-Id: Iec3cfcb1e03b33dda8e1f10ca51bd9b61fa8030d
    Closes-Bug: #1328162

Changed in neutron:
status: In Progress → Fix Committed
Revision history for this message
Matt Riedemann (mriedem) wrote :

Should this be proposed to stable/icehouse?

Revision history for this message
Matt Riedemann (mriedem) wrote :
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to neutron (stable/icehouse)

Fix proposed to branch: stable/icehouse
Review: https://review.openstack.org/99200

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to neutron (stable/icehouse)

Reviewed: https://review.openstack.org/99200
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=d5d345b975cbbfd27fbc215dacfa9fbb5c1f8046
Submitter: Jenkins
Branch: stable/icehouse

commit d5d345b975cbbfd27fbc215dacfa9fbb5c1f8046
Author: Eugene Nikanorov <email address hidden>
Date: Tue Jun 10 07:55:40 2014 +0400

    Fix race condition with firewall deletion

    In some cases when firewall is created and then deleted in short
    period of time, there could be a race condition of firewall status
    changes. Agent may change firewall status from PENDING_DELETE to ACTIVE
    because the agent has just set it up on the backend.
    Delete request then is not properly served and firewall remains in ERROR
    state and can't be deleted at all.

    To fix this changing status from PENDING_DELETE is not allowed.
    Deleting firewall in ERROR state is allowed.

    Change-Id: Iec3cfcb1e03b33dda8e1f10ca51bd9b61fa8030d
    Closes-Bug: #1328162
    (cherry picked from commit 58e6bb5893186517edafe1a4d51710c1362bc9cc)

tags: added: in-stable-icehouse
Thierry Carrez (ttx)
Changed in neutron:
status: Fix Committed → Fix Released
Thierry Carrez (ttx)
Changed in neutron:
milestone: juno-1 → 2014.2
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers