AttributeError in plugins/linuxbridge/lb_neutron_plugin.py

Bug #1241602 reported by Andreas Schröder on 2013-10-18
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
neutron
High
Eugene Nikanorov
Havana
High
Jon-Paul Sullivan

Bug Description

I'm running Ubuntu 12.04 LTS x64 + OpenStack Havana with the following neutron package versions:

neutron-common 2013.2~rc3-0ubuntu1~cloud0
neutron-dhcp-agent 2013.2~rc3-0ubuntu1~cloud0
neutron-l3-agent 2013.2~rc3-0ubuntu1~cloud0
neutron-metadata-agent 2013.2~rc3-0ubuntu1~cloud0
neutron-plugin-linuxbridge 2013.2~rc3-0ubuntu1~cloud0
neutron-plugin-linuxbridge-agent 2013.2~rc3-0ubuntu1~cloud0
neutron-server 2013.2~rc3-0ubuntu1~cloud0
python-neutron 2013.2~rc3-0ubuntu1~cloud0
python-neutronclient 2.3.0-0ubuntu1~cloud0

When adding a router interface the following error message in /var/log/neutron/server.log:

2013-10-18 15:35:14.862 15675 ERROR neutron.openstack.common.rpc.amqp [-] Exception during message handling
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp Traceback (most recent call last):
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/amqp.py", line 438, in _process_data
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp **args)
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp File "/usr/lib/python2.7/dist-packages/neutron/common/rpc.py", line 44, in dispatch
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp neutron_ctxt, version, method, namespace, **kwargs)
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/dispatcher.py", line 172, in dispatch
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp result = getattr(proxyobj, method)(ctxt, **kwargs)
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp File "/usr/lib/python2.7/dist-packages/neutron/plugins/linuxbridge/lb_neutron_plugin.py", line 147, in update_device_up
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp port = self.get_port_from_device.get_port(device)
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp AttributeError: 'function' object has no attribute 'get_port'
2013-10-18 15:35:14.862 15675 TRACE neutron.openstack.common.rpc.amqp
2013-10-18 15:35:14.862 15675 ERROR neutron.openstack.common.rpc.common [-] Returning exception 'function' object has no attribute 'get_port' to caller
2013-10-18 15:35:14.863 15675 ERROR neutron.openstack.common.rpc.common [-] ['Traceback (most recent call last):\n', ' File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/amqp.py", line 438, in _process_data\n **args)\n', ' File "/usr/lib/python2.7/dist-packages/neutron/common/rpc.py", line 44, in dispatch\n neutron_ctxt, version, method, namespace, **kwargs)\n', ' File "/usr/lib/python2.7/dist-packages/neutron/openstack/common/rpc/dispatcher.py", line 172, in dispatch\n result = getattr(proxyobj, method)(ctxt, **kwargs)\n', ' File "/usr/lib/python2.7/dist-packages/neutron/plugins/linuxbridge/lb_neutron_plugin.py", line 147, in update_device_up\n port = self.get_port_from_device.get_port(device)\n', "AttributeError: 'function' object has no attribute 'get_port'\n"]

description: updated
Changed in neutron:
assignee: nobody → Eugene Nikanorov (enikanorov)
tags: added: lb
Eugene Nikanorov (enikanorov) wrote :

I was not able to reproduce the issue.
Could you give a sequence of operations?

However from the trace the root cause and the fix seem obvious.

Changed in neutron:
importance: Undecided → Medium

Fix proposed to branch: master
Review: https://review.openstack.org/52697

Changed in neutron:
status: New → In Progress
Dirk Mueller (dmllr) wrote :

Needs to be backported to Havana.

tags: added: havana-rc-potential
Akihiro Motoki (amotoki) on 2013-10-19
tags: added: havana-backport-potential
removed: havana-rc-potential

Fix proposed to branch: master
Review: https://review.openstack.org/52789

Changed in neutron:
milestone: none → icehouse-1
tags: added: linuxbridge

Importance should be high as it breaks routers.

Changed in neutron:
importance: Medium → High

Reviewed: https://review.openstack.org/52697
Committed: http://github.com/openstack/neutron/commit/01e45596fae2818b41c76b41bef46e86c5d33231
Submitter: Jenkins
Branch: master

commit 01e45596fae2818b41c76b41bef46e86c5d33231
Author: Eugene Nikanorov <email address hidden>
Date: Sat Oct 19 16:06:03 2013 +0400

    Fix update_device_up method of linuxbridge plugin

    Also add unit tests covering update_device_up and update_device_down
    methods

    Change-Id: I97f2f9249b684aa5350b3f0621754543e80bec70
    Closes-Bug: #1241602

Changed in neutron:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/57237
Committed: http://github.com/openstack/neutron/commit/8fdcb08ed32f6561603d5df82273151a775cf3a1
Submitter: Jenkins
Branch: stable/havana

commit 8fdcb08ed32f6561603d5df82273151a775cf3a1
Author: Eugene Nikanorov <email address hidden>
Date: Sat Oct 19 16:06:03 2013 +0400

    Fix update_device_up method of linuxbridge plugin

    Also add unit tests covering update_device_up and update_device_down
    methods

    (cherry picked from commit: 01e45596fae2818b41c76b41bef46e86c5d33231)

    Change-Id: I97f2f9249b684aa5350b3f0621754543e80bec70
    Closes-Bug: #1241602

tags: added: in-stable-havana
tags: removed: havana-backport-potential lb
Thierry Carrez (ttx) on 2013-12-04
Changed in neutron:
status: Fix Committed → Fix Released
Alan Pevec (apevec) on 2013-12-16
tags: removed: in-stable-havana
Thierry Carrez (ttx) on 2014-04-17
Changed in neutron:
milestone: icehouse-1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers