WARNING [QUANTUM.DB.AGENTSCHEDULERS_DB] FAIL SCHEDULING NETWORK

Bug #1192786 reported by Peng Yong on 2013-06-20
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
neutron
Medium
li,chen
Havana
Medium
Francois Deppierraz

Bug Description

when i boot a new instance, i got a error message, and Everything is running normal but the error is still present

2013-06-20 02:41:39 WARNING [quantum.db.agentschedulers_db] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'9a1c3be6-4678-4cf7-85e8-494b49fa40b7'], 'name': u'vlan3001', 'provider:physical_network': u'physnet1', 'admin_state_up': True, 'tenant_id': u'71eedd4d59384d13b7c80cdfb4999bf0', 'provider:network_type': u'vlan', 'router:external': False, 'shared': True, 'id': u'8717d0e0-d17e-4262-ab3e-2a423d71bae4', 'provider:segmentation_id': 3001L} 2013-06-20 02:41:40 WARNING [quantum.db.agentschedulers_db] Fail scheduling network {'status': u'ACTIVE', 'subnets': [u'5c8ac388-972d-4599-a0f9-ad4cc7fa720f'], 'name': u'vlan3501', 'provider:physical_network': u'physnet2', 'admin_state_up': True, 'tenant_id': u'71eedd4d59384d13b7c80cdfb4999bf0', 'provider:network_type': u'vlan', 'router:external': False, 'shared': True, 'id': u'5b18231f-8a3a-4c5a-b6a8-a4773f45c695', 'provider:segmentation_id': 3501L}

if i check agent-list, the Open vSwitch agent on compute is up and down every several seconds.

date;quantum agent-list <<<

Thu Jun 20 02:40:02 UTC 2013 +--------------------------------------+--------------------+-------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+-------------+-------+----------------+ | 31e422a4-833c-47fd-8be2-aa71471999a0 | L3 agent | h172-16-0-2 | :-) | True | | 4a26d0b7-23aa-4b84-96e2-295bd9aff9db | DHCP agent | h172-16-0-2 | :-) | True | | 67f74ab1-f5b1-4944-8acf-f4b9eefa88ac | Open vSwitch agent | h172-16-0-2 | :-) | True | | 99c9f8a2-587f-42ec-ac51-cc2bdc6cad5a | Open vSwitch agent | h172-16-0-3 | xxx | True | +--------------------------------------+--------------------+-------------+-------+----------------+

date;quantum agent-list <<<

Thu Jun 20 02:40:04 UTC 2013 +--------------------------------------+--------------------+-------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+-------------+-------+----------------+ | 31e422a4-833c-47fd-8be2-aa71471999a0 | L3 agent | h172-16-0-2 | :-) | True | | 4a26d0b7-23aa-4b84-96e2-295bd9aff9db | DHCP agent | h172-16-0-2 | :-) | True | | 67f74ab1-f5b1-4944-8acf-f4b9eefa88ac | Open vSwitch agent | h172-16-0-2 | :-) | True | | 99c9f8a2-587f-42ec-ac51-cc2bdc6cad5a | Open vSwitch agent | h172-16-0-3 | :-) | True | +--------------------------------------+--------------------+-------------+-------+----------------+

date;quantum agent-list <<<

Thu Jun 20 02:40:09 UTC 2013 +--------------------------------------+--------------------+-------------+-------+----------------+ | id | agent_type | host | alive | admin_state_up | +--------------------------------------+--------------------+-------------+-------+----------------+ | 31e422a4-833c-47fd-8be2-aa71471999a0 | L3 agent | h172-16-0-2 | :-) | True | | 4a26d0b7-23aa-4b84-96e2-295bd9aff9db | DHCP agent | h172-16-0-2 | :-) | True | | 67f74ab1-f5b1-4944-8acf-f4b9eefa88ac | Open vSwitch agent | h172-16-0-2 | :-) | True | | 99c9f8a2-587f-42ec-ac51-cc2bdc6cad5a | Open vSwitch agent | h172-16-0-3 | xxx | True | +--------------------------------------+--------------------+-------------+-------+----------------+

Peng Yong (ppyy) wrote :
affects: nova → quantum

Hi,
I am hoping that https://review.openstack.org/#/c/33254/ will address this.
Thanks
Gary

On 06/20/2013 06:04 AM, Peng Yong wrote:
> here is another issue report:
>
> https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/issues/53
>

Peng Yong (ppyy) wrote :

after i patched quantum, the status does not bounced now.

but there are also fails of scheduling in quantum.db.agentschedulers_db when booting new instance.

Gary Kotton (garyk) wrote :

Would it be possible that you paste the steps that you do so that I can try and reproduce.
thanks
gary

Peng Yong (ppyy) wrote :

i install a multi node openstack with OVS:

https://github.com/mseknibilel/OpenStack-Grizzly-Install-Guide/blob/OVS_MultiNode/OpenStack_Grizzly_Install_Guide.rst

when i boot every new instance, it give me error message.

the instance works fine, it's network is ok.

arindam (arindam-live) on 2013-06-27
no longer affects: fedora
li,chen (chen-li) wrote :

I have the same WARNING in quantum-server.log.
And I checked code, find out the reason of the warning is because in quantum.scheduler.dhcp_agent_scheduler:

            if dhcp_agents:

                LOG.debug(_('Network %s is hosted already'),
                          network['id'])
                return

Why quantum-server try to scheduler a network that is already hosted ???

ZhiQiang Fan (aji-zqfan) wrote :

when a new port is created (new instance will create a new for most case), the schedule_network in agentschedulers_db is called, and since this network may already hosted (already launch instance on that network), it will directly return None in dhcp_agent_scheduler, which cause the agentschedulers_db.schedule_network treats it as a problem and log a warning message.

actually it is a bug because it treat a normal situation same as a real problem (like dhcp_agent doesn't live!), and it may be fixed in the master branch according to https://review.openstack.org/#/c/42457/ (which is not proved yet, yes it is my commit, but not advertise ), this patch remove the log warn in agentschedulers_db and log the message in dhcp_agent_scheduler which can tell the difference of normal situation and a real problem.

li,chen (chen-li) on 2013-08-22
Changed in neutron:
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/55793

Changed in neutron:
assignee: nobody → li,chen (chen-li)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/55793
Committed: http://github.com/openstack/neutron/commit/3ef877fc5a669659c2fa4bb2fc416d4a473c6ac5
Submitter: Jenkins
Branch: master

commit 3ef877fc5a669659c2fa4bb2fc416d4a473c6ac5
Author: chen-li <email address hidden>
Date: Tue Nov 12 09:17:17 2013 +0800

    Remove the warning for Scheduling Network

    when a new port is created, the schedule_network in agentschedulers_db is called.
    Since this network may already be hosted, it will directly return None in dhcp_agent_scheduler,
    which cause the agentschedulers_db.schedule_network log a warning message.

    This is really annoying and making users confused.
    And, real warnings are already addressed in the real scheduler function.
    which is neutron.scheduler.dhcp_agent_scheduler.ChanceScheduler.schedule by default.

    Change-Id: I11bdbe47c2cc0fc45fb143970fb6762678bc27e5
    Closes-Bug: #1192786

Changed in neutron:
status: In Progress → Fix Committed
Changed in neutron:
importance: Undecided → Medium
milestone: none → icehouse-1
tags: added: havana-backport-potential neutron-core
Thierry Carrez (ttx) on 2013-12-04
Changed in neutron:
status: Fix Committed → Fix Released
Alan Pevec (apevec) on 2014-02-02
tags: removed: havana-backport-potential

Reviewed: https://review.openstack.org/66586
Committed: https://git.openstack.org/cgit/openstack/neutron/commit/?id=a47fde6e7aaafda70a94d025959049b242fba36b
Submitter: Jenkins
Branch: stable/havana

commit a47fde6e7aaafda70a94d025959049b242fba36b
Author: chen-li <email address hidden>
Date: Tue Nov 12 09:17:17 2013 +0800

    Remove the warning for Scheduling Network

    when a new port is created, the schedule_network in agentschedulers_db is called.
    Since this network may already be hosted, it will directly return None in dhcp_agent_scheduler,
    which cause the agentschedulers_db.schedule_network log a warning message.

    This is really annoying and making users confused.
    And, real warnings are already addressed in the real scheduler function.
    which is neutron.scheduler.dhcp_agent_scheduler.ChanceScheduler.schedule by default.

    Cherry-picked from 3ef877fc5a669659c2fa4bb2fc416d4a473c6ac5 in master.

    Change-Id: I11bdbe47c2cc0fc45fb143970fb6762678bc27e5
    Closes-Bug: #1192786

Thierry Carrez (ttx) on 2014-04-17
Changed in neutron:
milestone: icehouse-1 → 2014.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions