List servers matching a regex fails with Neutron

Bug #1182883 reported by Jordan Pittier on 2013-05-22
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Undecided
Unassigned
neutron
Medium
Unassigned
tempest
High
Alexander Gubanov

Bug Description

The test tempest.api.compute.servers.test_list_server_filters:ListServerFiltersTestXML.test_list_servers_filtered_by_ip_regex tries to search a server with only a fragment of its IP (GET http://XX/v2/$Tenant/servers?ip=10.0.) which calls the following Quantum request : http://XX/v2.0/ports.json?fixed_ips=ip_address%3D10.0. But it seems this regex search is not supporter by Quantum. Thus the tempest test fauls.

Tags: api Edit Tag help
Jordan Pittier (jordan-pittier) wrote :

If one would implement a "search port by IP with regex" feature, I think the best place to hack it would be in file quantum/db/db_base_plugin_v2.py::_get_ports_query()

yong sheng gong (gongysh) wrote :

I will use a BP to do it since it involves much.

Changed in quantum:
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → yong sheng gong (gongysh)
milestone: none → havana-2
Sean Dague (sdague) wrote :

because this is a Quantum gap with the nova-network API I'm going to call it confirmed, but it's a quantum bug.

Changed in tempest:
status: New → Confirmed
Sean Dague (sdague) wrote :

This is a blocking issue for full tempest runs of Quantum.

Changed in tempest:
importance: Undecided → High
tags: added: api
Changed in neutron:
milestone: havana-2 → havana-3

Fix proposed to branch: master
Review: https://review.openstack.org/38600

Changed in neutron:
status: Confirmed → In Progress

converted to blueprint for neutron.

Changed in neutron:
milestone: havana-3 → none
status: In Progress → Invalid

I will be out of the office starting 2013-09-05 and will not return until
2013-09-15.

I will be on my marriage leave from 9/5 to 9/15, for any urgent issue
please call me before 9/7.

For daily work, please ask my scrum master Zhu Zhu for help.
For glance issue, please ask glance SME Feilong Wang for help.
For defect report, there will be no report next week.

Changed in nova:
status: New → Invalid
Sean Dague (sdague) on 2013-12-12
Changed in tempest:
status: Confirmed → Invalid
Changed in neutron:
status: Invalid → Confirmed
summary: - List servers matching a regex fails with Quantum
+ List servers matching a regex fails with Neutron
Changed in neutron:
assignee: yong sheng gong (gongysh) → nobody
Dr. Jens Harbott (j-harbott) wrote :

Is this bug still current? The tempest check can be enabled now and it seems to work just fine (depending on https://launchpad.net/bugs/1450859 though):

http://logs.openstack.org/70/179570/2/check/check-tempest-dsvm-neutron-full/b6bde81/console.html#_2015-05-26_10_20_13_515

Fix proposed to branch: master
Review: https://review.openstack.org/188511

Changed in tempest:
assignee: nobody → Alexander Gubanov (ogubanov)
status: Invalid → In Progress

Reviewed: https://review.openstack.org/188511
Committed: https://git.openstack.org/cgit/openstack/tempest/commit/?id=98a9aec4a9ad6bcdd4cd5c0e7ad3b7ecb449e4aa
Submitter: Jenkins
Branch: master

commit 98a9aec4a9ad6bcdd4cd5c0e7ad3b7ecb449e4aa
Author: Alexander Gubanov <email address hidden>
Date: Thu Jun 4 19:10:00 2015 +0300

    Unskip test skipped because of closed bugs

    Removed skip for test "list_servers_filtered_by_ip_regex"
    which skipped because of closed bugs.

    Change-Id: I205fcc785595abd8c22100ee01074d859ec75827
    Closes-bug: #1182883

Changed in tempest:
status: In Progress → Fix Released

This bug is > 172 days without activity. We are unsetting assignee and milestone and setting status to Incomplete in order to allow its expiry in 60 days.

If the bug is still valid, then update the bug status.

Changed in neutron:
status: Confirmed → Incomplete

This bug is > 180 days without activity. We are unsetting assignee and milestone and setting status to Incomplete in order to allow its expiry in 60 days.

If the bug is still valid, then update the bug status.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers