OpenStack Neutron (virtual network service)

Fix Cisco Nexus plugin failures for vlan IDs 1006-4094

Reported by Dane LeBlanc on 2013-04-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Low
Dane LeBlanc
Grizzly
Low
Dane LeBlanc

Bug Description

Add support for vlan IDs 1006-4094 on the Cisco nexus plugin for the Nexus 3K switch. Currently, if the Cisco Nexus plugin is configured and a Nexus 3K is attached to a compute host, and an attempt is made to bring up a VM which uses a VLAN ID in the range of 1006-4094, then the switch rejects the VLAN configuration with the following error:
    ERROR: Can't modify state for extended VLAN <vlan-ID>
and the VM instance fails to come up.
This is not an issue with the Nexus 5K or 7K family of switches.

Dane LeBlanc (leblancd) on 2013-04-30
Changed in quantum:
assignee: nobody → Dane LeBlanc (leblancd)

Fix proposed to branch: master
Review: https://review.openstack.org/27793

Changed in quantum:
status: New → In Progress
Dane LeBlanc (leblancd) on 2013-04-30
summary: - Cisco nexus plugin fails for vlan IDs 1006-4094
+ Add support for vlan IDs 1006-4094 on Cisco Nexus 3K plugin
Dane LeBlanc (leblancd) on 2013-04-30
description: updated
tags: added: cisco
Changed in quantum:
importance: Undecided → Wishlist
Kyle Mestery (mestery) on 2013-05-07
Changed in quantum:
importance: Wishlist → Low
milestone: none → havana-1
Dane LeBlanc (leblancd) on 2013-05-14
summary: - Add support for vlan IDs 1006-4094 on Cisco Nexus 3K plugin
+ Fix Cisco Nexus plugin failures for vlan IDs 1006-4094

Reviewed: https://review.openstack.org/27793
Committed: http://github.com/openstack/quantum/commit/fc914f66502ee066f41780e10b0e659334ffd060
Submitter: Jenkins
Branch: master

commit fc914f66502ee066f41780e10b0e659334ffd060
Author: Dane LeBlanc <email address hidden>
Date: Mon Apr 29 23:43:14 2013 -0400

    Fix Cisco Nexus plugin failures for vlan IDs 1006-4094

    Fixes bug 1174593

    VLAN IDs in the range 1006-4094 are considered to be in the extended
    range by the Cisco Nexus 3K switch. As such, the 3K rejects any
    state change configuration commands for VLANs in this range, including
    "state active" and "no shutdown". The errors returned by the 3K for
    these commands can be ignored, since the default states for these commands
    are acceptable for the 3K.

    For the 5K and 7K versions of the Nexus switch, on the other hand, the
    "state active" and "no shutdown" commands are required for proper VLAN
    configuration, regardless of VLAN ID.

    This fix splits the configuration commands which are used to create a
    VLAN on the Nexus switch into three separate configurations:
      - VLAN creation
      - state active
      - no shutdown
    For the "state active" and "no shutdown" configurations, the Cisco Nexus
    plugin will tolerate (ignore) errors involving invalid setting of state
    for VLANs in the extended VLAN range. These specific errors can be
    identified by looking for the appearance of certain signature strings
    in the associated exception's message string, i.e. "Can't modify
    state for extended" or "Command is allowed on VLAN".

    This approach will yield a very small hit in performance, but the solution
    is much less error prone than requiring customers to configure the
    Cisco plugin for 3K vs. 5K vs. 7K, or perhaps even specific software
    versions of the 3K, in order to inform the Cisco plugin whether
    VLAN state configuration commands should be used or not.

    Change-Id: I1be4966ddc6f462bca38428c4f904f8c982f318f

Changed in quantum:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2013-05-29
Changed in quantum:
status: Fix Committed → Fix Released
Arvind Somya (asomya) on 2013-05-29
tags: added: grizzly-backport-potential

Reviewed: https://review.openstack.org/40011
Committed: http://github.com/openstack/neutron/commit/ce0e9a36bdb8ef62505648f6af77b4e3d855813a
Submitter: Jenkins
Branch: stable/grizzly

commit ce0e9a36bdb8ef62505648f6af77b4e3d855813a
Author: Dane LeBlanc <email address hidden>
Date: Thu Aug 1 09:50:47 2013 -0400

    Fix Cisco Nexus plugin failures for vlan IDs 1006-4094

    Fixes bug 1174593

    VLAN IDs in the range 1006-4094 are considered to be in the extended
    range by the Cisco Nexus 3K switch. As such, the 3K rejects any
    state change configuration commands for VLANs in this range, including
    "state active" and "no shutdown". The errors returned by the 3K for
    these commands can be ignored, since the default states for these commands
    are acceptable for the 3K.

    For the 5K and 7K versions of the Nexus switch, on the other hand, the
    "state active" and "no shutdown" commands are required for proper VLAN
    configuration, regardless of VLAN ID.

    This fix splits the configuration commands which are used to create a
    VLAN on the Nexus switch into three separate configurations:
      - VLAN creation
      - state active
      - no shutdown
    For the "state active" and "no shutdown" configurations, the Cisco Nexus
    plugin will tolerate (ignore) errors involving invalid setting of state
    for VLANs in the extended VLAN range. These specific errors can be
    identified by looking for the appearance of certain signature strings
    in the associated exception's message string, i.e. "Can't modify
    state for extended" or "Command is allowed on VLAN".

    This approach will yield a very small hit in performance, but the solution
    is much less error prone than requiring customers to configure the
    Cisco plugin for 3K vs. 5K vs. 7K, or perhaps even specific software
    versions of the 3K, in order to inform the Cisco plugin whether
    VLAN state configuration commands should be used or not.

    Change-Id: I1be4966ddc6f462bca38428c4f904f8c982f318f
    (cherry picked from commit fc914f66502ee066f41780e10b0e659334ffd060)

tags: added: in-stable-grizzly
Alan Pevec (apevec) on 2013-08-06
tags: removed: grizzly-backport-potential in-stable-grizzly
Thierry Carrez (ttx) on 2013-10-17
Changed in neutron:
milestone: havana-1 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers