lbaas. when operation fails and and the status is ERROR there is a need to add error description

Bug #1166925 reported by Avishay Balderman on 2013-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Wishlist
Oleg Bondarev

Bug Description

Since the LBaaS config entities are created/updated on the "load balancer device" in the background, the call will return with 202 and PENDING_CREATE.
Later the when the lbass plugin understands that the operation has failed, it sets the status to ERROR in DB.

When the tenant checks the the entity configuration status he will get back an ERROR status but there is no way to return the reason of the error because there is no field in DB to keep the error description.

Changed in quantum:
importance: Undecided → Wishlist
Changed in quantum:
status: New → Confirmed
Changed in quantum:
assignee: nobody → Oleg Bondarev (obondarev)

Fix proposed to branch: master
Review: https://review.openstack.org/34209

Changed in quantum:
status: Confirmed → In Progress
tags: added: api

Reviewed: https://review.openstack.org/34209
Committed: http://github.com/openstack/neutron/commit/32e5b054d20083edc5e6bd255505757d5793d376
Submitter: Jenkins
Branch: master

commit 32e5b054d20083edc5e6bd255505757d5793d376
Author: Oleg Bondarev <email address hidden>
Date: Mon Jun 24 16:50:19 2013 +0400

    Add status description field for lbaas objects

    Fixes bug 1166925

    Change-Id: I44d936afd8cd531a786c09c38bbc4702737ce99c

Changed in neutron:
status: In Progress → Fix Committed
Changed in neutron:
milestone: none → havana-3
Thierry Carrez (ttx) on 2013-09-05
Changed in neutron:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2013-10-17
Changed in neutron:
milestone: havana-3 → 2013.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers