l3_agent destroys all namespaces on init, even if router_id is set

Bug #1122206 reported by Christoph Thiel on 2013-02-11
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
High
Christoph Thiel
Folsom
High
Christoph Thiel
quantum (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
Raring
High
Unassigned

Bug Description

When two l3_agents are running on the same host, both using namespaces and having router_id set, the l3_agent that is started last will destroy the namespace of the l3_agent that was started first. This shouldn't happen.

Will propose a fix momentarily.

Fix proposed to branch: master
Review: https://review.openstack.org/21668

Changed in quantum:
assignee: nobody → Christoph Thiel (cthiel-suse)
status: New → In Progress
Gary Kotton (garyk) on 2013-02-12
Changed in quantum:
importance: Undecided → High
Christoph Thiel (cthiel-suse) wrote :

Will propose a backport to stable/folsom.

tags: added: folsom-backport-potential
Gary Kotton (garyk) on 2013-02-12
Changed in quantum:
milestone: none → grizzly-3

Reviewed: https://review.openstack.org/21668
Committed: http://github.com/openstack/quantum/commit/23b47c832a9ae0c1890ad0d467c28f81914d4b57
Submitter: Jenkins
Branch: master

commit 23b47c832a9ae0c1890ad0d467c28f81914d4b57
Author: Christoph Thiel <email address hidden>
Date: Mon Feb 11 17:46:59 2013 +0100

    only destroy single namespace if router_id is set

    Fixes bug 1122206

    If multiple instances of l3_agent are running on the same host, all qrouter-
    namespaces will be destroyed as new l3_agents are started. This fix allows
    for multiple l3_agents to be running on the same host when router_id is set
    for each agent.

    Change-Id: I879cdc6faba94900f831232232d67e471c70d778

Changed in quantum:
status: In Progress → Fix Committed

Reviewed: https://review.openstack.org/21759
Committed: http://github.com/openstack/quantum/commit/45baf034466275fbc32ababada1513c7b5e76c01
Submitter: Jenkins
Branch: stable/folsom

commit 45baf034466275fbc32ababada1513c7b5e76c01
Author: Christoph Thiel <email address hidden>
Date: Tue Feb 12 11:44:23 2013 +0100

    only destroy single namespace if router_id is set

    Fixes bug 1122206

    If multiple instances of l3_agent are running on the same host, all qrouter-
    namespaces will be destroyed as new l3_agents are started. This fix allows
    for multiple l3_agents to be running on the same host when router_id is set
    for each agent.

    Change-Id: I879cdc6faba94900f831232232d67e471c70d778

tags: added: in-stable-folsom
James Page (james-page) on 2013-02-14
Changed in quantum (Ubuntu):
importance: Undecided → High
Changed in quantum (Ubuntu Quantal):
importance: Undecided → High
status: New → Triaged
Changed in quantum (Ubuntu Raring):
status: New → Triaged
Thierry Carrez (ttx) on 2013-02-21
Changed in quantum:
status: Fix Committed → Fix Released
James Page (james-page) on 2013-02-26
Changed in quantum (Ubuntu Raring):
status: Triaged → Fix Released
Thierry Carrez (ttx) on 2013-04-04
Changed in quantum:
milestone: grizzly-3 → 2013.1
Alan Pevec (apevec) on 2013-04-07
tags: removed: folsom-backport-potential in-stable-folsom

Hello Christoph, or anyone else affected,

Accepted quantum into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/quantum/2012.2.4-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in quantum (Ubuntu Quantal):
status: Triaged → Fix Committed
tags: added: verification-needed

Please find the attached test log from the Ubuntu Server Team's CI infrastructure. As part of the verification process for this bug, the OpenStack components have been deployed and configured across multiple nodes using quantal-proposed as an installation source. After successful bring-up and configuration of the cluster, a number of exercises and smoke tests have be invoked to ensure the updated package did not introduce any regressions. A number of test iterations were carried out to catch any possible transient errors.

These proposed packages were deployed and tested in several different configurations. Attached are tarballs with various test logs from each configuration. In addition to the base components, variables in deployments include:

quantal_folsom.tar: nova-network (FlatDHCP), glance (Ceph backend), cinder (Ceph backend),
quantal_folsom_nova-volume.tar: nova-network (FlatDHCP), glance (local file), nova-volume (iSCSI backend)
quantal_folsom_quantum.tar: quantum (OVS plugin), glance (Ceph backend), nova-volume (Ceph backend)

Please note the versions_tested file in each tarball, which contains details about relevant package versions installed and tested.

For records of upstream test coverage of this update, please see the Jenkins links in the comments of the relevant upstream code-review(s):

Trunk review: https://review.openstack.org/21668
Stable review: https://review.openstack.org/21759

As per the provisional Micro Release Exception granted to this package by the Technical Board, we hope this contributes toward verification of this update.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package quantum - 2012.2.4-0ubuntu1

---------------
quantum (2012.2.4-0ubuntu1) quantal-proposed; urgency=low

  * Resynchronize with stable/folsom (96680c96) (LP: #1179707):
    - [527b5ec] Folsom NEC plugin fails to create a network/port on some version
      of PFC due to too long string LP: 1166077
    - [346aae3] Folsom NEC plugin: Cannot create a tenant on some version of
      OpenFlow controller LP: 1166076
    - [a31069a] Network cannot be created in NEC plugin when OFC network ID is
      unique inside a tenant LP: 1127664
    - [a109f7e] Folsom l3 agent unable to connect to quantum service LP: 1157090
    - [913586b] MyISAM does not perform cascading deletions LP: 1153594
    - [5a2ef81] Openstack quantum, race condition in ip address creation when
      starting 50 VMs on a 5-node cluster LP: 1110807
    - [f94b149] Deleting a subnet that is added to a router leaves behind a port
      that cannot be deleted LP: 1104337
    - [b14824f] Address re-allocation before DHCP lease's expire LP: 1116500
    - [30bb632] file descriptors not closed when executing sub-processes
      LP: 1130735
    - [5d26f41] DHCP agent could take upto a minute to get its IP address
      LP: 1128180
    - [2f32795] dhcp-agent distributes empty domain when dhcp_domain=""
      LP: 1099625
    - [8755cb3] ovs and netns cleanupo utilities do not log LP: 1118517
    - [45baf03] l3_agent destroys all namespaces on init, even if router_id is
      set (LP: #1122206)
 -- Adam Gandelman <email address hidden> Thu, 25 Apr 2013 17:52:50 -0400

Changed in quantum (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers