OpenStack Neutron (virtual network service)

Restarting l3 agents has an exception

Reported by Gary Kotton on 2012-09-09
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
neutron
High
Gary Kotton

Bug Description

When restarting the l3 agent, after a router has been configured, causes an exception.

qdhcp-6a2d77e9-8a4c-4a32-a14c-99aaf32bda94\nqrouter-23bda4be-b275-4b79-922b-42ddb8b56b60\nqdhcp-dd385891-8efb-4229-8d47-0466cde3be97\nqdhcp-e8dc7e7e-6623-4668-9492-fe88d0322888\nqdhcp-03b52de3-050c-4bcf-bba0-4f3ed2062dbf\nqrouter-d5944d17-fdfb-4590-9df9-76dc7fae636a\nqdhcp-4ac579e1-93a9-453c-ac55-5bd16be8eb83\nqdhcp-65038560-6352-4ffe-8898-1b75dde59208\nqdhcp-5fe80e87-426c-4bef-bfcf-18599ca2f371\nqrouter-b9e8e14c-c638-4cca-a1c6-2a44a8799d5b\nqdhcp-5a9b29e5-0e17-4c55-b837-abaf3f04d3e5\n'
Stderr: ''
2012-09-08 17:43:48 DEBUG [quantum.agent.linux.utils] Running command:
sudo ip link set qgw-55ee669c-4 netns
qrouter-23bda4be-b275-4b79-922b-42ddb8b56b60
2012-09-08 17:43:48 DEBUG [quantum.agent.linux.utils]
Command: ['sudo', 'ip', 'link', 'set', 'qgw-55ee669c-4', 'netns',
'qrouter-23bda4be-b275-4b79-922b-42ddb8b56b60']
Exit code: 2
Stdout: ''
Stderr: 'RTNETLINK answers: Invalid argument\n'
2012-09-08 17:43:48 ERROR [quantum.agent.l3_agent] Error running l3_nat
daemon_loop
Traceback (most recent call last):
  File "/opt/stack/quantum/quantum/agent/l3_agent.py", line 169, in
daemon_loop
    self.do_single_loop()
  File "/opt/stack/quantum/quantum/agent/l3_agent.py", line 197, in
do_single_loop
    self.process_router(ri)
  File "/opt/stack/quantum/quantum/agent/l3_agent.py", line 250, in
process_router
    self.external_gateway_added(ri, ex_gw_port, internal_cidrs)
  File "/opt/stack/quantum/quantum/agent/l3_agent.py", line 329, in
external_gateway_added
    prefix=EXTERNAL_DEV_PREFIX)
  File "/opt/stack/quantum/quantum/agent/linux/interface.py", line 145, in
plug
    namespace_obj.add_device_to_namespace(device)
  File "/opt/stack/quantum/quantum/agent/linux/ip_lib.py", line 120, in
add_device_to_namespace
    device.link.set_netns(self.namespace)
  File "/opt/stack/quantum/quantum/agent/linux/ip_lib.py", line 183, in
set_netns
    self._as_root('set', self.name, 'netns', namespace)
  File "/opt/stack/quantum/quantum/agent/linux/ip_lib.py", line 158, in
_as_root
    kwargs.get('use_root_namespace', False))
  File "/opt/stack/quantum/quantum/agent/linux/ip_lib.py", line 45, in
_as_root
    namespace)
  File "/opt/stack/quantum/quantum/agent/linux/ip_lib.py", line 56, in
_execute
    root_helper=root_helper)
  File "/opt/stack/quantum/quantum/agent/linux/utils.py", line 55, in
execute
    raise RuntimeError(m)
RuntimeError:
Command: ['sudo', 'ip', 'link', 'set', 'qgw-55ee669c-4', 'netns',
'qrouter-23bda4be-b275-4b79-922b-42ddb8b56b60']
Exit code: 2
Stdout: ''

dan wendlandt (danwent) wrote :

Note: multiple people will be working on this. Setting gary as the owner since he has done the most already.

Changed in quantum:
milestone: none → folsom-rc1
assignee: nobody → Gary Kotton (garyk)
importance: Undecided → High
status: New → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/12691

Changed in quantum:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/12691
Committed: http://github.com/openstack/quantum/commit/9b5871c658e1ec77bc29da507a2471a8b81b3702
Submitter: Jenkins
Branch: master

commit 9b5871c658e1ec77bc29da507a2471a8b81b3702
Author: Gary Kotton <email address hidden>
Date: Mon Sep 10 04:19:09 2012 -0400

    Ensure that l3 agent does not crash on restart

    Fixes bug 1048108

    The changeset also removed the namespace garbage collection from the port unplug. This
    attempts to delete the namespace. This is problematic as there may be additional attributes
    to the namespace that need to be dealt with.

    Change-Id: I418a1ec4e9b65e5bea67ae84414019c3d6b54214

Changed in quantum:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-09-12
Changed in quantum:
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in quantum:
milestone: folsom-rc1 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers