[RFE] auto-associate floating ips

Bug #1042049 reported by dan wendlandt on 2012-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
neutron
Wishlist
Unassigned

Bug Description

nova has a flag that indicates that each VM should automatically have a floating IP assigned and associated at the time of VM creation.

In neutron, the equivalent would be at port creation time. In Nova this is a system wide flag, but in neutron this would likely be an option that is enabled per-network (i.e., for a particular network, it is automatically assigned a floating IP from external network X). this would map to a amazon VPC use case as well.

dan wendlandt (danwent) on 2012-08-27
Changed in quantum:
importance: Undecided → Medium
Thierry Carrez (ttx) on 2012-09-04
Changed in quantum:
status: New → Confirmed
dan wendlandt (danwent) on 2012-11-08
Changed in quantum:
status: Confirmed → Invalid
Changed in neutron:
status: Invalid → Confirmed
summary: - auto-associate floating ips
+ [RFE] auto-associate floating ips
tags: added: rfe
description: updated
Changed in neutron:
importance: Medium → Wishlist
tags: added: auto-allocated-topology

worth discussing.

Changed in neutron:
status: Confirmed → Triaged
tags: added: rfe-approved
removed: rfe
tags: added: rfe-postponed
removed: rfe-approved
tags: added: rfe-approved
removed: rfe-postponed

Change abandoned by Slawek Kaplonski (<email address hidden>) on branch: master
Review: https://review.opendev.org/469294
Reason: According to what we agreed during Shanghai PTG, I abandon this patch for now due to no activity. If You would be interested in continue work on this, feel free to restore the patch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers