[stable/train] py27 tests fail with "ERROR: Package 'hacking' requires a different Python: 2.7.17 not in '>=3.5'"

Bug #1922660 reported by Bernard Cafarelli
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-ovn
Undecided
Bernard Cafarelli

Bug Description

Seen on recent backports like https://review.opendev.org/c/openstack/networking-ovn/+/784096

2021-04-06 08:06:55.021796 | ubuntu-bionic | Collecting hacking>=1.1.0
2021-04-06 08:06:55.021805 | ubuntu-bionic | Downloading https://mirror.bhs1.ovh.opendev.org/pypifiles/packages/cd/6a/c4885e716d6a9f2263be3c541937d0a8a1bcc6e19cb3e35af8b960f70380/hacking-4.0.0.tar.gz (60 kB)
2021-04-06 08:06:55.021811 | ubuntu-bionic | ERROR: Package 'hacking' requires a different Python: 2.7.17 not in '>=3.5'

hacking is not capped so it picks python3-only versions. Let's use the same max upper version as neutron train branch

Revision history for this message
Bernard Cafarelli (bcafarel) wrote :
Changed in networking-ovn:
status: New → In Progress
assignee: nobody → Bernard Cafarelli (bcafarel)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/networking-ovn 7.4.1

This issue was fixed in the openstack/networking-ovn 7.4.1 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers