Add support for fragmentation

Bug #1838405 reported by Lucas Alvares Gomes
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-ovn
Fix Released
Medium
Lucas Alvares Gomes

Bug Description

Core OVN now supports fragmentation (see commit message [0] for more details), networking-ovn should add supports for it.

Reported upstream at: https://mail.openvswitch.org/pipermail/ovs-discuss/2018-July/047039.html
Reported downstream at: https://bugzilla.redhat.com/show_bug.cgi?id=1547074

[0] https://kernel.googlesource.com/pub/scm/linux/kernel/git/davem/net-next/+/4d5ec89fc8d14dcdab7214a0c13a1c7321dc6ea9%5E%21/

Tags: rfe
Changed in networking-ovn:
assignee: nobody → Lucas Alvares Gomes (lucasagomes)
tags: added: rfe
Changed in networking-ovn:
status: New → Confirmed
importance: Undecided → Medium
Changed in networking-ovn:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to networking-ovn (master)

Reviewed: https://review.opendev.org/671766
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=d7e950002d7bcf1bbebab5cd289b59d65366492e
Submitter: Zuul
Branch: master

commit d7e950002d7bcf1bbebab5cd289b59d65366492e
Author: Lucas Alvares Gomes <email address hidden>
Date: Fri Jul 19 16:22:24 2019 +0100

    OVN to emit ICMP "fragmentation needed" packets

    A new configuration option called "ovn_emit_need_to_frag" has been added
    and defaults to False. Reason being, it requires a specific kernel
    version for it to work (upstream >= 5.2). It's also possible to find out
    if OVN supports that operation by running the following command as root:

    $ ovs-appctl -t ovs-vswitchd dpif/show-dp-features br-int
    (check for "Check pkt length action: Yes").

    WARNING: Enabling this option without kernel support will result in a
    real performance degradation.

    At earlier versions of this patch we thought about having networking-ovn
    to discover if this option is supported or not (by issuing that
    ovs-appctl command above) but, since networking-ovn doesn't run in the
    network nodes we thought that an upper level tool (such as puppet-ovn or
    TripleO) could do a better job at checking for it and configuring things
    accordingly.

    Closes-Bug: #1838405
    Change-Id: I089f95b40803a6cd5e01990acacd599ced3bbd91
    Signed-off-by: Lucas Alvares Gomes <email address hidden>

Changed in networking-ovn:
status: In Progress → Fix Released
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/networking-ovn 7.0.0.0b1

This issue was fixed in the openstack/networking-ovn 7.0.0.0b1 development milestone.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers