Functional tests: fixup_uca: command not found

Bug #1835375 reported by Lucas Alvares Gomes on 2019-07-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-ovn
Critical
Lucas Alvares Gomes

Bug Description

Apparently devstack removed that function

2019-07-04 03:40:41.450674 | primary | ++ /opt/stack/new/networking-ovn/tools/configure_for_func_testing.sh:_init:83 : source /opt/stack/new/devstack/tools/fixup_stuff.sh
2019-07-04 03:40:41.452503 | primary | +++ tools/fixup_stuff.sh:source:22 : [[ -z /opt/stack/new/devstack ]]
2019-07-04 03:40:41.455270 | primary | ++ /opt/stack/new/networking-ovn/tools/configure_for_func_testing.sh:_init:84 : fixup_uca
2019-07-04 03:40:41.455887 | primary | /opt/stack/new/networking-ovn/tools/configure_for_func_testing.sh: line 84: fixup_uca: command not found
2019-07-04 03:40:41.459151 | primary | ERROR: the main setup script run by this job failed - exit code: 127
2019-07-04 03:40:41.459258 | primary | please look at the relevant log files to determine the root cause
2019-07-04 03:40:41.459310 | primary | Running devstack worlddump.py

http://logs.openstack.org/50/668850/1/check/networking-ovn-dsvm-functional/0f3a6eb/job-output.txt.gz

Changed in networking-ovn:
status: New → Incomplete
status: Incomplete → Confirmed
importance: Undecided → Critical
assignee: nobody → Lucas Alvares Gomes (lucasagomes)
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to networking-ovn (master)

Fix proposed to branch: master
Review: https://review.opendev.org/669099

Changed in networking-ovn:
status: Confirmed → In Progress
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to networking-ovn (master)

Reviewed: https://review.opendev.org/669099
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=dd5f1656b54822883f6c73ee68149f3312e02819
Submitter: Zuul
Branch: master

commit dd5f1656b54822883f6c73ee68149f3312e02819
Author: Lucas Alvares Gomes <email address hidden>
Date: Thu Jul 4 09:23:40 2019 +0100

    Functional tests: Fix setup error due to missing function

    The "fixup_uca" was recently renamed in DevStack to "fixup_ubuntu"
    as part of https://review.opendev.org/#/c/619562 and that broke our
    functional gate setup. The functional itself does not seeing to be
    needed anymore (functional tests passes without it) so this patch is
    getting rid of it to avoid another renaming in the future.

    Change-Id: I15419c029cd9e60a1a6164f97fa893611994b8f3
    Closes-Bug: #1835375
    Signed-off-by: Lucas Alvares Gomes <email address hidden>

Changed in networking-ovn:
status: In Progress → Fix Released
tags: added: networking-ovn-proactive-backport-potential
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/networking-ovn 7.0.0.0b1

This issue was fixed in the openstack/networking-ovn 7.0.0.0b1 development milestone.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to networking-ovn (stable/stein)

Fix proposed to branch: stable/stein
Review: https://review.opendev.org/698952

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix proposed to networking-ovn (stable/rocky)

Fix proposed to branch: stable/rocky
Review: https://review.opendev.org/698953

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to networking-ovn (stable/stein)

Reviewed: https://review.opendev.org/698952
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=deb9efeb45e79e6413c8a59bff1f8bad9141477e
Submitter: Zuul
Branch: stable/stein

commit deb9efeb45e79e6413c8a59bff1f8bad9141477e
Author: Lucas Alvares Gomes <email address hidden>
Date: Thu Jul 4 09:23:40 2019 +0100

    Functional tests: Fix setup error due to missing function

    The "fixup_uca" was recently renamed in DevStack to "fixup_ubuntu"
    as part of https://review.opendev.org/#/c/619562 and that broke our
    functional gate setup. The functional itself does not seeing to be
    needed anymore (functional tests passes without it) so this patch is
    getting rid of it to avoid another renaming in the future.

    Change-Id: I15419c029cd9e60a1a6164f97fa893611994b8f3
    Closes-Bug: #1835375
    Signed-off-by: Lucas Alvares Gomes <email address hidden>
    (cherry picked from commit dd5f1656b54822883f6c73ee68149f3312e02819)

tags: added: in-stable-stein
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix merged to networking-ovn (stable/rocky)

Reviewed: https://review.opendev.org/698953
Committed: https://git.openstack.org/cgit/openstack/networking-ovn/commit/?id=7eeb4f1aa0c6e68f7714f2384594f021834596b2
Submitter: Zuul
Branch: stable/rocky

commit 7eeb4f1aa0c6e68f7714f2384594f021834596b2
Author: Lucas Alvares Gomes <email address hidden>
Date: Thu Jul 4 09:23:40 2019 +0100

    Functional tests: Fix setup error due to missing function

    The "fixup_uca" was recently renamed in DevStack to "fixup_ubuntu"
    as part of https://review.opendev.org/#/c/619562 and that broke our
    functional gate setup. The functional itself does not seeing to be
    needed anymore (functional tests passes without it) so this patch is
    getting rid of it to avoid another renaming in the future.

    Change-Id: I15419c029cd9e60a1a6164f97fa893611994b8f3
    Closes-Bug: #1835375
    Signed-off-by: Lucas Alvares Gomes <email address hidden>
    (cherry picked from commit dd5f1656b54822883f6c73ee68149f3312e02819)

tags: added: in-stable-rocky
Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/networking-ovn 6.0.1

This issue was fixed in the openstack/networking-ovn 6.0.1 release.

Revision history for this message
OpenStack Infra (hudson-openstack) wrote : Fix included in openstack/networking-ovn 5.1.0

This issue was fixed in the openstack/networking-ovn 5.1.0 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers