Allow networking-odl to support DSCP Marking rule for qos driver.

Bug #1686625 reported by rajiv on 2017-04-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-odl
High
rajiv

Bug Description

Opendaylight is planned to support DSCP Marking rule for qos, this bug keeps track to support for the same in networking-odl.

rajiv (rajiv-kumar) on 2017-04-27
Changed in networking-odl:
assignee: nobody → rajiv (rajiv-kumar)

Fix proposed to branch: master
Review: https://review.openstack.org/460470

Changed in networking-odl:
status: New → In Progress
Isaku Yamahata (yamahata) wrote :

which rule is supported depends on ODL backend.
The direction is, ODL backends should publish supported rules and networking-odl retrieaves it at startup.

Mike Kolesnik (mkolesni) wrote :

I think the best way is to use the feature negotiation mechanism to see if this is supported by ODL or not.
In the interim, until this is published by ODL, we can have this as a seperate cofig value or even use the features one so that if operator wants to turn it on he only has to specify it in the features config list.

Changed in networking-odl:
importance: Undecided → High

Change abandoned by Armando Migliaccio (<email address hidden>) on branch: master
Review: https://review.openstack.org/460470
Reason: This review is > 4 weeks without comment, and failed Jenkins the last time it was checked. We are abandoning this for now. Feel free to reactivate the review by pressing the restore button and leaving a 'recheck' comment to get fresh test results.

Change abandoned by rajiv (<email address hidden>) on branch: master
Review: https://review.openstack.org/460470
Reason: https://review.openstack.org/#/c/519513/ patch has been raise. Will work on that

Fix proposed to branch: master
Review: https://review.openstack.org/558554

Change abandoned by rajiv (<email address hidden>) on branch: master
Review: https://review.openstack.org/529537

Reviewed: https://review.openstack.org/567626
Committed: https://git.openstack.org/cgit/openstack/networking-odl/commit/?id=86175e8f557f1f7930e097cab8345a40b8bce6f8
Submitter: Zuul
Branch: master

commit 86175e8f557f1f7930e097cab8345a40b8bce6f8
Author: Rajiv Kumar <email address hidden>
Date: Mon May 7 21:18:29 2018 +0530

    Enabled feature negotation for qos rules

    This patch enables feature negotiations for qos rules. Now
    configuration of rules are being fetched from the get_config
    api of the odl_feature

    Change-Id: Iacba50efe8fc4eee3ebac14423852aa87f2d72e8
    Closes-bug: #1686625

Changed in networking-odl:
status: In Progress → Fix Released

This issue was fixed in the openstack/networking-odl 13.0.0.0rc1 release candidate.

Change abandoned by Michel Peterson (<email address hidden>) on branch: master
Review: https://review.openstack.org/558554
Reason: Cleaning up changes that seem to be abandoned or are older than two months. If you think this was an error and the change is still relevant, please be free to restore it. Sorry for any inconvenience that I might have caused by this.

Change abandoned by Lucas Alvares Gomes (<email address hidden>) on branch: stable/pike
Review: https://review.openstack.org/589538
Reason: Michel Peterson, done

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers