test_update_firewall_calls_get_dvr_hosts_for_router failure on rocky

Bug #1847019 reported by YAMAMOTO Takashi on 2019-10-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
networking-midonet
Critical
Unassigned
neutron
Critical
Unassigned

Bug Description

eg. https://storage.bhs1.cloud.ovh.net/v1/AUTH_dcaab5e32b234d56b626f72581e3644c/zuul_opendev_logs_5f4/686959/1/check/openstack-tox-py27/5f405a7/testr_results.html.gz

ft1.24: midonet.neutron.tests.unit.test_extension_fwaas.FirewallTestCaseML2.test_update_firewall_calls_get_dvr_hosts_for_router_StringException: Traceback (most recent call last):
  File "/home/zuul/src/opendev.org/openstack/networking-midonet/.tox/py27/local/lib/python2.7/site-packages/neutron/tests/base.py", line 181, in func
    return f(self, *args, **kwargs)
  File "/home/zuul/src/opendev.org/openstack/networking-midonet/.tox/py27/local/lib/python2.7/site-packages/neutron/tests/base.py", line 181, in func
    return f(self, *args, **kwargs)
  File "/home/zuul/src/opendev.org/openstack/networking-midonet/.tox/py27/local/lib/python2.7/site-packages/neutron_fwaas/tests/unit/services/firewall/test_fwaas_plugin.py", line 398, in test_update_firewall_calls_get_dvr_hosts_for_router
    'get_l3_agents_hosting_routers') as s_hosts, \
  File "/home/zuul/src/opendev.org/openstack/networking-midonet/.tox/py27/local/lib/python2.7/site-packages/mock/mock.py", line 1369, in __enter__
    original, local = self.get_original()
  File "/home/zuul/src/opendev.org/openstack/networking-midonet/.tox/py27/local/lib/python2.7/site-packages/mock/mock.py", line 1343, in get_original
    "%s does not have the attribute %r" % (target, name)
AttributeError: <midonet.neutron.services.l3.l3_midonet.MidonetL3ServicePlugin object at 0x7f2f124b81d0> does not have the attribute 'get_l3_agents_hosting_routers'

tags: added: fwaas gate-failure
Changed in networking-midonet:
importance: Undecided → Critical
Slawek Kaplonski (slaweq) wrote :

I don't this issue affects neutron so I'm removing it from the list of affected projects for now.

no longer affects: neutron
YAMAMOTO Takashi (yamamoto) wrote :

slaweq, aren't neutron-fwaas issues tracked with neutron?

Bernard Cafarelli (bcafarel) wrote :

They are (I was surprised recently when I did not find a neutron-fwaas project trying to move a neutron bug to it), adding back neutron also for https://review.opendev.org/#/c/687085/

Changed in neutron:
status: New → In Progress
Slawek Kaplonski (slaweq) wrote :

@Yamamoto: sorry for mistake. I though that neutron-fwaas has got own project to track bugs.
@Bernard: thx a lot for adding it back.

Slawek Kaplonski (slaweq) wrote :
Changed in neutron:
importance: Undecided → Critical
status: In Progress → Fix Committed
Changed in networking-midonet:
status: New → Fix Committed
YAMAMOTO Takashi (yamamoto) wrote :

Slawek,

i guess you meant https://review.opendev.org/#/c/687085/ .
it hasn't been merged yet.

Slawek Kaplonski (slaweq) wrote :

Right Yamamoto. Too many opened bugs and wrong copy/paste :)

Changed in networking-midonet:
status: Fix Committed → Confirmed
Changed in neutron:
status: Fix Committed → In Progress

Reviewed: https://review.opendev.org/687085
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas/commit/?id=fc59b08ff78456c98fee0cc187f8888bc99c333e
Submitter: Zuul
Branch: stable/rocky

commit fc59b08ff78456c98fee0cc187f8888bc99c333e
Author: Ryan Tidwell <email address hidden>
Date: Mon Oct 7 10:46:53 2019 -0500

    Fix AttributeError with third-party L3 service plugins

    A recent patch fix for the Rocky branch from
    commit 20fd02611674da5365e93d06f330d1f76fd71e3e have introduced an
    AttributeError on Third Party Plugins that does not implement
    certain extensions.

    This is just related to FWaaSv1 and only applicable to Rocky and below
    releases.

    This change fixes an issue where in the course of sending firewall
    update notifications to the appropriate agents an AttributeError
    is encountered due to unsafe assumption of the availability of L3
    extensions on the l3_plugin.

    This change puts protections in place to avoid this issue.

    Change-Id: If5fde4fc9475f468860b0c1fb29db66f1c44f74e
    Closes-Bug: #1847019

tags: added: in-stable-rocky
Slawek Kaplonski (slaweq) wrote :

Now as https://review.opendev.org/687085 is merged we can consider this as fixed.

Changed in neutron:
status: In Progress → Fix Committed
Changed in networking-midonet:
status: Confirmed → Fix Committed

Reviewed: https://review.opendev.org/688988
Committed: https://git.openstack.org/cgit/openstack/neutron-fwaas/commit/?id=4c05f1f6617b49f6cc2dfb6c976e93c2a54d41bf
Submitter: Zuul
Branch: stable/queens

commit 4c05f1f6617b49f6cc2dfb6c976e93c2a54d41bf
Author: Ryan Tidwell <email address hidden>
Date: Mon Oct 7 10:46:53 2019 -0500

    Fix AttributeError with third-party L3 service plugins

    A recent patch fix for the Rocky branch from
    commit 20fd02611674da5365e93d06f330d1f76fd71e3e have introduced an
    AttributeError on Third Party Plugins that does not implement
    certain extensions.

    This is just related to FWaaSv1 and only applicable to Rocky and below
    releases.

    This change fixes an issue where in the course of sending firewall
    update notifications to the appropriate agents an AttributeError
    is encountered due to unsafe assumption of the availability of L3
    extensions on the l3_plugin.

    This change puts protections in place to avoid this issue.

    Change-Id: If5fde4fc9475f468860b0c1fb29db66f1c44f74e
    Closes-Bug: #1847019
    (cherry picked from commit fc59b08ff78456c98fee0cc187f8888bc99c333e)

tags: added: in-stable-queens

This issue was fixed in the openstack/neutron-fwaas 12.0.2 release.

This issue was fixed in the openstack/neutron-fwaas 13.0.3 release.

Change abandoned by Bernard Cafarelli (<email address hidden>) on branch: stable/rocky
Review: https://review.opendev.org/686966
Reason: https://review.opendev.org/#/c/687085/ is the proper fix, closing this one (feel free to reopen if I did not read it correctly)

Changed in neutron:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers