Translation for "Wired Connection %s" not displayed

Bug #875017 reported by Hendrik Knackstedt on 2011-10-15
36
This bug affects 6 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
Ubuntu Translations
Medium
Unassigned
network-manager (Ubuntu)
Undecided
Mathieu Trudel-Lapierre

Bug Description

The string "Wired Connection %d" (where %d is a number) which is displayed when you connect to the Internet using an ethernet cable does show up in English, although there is a translation available and has been submitted in time. If you have an ethernet cable connected the string also appears when you click the network-icon.

You'll find the affected string here:
https://translations.launchpad.net/ubuntu/oneiric/+source/network-manager-applet/+pots/nm-applet/de/+translate?batch=10&show=all&search=wired+connection

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: network-manager-gnome 0.9.1.90-0ubuntu6
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
Date: Sat Oct 15 15:15:51 2011
IfupdownConfig:
 auto lo
 iface lo inet loopback
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
IpRoute:
 default via 192.168.2.1 dev eth0 proto static
 169.254.0.0/16 dev eth0 scope link metric 1000
 192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.124 metric 1
 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.121 metric 2
Keyfiles: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager-applet
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (1 days ago)

Related branches

Hendrik Knackstedt (hennekn) wrote :
Gabor Kelemen (kelemeng) wrote :

I see this too, but only with the connection created automatically. I have started the Live CD in German, clicked the network icon, and "Wired Connection 1" appears untranslated. If I choose Edit Connections from the menu, then I try to create a new wired connection, the proposed default name appears translated just fine.

Gabor Kelemen (kelemeng) on 2011-10-15
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in network-manager-applet (Ubuntu):
status: New → Confirmed
Märt Põder (boamaod) wrote :

Any workarounds for that, that can be used in remastered ISO images? Can I predefine the default network connection name somehow?

Download full text (3.4 KiB)

Hello,

I had a quick look at the code and from what I understood the translation
for "Wired Connection %d" is just valid for the file
"../src/connection-editor/page-wired.c../src/connection-editor/page-wired.c"
[1], so I think the German po-file has to be edited to include the string
for the correct c-file.

Regards,
Joshua

[1]
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/network-manager-applet/oneiric/view/head:/po/de.po:1788-1791

1788 *#: ../src/connection-editor/page-wired.c:348*
1789 #, c-format
1790 msgid "Wired connection %d"
1791 msgstr "Kabelnetzwerkverbindung %d"

2011/10/31 tabbernuk <email address hidden>
>
> Any workarounds for that, that can be used in remastered ISO images? Can
> I predefine the default network connection name somehow?
>
> --
> You received this bug notification because you are a member of Ubuntu
> German Translators (Community-Team), which is subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/875017
>
> Title:
> Translation for "Wired Connection %s" not displayed
>
> Status in Ubuntu Translations:
> Triaged
> Status in “network-manager-applet” package in Ubuntu:
> Confirmed
>
> Bug description:
> The string "Wired Connection %d" (where %d is a number) which is
> displayed when you connect to the Internet using an ethernet cable
> does show up in English, although there is a translation available and
> has been submitted in time. If you have an ethernet cable connected
> the string also appears when you click the network-icon.
>
> You'll find the affected string here:
>
https://translations.launchpad.net/ubuntu/oneiric/+source/network-manager-applet/+pots/nm-applet/de/+translate?batch=10&show=all&search=wired+connection
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: network-manager-gnome 0.9.1.90-0ubuntu6
> ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
> Uname: Linux 3.0.0-12-generic-pae i686
> NonfreeKernelModules: nvidia
> ApportVersion: 1.23-0ubuntu3
> Architecture: i386
> CRDA: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
> Date: Sat Oct 15 15:15:51 2011
> IfupdownConfig:
> auto lo
> iface lo inet loopback
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386
(20110427.1)
> IpRoute:
> default via 192.168.2.1 dev eth0 proto static
> 169.254.0.0/16 dev eth0 scope link metric 1000
> 192.168.2.0/24 dev eth0 proto kernel scope link src 192.168.2.124
 metric 1
> 192.168.2.0/24 dev wlan0 proto kernel scope link src 192.168.2.121
 metric 2
> Keyfiles: Error: [Errno 2] Datei oder Verzeichnis nicht gefunden
> NetworkManager.state:
> [main]
> NetworkingEnabled=true
> WirelessEnabled=true
> WWANEnabled=true
> ProcEnviron:
> PATH=(custom, no user)
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> RfKill:
> 0: phy0: Wireless LAN
> Soft blocked: no
> Hard blocked: no
> SourcePackage: network-manager-applet
> UpgradeStatus: Upgraded to oneiric on 2011-10-14 (1 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-translations/+bug/875017/+subscriptions
>
> _______________________________________________
> Mailing...

Read more...

Gabor Kelemen (kelemeng) wrote :

Joshua: no, you completely misunderstood the working of gettext. Identical strings are represented only once in po files, and the comment line is only informational, the mo files do not contain them.

On the other hand, I think I have found the problem. This untranslated string does not come from the nm-applet connection wizard, but from network-manager itself:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/network-manager/oneiric/view/head:/src/settings/nm-settings-utils.c

I have only guesses on why does it not appear translated. i18n support seems to be all good in NM, but obviously it isn't.

Märt Põder (boamaod) wrote :

Most non-hackish workaround for bypassing this bug when generating localized ISO images seems to be providing localized connection description under /etc/NetworkManager/system-connections.

Hendrik Knackstedt (hennekn) wrote :

Still a problem in Precise.

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → New
Changed in network-manager:
status: New → Invalid
Märt Põder (boamaod) wrote :

From the GNOME bug tracker:

The default connection name is created by NetworkManager daemon. So, in order
to have the string translated, you have to run the daemon with German locale,
something like:
LANG=de_DE /usr/sbin/NetworkManager

Gabor Kelemen (kelemeng) on 2011-12-20
affects: network-manager-applet (Ubuntu) → network-manager (Ubuntu)
Gabor Kelemen (kelemeng) wrote :

Okay, I have figured it out and reopened the upstream bug. The interesting part is this: http://bugzilla-attachments.gnome.org/attachment.cgi?id=204033
Starting NM from the command line after applying this patch results in the "Wired connection 1" string being translated.
However when starting NM as a service the string shows up untranslated, so something else is wrong. Maybe upstart does not pass the environment to the services it starts?

Changed in network-manager:
status: Invalid → New
Changed in network-manager:
status: New → Fix Released
Gabor Kelemen (kelemeng) wrote :

Current package in Precise has the fix for the upstream part of this bug.
Now the Ubuntu-specific task left is to tell NM the locale, this can be done with a few lines stolen from mountalls upstart job. After adding these, the string appears translated for me.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.2.0+git201202161854.8572ecf-0ubuntu4

---------------
network-manager (0.9.2.0+git201202161854.8572ecf-0ubuntu4) precise; urgency=low

  [ Gabor Kelemen ]
  * debian/network-manager.upstart: Make NM aware of the locale. (LP: #875017)

  [ Mathieu Trudel-Lapierre ]
  * debian/patches/lp936712_dnsmasq_ip6_ns_ordering.patch: order IPv6
    nameservers before IPv4 ones in dnsmasq config: dnsmasq is able to properly
    deal with broken IPv6 nameservers (or routers). (LP: #936712)
  * debian/control: add Conflicts: connman to network-manager. (LP: #659460)
  * debian/patches/manage-privacy-extensions.patch: set the default for using
    IPv6 Privacy extensions to TRUE; this is just correcting an oversight from
    adapting the upstream patch. (LP: #176125)
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 21 Feb 2012 19:40:35 -0500

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) on 2012-02-22
Changed in ubuntu-translations:
status: Triaged → Fix Released
TomasHnyk (sup) wrote :

BTW: this seems ti have introduced a bug that prevents Network Manager from starting correctly upon boot if there is a typo in locale, see bug 1192514, the fix seems to be easy.

Pascal S (pascal.s) wrote :

I am experiencing this bug with Ubuntu 14.10.
nm-applet displays "wired" though I expect it to be translated in French.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.