live-cd boot does not work with nvidia ion (ZOTAC GeForce 9300-ITX WiFi) nor with GeForce 210

Bug #661235 reported by typo on 2010-10-15
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
NetworkManager
New
Undecided
Unassigned
xserver-xorg-video-nouveau (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-nouveau

When I want to boot Ubuntu 10.04 or 10.10 using the desktop cd, the boot always freezes. I have a ZOTAC GeForce 9300-ITX WiFi. I think it's because of nouveau, because when I tried it on my system, which normally uses official nvidia driver, the boot will freeze the same way. I used an live-cd of an older version of Ubuntu, which works fine, to repair the system by setting Xorg.conf to use the nvidia driver.

Currently I'm using Ubuntu 10.04 LTS with the mainline 2.6.34 kernel, because the current-nvidia driver always crashs with the original kernel.

I would like you to blacklist my graphic card at least, so that I can use the desktop-cd with the vesa driver.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: xserver-xorg-video-nouveau 1:0.0.15+git20100219+9b4118d-0ubuntu5
Uname: Linux 2.6.34-020634-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Oct 15 15:11:59 2010
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: xserver-xorg-video-nouveau
system:
 distro: Ubuntu
 codename: lucid
 architecture: i686
 kernel: 2.6.34-020634-generic

typo (gnomeuser8) wrote :
typo (gnomeuser8) wrote :

The freeze occurs in the middle of the Plymouth boot animation.

Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we can't start working on it yet, because your description didn't include enough information. Please include the information requested at https://wiki.ubuntu.com/DebuggingCasper as separate attachments. Thanks in advance.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Incomplete
Book 'em Dano (heymrdjd) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. While we appreciate the difficulties you are facing, it would appear that the CD image (ISO file) you downloaded could be corrupt. There is an easy way to verify the integrity of the Ubuntu ISO files you download. Could you please visit https://help.ubuntu.com/community/HowToMD5SUM follow the instructions and report back as to whether or not the MD5SUM verified? Thanks in advance.

typo (gnomeuser8) wrote :

"md5sum" takes too much time for me or does not work at all. I've downloaded the ISO files using Transmission, which should check the hash automatically. I also tried various disk images (10.04, 10.04.1 64bit, 10.04.1 32bit, 10.10). They work well on other computers, but not on mine.

typo (gnomeuser8) wrote :

I've followed "DebuggingCasper" tutorial with my "Ubuntu 10.10 amd64 desktop" disk and created an photograph of the screen with hopefully useful error messages.

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: Incomplete → New
typo (gnomeuser8) wrote :

I've also tested now Ubuntu 10.04.1 live cd and it works properly (in contrast to Ubuntu 10.10 live cd, which works not at all). Screen resolution is also correct (1920*1200). So it seems to be an regression.

typo (gnomeuser8) wrote :
Book 'em Dano (heymrdjd) wrote :

I can't see all that is going on with your pc, but at least in the pic you provide there is a reference to a kernel panic... can't tell if anything with nouveau is going on. It would be extremely helpful if you could provide some logs. I'll check to see if I can provide you with another way to obtain them.

I still think you need to check the md5sum of the 10.10 CD's you burned, the pieces of the .iso are checked when you download the torrent, but there could have been an error while the iso was burned.

typo (gnomeuser8) wrote :

$ sh ./hashtocdrom.sh ./Downloads/ubuntu-10.10-desktop-amd64.iso
/usr/bin/md5deep
checksum for input image: 1b9df87e588451d2ca4643a036020410
checksum for output disk: 1b9df87e588451d2ca4643a036020410
verification successful!

typo (gnomeuser8) wrote :

I disabled the "nvidia" driver and rebooted the system. It occurred no kernel panic, as I would expect, but nouveau failed and vesa worked instead. See the attached log for details.

driden91 (driden91) wrote :

hello

i have exactly the same problem with the same motherboard.

I must use an older ubuntu for it works

( sorry for my english)

typo (gnomeuser8) wrote :

Hello driden91, you can select the "this bug affects me" option.

I bought a new graphics adaptor to replace my old ATI one. The model I chose is a Gainward GeForce 210 1024MB DDR2 HDMI.

Upon installing the new adaptor my Ubuntu 10.10 64bit system froze on reboot. I tried booting from the 64 and 32 bit CDs always producing the same result - freezing.

After changing the grub command line options to "nouveau.blacklist=1" (as suggested somewhere on the web) I could boot my system and install the NVIDIA driver instead which works fine, however, I no longer get a bootsplash. Consecutively I made it a default in /etc/default/grub to keep my system from freezing.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nouveau.blacklist=1"

I did an lspic -vv, maybe it helps:

01:00.0 VGA compatible controller: nVidia Corporation GT218 [GeForce 210] (rev a2) (prog-if 00 [VGA controller])
 Subsystem: CardExpert Technology Device 1401
 Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
 Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
 Latency: 0, Cache Line Size: 32 bytes
 Interrupt: pin A routed to IRQ 11
 Region 0: Memory at d0000000 (32-bit, non-prefetchable) [size=16M]
 Region 1: Memory at b0000000 (64-bit, prefetchable) [size=256M]
 Region 3: Memory at c0000000 (64-bit, prefetchable) [size=32M]
 Region 5: I/O ports at 9000 [size=128]
 Expansion ROM at d1000000 [disabled] [size=512K]
 Capabilities: <access denied>
 Kernel modules: nouveau, nvidiafb

Anyway, I thought I might report this bug as a frozen system might be a real showstopper for any Linux newbies. I'd be grateful, if anybody could look into this.

summary: live-cd boot does not work with nvidia ion (ZOTAC GeForce 9300-ITX WiFi)
+ nor with GeForce 210
typo (gnomeuser8) wrote :

I've reinstalled Ubuntu using the Ubuntu 10.04.1 live-cd (32-bit) and then upgraded to Ubuntu 10.10. I'm using Ubuntu 10.10 with nouveau on my nvidia ion hardware right now. The bug seems to be somewhere else in the live-cd, e.g. casper. Therefore I propose to divide my problem from the problem of Martin O'Mahony.

I tried the Natty Alpha 1 live-cd and the problem persists. The computer freezes upon starting nouveau. :-(

@typo: If only I knew how to separate my bug description, I'd be more than willing to do so. Or do I rather need to start a new bug report?

Summary: Natty alpha 1 live-cd does not work with GeForce 210.

Geoffrey McClinsey (geoffmcc) wrote :

You wouldn't by any chance have a dual display set-up or be using a non VGA connection are you. Even if your are not check your bios and see if dual display is enabled (Advanced Chipset in my bios).

I found if it is enabled and set to primary video AUTO or PCI-E and you are using a (in my case) HDMI connection the install will fail. Fails right after plymouth and just flashes a blinking _ in the upper left. Eventually displays Samsungs default NO Connection Msg.

My Setup is:
1 TV Plugged in threw HDMI
1 CRT monitor plugged in threw onboard VGA

BIOS / Advanced Chipset

1.)

Dual Display - Enabled // Primary Video - Auto ---> Will NOT work (displays on flatscreen)
Dual Display - Enabled // Primary Video - PCI-E ---> Will NOT work
Dual Display - Enabled // Primary Video - VGA ---> Works Everytime (if you also have a old CRT monitor connected)

2.)

Dual Display - Disabled // Primary Video - Auto ---> WORKS (displays on flatscreen)
Dual Display - Disabled // Primary Video - PCI-E ---> WORKS
Dual Display - Disabled // Primary Video - VGA ---> WORKS

* I recall one of the above 3 getting past install but then failing after restart with same black screen. I think it was auto. Unfortunately I forgot to document that one. But I have documented that PCI-E did work, so its not clear to me why auto would fail and PCI-E would work when they both were using the PCI-E connection. This might have just been a mishap but after trying to install so much once it got installed I did not want to try to recreate problem. Can someone verify?

3. (HDMI Connection and a VGA to DVI Adapter Connection)

Dual Display - Enabled // Primary Video - Auto ---> WORKS (displays on flatscreen)
Dual Display - Enabled // Primary Video - PCI-E ---> WORKS
Dual Display - Enabled // Primary Video - VGA ---> WORKS

So to me it appears this driver does not work properly with the BIOS having Dual Display Enabled.

Geoffrey McClinsey (geoffmcc) wrote :

Also i think its trying to display gdm not freezing. You just cant ctrl alt del out of it because it brought down your keyboard. Once gdm loads the keyboard would normally be brought back up. You should notice, or at least it did for me the keyboard lights shutting off right after plymouth finishes. After about 2 or 3 minutes it will restart on its own.

Geoff,

Thank you so much for taking a look into this. I really appreciate it.

I'll post my comment to:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/713867

typo (gnomeuser8) wrote :

The same sort of kernel panic as with Ubuntu 10.10 seems to happen with Ubuntu 11.10, too. (NetworkManager)

Bryce Harrington (bryce) wrote :

[Kernel panic indicates a bug in the kernel rather than X]

Likely this bug is something in the linux kernel's nouveau drm driver. If that's true, then booting a newer version of the kernel might resolve it. Has anyone tested if this issue still exists with Lucid 10.04.4?

As we're on the cusp of the next LTS release, it would be worth testing if this issue exists in the 12.04 beta. This can be checked using a USB live image. You can get it at http://cdimage.ubuntu.com/daily/current/, and use USB Disk Creator to make a boot drive. Please update this bug report once you've tested. (If you've already tested any version of ubuntu newer than Lucid and already know it works, that's sufficient testing, just mention that here.)

Changed in xserver-xorg-video-nouveau (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers