huawei e182e usb-modem not working

Bug #513039 reported by Daniel Holm on 2010-01-27
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Undecided
Unassigned
network-manager (Ubuntu)
Undecided
MIchael Ringler

Bug Description

Binary package hint: network-manager

It worked five days ago, but not anymore. It just worked when I plugged it in (after removing PIN from the SIM). But then, five days later, it just did not work..

Neither mounting or unmounting the local filesystem on the modem makes a difference.

lsusb:
Bus 002 Device 009: ID 12d1:14ac Huawei Technologies Co., Ltd.

ProblemType: Bug
Architecture: amd64
CRDA: Error: [Errno 2] Filen eller katalogen finns inte
Date: Wed Jan 27 02:18:48 2010
DistroRelease: Ubuntu 9.10
IfupdownConfig:
 auto lo
 iface lo inet loopback
IpRoute:
 192.168.5.0/24 dev wlan1 proto kernel scope link src 192.168.5.4 metric 2
 169.254.0.0/16 dev wlan1 scope link metric 1000
 default via 192.168.5.1 dev wlan1 proto static
NonfreeKernelModules: nvidia
Package: network-manager 0.8~a~git.20091013t193206.679d548-0ubuntu1
ProcEnviron:
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: network-manager
Uname: Linux 2.6.31-17-generic x86_64

Daniel Holm (danielholm) wrote :
Daniel Holm (danielholm) wrote :

After yesterdays new upgrades with the kernel (among other things) the modem now works again with no manual work.

Changed in network-manager:
status: New → Fix Released
Changed in network-manager (Ubuntu):
status: New → Fix Released
MIchael Ringler (ringler) wrote :

I Have the same problem
ubuntu 10.04 up to date

But if i start windows first and login, and then reboot without repluggin the device, it works. othervise nothing

Changed in network-manager (Ubuntu):
assignee: nobody → MIchael Ringler (ringler)
Felipe Rojas (jotaefe-cl) wrote :

Sorry if I don't get it....is this bug fixed?....my huawei e182e doesn't work with my ubuntu 10.04....thanks for your time....

MIchael Ringler (ringler) wrote :

http://ubuntuforums.org/showthread.php?t=1307277

this worked for my e182 even though it is for 1550
 you will have to enter pin manualy though

hinge (martinhinge) wrote :

Michael, did you install the udev-extras... Does this package exist on 10.04 ? What part of the link fixed the problem.
Have the E182E, it does not show up as a modem

MIchael Ringler (ringler) wrote :

Yes i installed udev extras (if i remember right it said something about udev-extras being a part uf udev now)
 sudo apt-get update && sudo apt-get install udev-extras

and then ran this command and did a reboot.

echo 'SUBSYSTEM=="usb", SYSFS{idProduct}=="1446", SYSFS{idVendor}=="12d1", RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"' | sudo tee /etc/udev/rules.d/45-huawei1550.rules

Then it showed up. but still looped forever if i just tryed to connect, but after entering the pin manualy it worked.

Btw before the fix i was able to get it working by loggin in to my windows 7 connect to the internet, and then reboot without plugging the usb out, because it remembers the pin and mode or something. so it showed up and i was able to connect and get the rest working :)

MIchael Ringler (ringler) wrote :

**then it showed up but looped forever

no still at the beginning it didnt show up

StefanHuszics (stefan-huszics) wrote :

I got the HUAWEI E182E to work on two laptops with the following procedure.

1) gksu gedit /etc/udev/rules.d/15-huawei-e182e.rules

2) Paste and save the following

SUBSYSTEM==”usb”,
SYSFS{idProduct}==”1446″,
SYSFS{idVendor}==”12d1″,
RUN+=”/lib/udev/modem-modeswitch -v 0x12d1 -p 0×1446 -t option-zerocd”

3) Restart computer (or at least udev)

After this it still didnt work, so I tried to also

4) sudo apt-get install usb-modeswitch

and after next insert of the modem it was found and all I had to do was to add a new mobile broadband internet connection for HUAWEI in the connection manage and it worked just fine. Of course I don't know if step 1-3 is actually necessary or not, but I thought I better write too much info than too little. :)

Interestingly enough, the memorystick part of the modem is still visible and reachable/browsable as a CD, but it properly switches from :1446 to :14ac and works just fine as a modem as well at the same time. Maybe this has to do with the presence of the micro sd slot on the modem.

StefanHuszics (stefan-huszics) wrote :

BTW the two laptops above was running Ubuntu and Xubuntu 10.04 respectively, both fully updated.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers