[ipv6] Network manager incorrectly lowers MTU when IPv6 is enabled

Bug #1499827 reported by Bryan Quigley on 2015-09-25
66
This bug affects 11 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
High
Unassigned
Wily
High
Mathieu Trudel-Lapierre

Bug Description

[Impact]
Users with IPv6-supporting networks will see the messages below in the bug description appear repeatedly as NM mistakes a 0 value for MTU in internal NM code with 0-size packets instead of meaning "use default MTU".

[Test case]
- Run network-manager on a network supporting IPv6.
- Check /var/log/syslog for <warn> messages from NetworkManager.

[Regression Potential]
This changes behavior for handling the MTU value for IPv6, which should be no higher than the device MTU. Since 0 is an invalid value for MTU anyway, this should not otherwise affect MTU handling for devices.
Possible regressions from the change might include invalid (too high) set MTU for a device due to the failure to recognize cases where the MTU needs to be adjusted, leading to packet loss on IPv6.

--

Network manager is sending out a lot of warnings about changing the MTU:
Sep 25 14:13:03 desktop NetworkManager[703]: <warn> (wlan0): Lowering IPv6 MTU (1480) to match device MTU (1280)
Sep 25 14:13:21 desktop NetworkManager[703]: <warn> (wlan0): Lowering IPv6 MTU (1480) to match device MTU (0)
Sep 25 14:13:21 desktop NetworkManager[703]: <warn> (wlan0): IPv6 MTU (0) smaller than 1280, adjusting
Sep 25 14:13:21 desktop NetworkManager[703]: <warn> (wlan0): Raising device MTU (0) to match IPv6 MTU (1280)
Sep 25 14:13:29 desktop NetworkManager[703]: <warn> (wlan0): Lowering IPv6 MTU (1480) to match device MTU (1280)

Lowering IPv6 MTU (1480) to match device MTU (1280) repeats about 16 times between the other messages (about 2 mins round).

This doesn't appear to be Ubuntu specific - https://bbs.archlinux.org/viewtopic.php?pid=1552751

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: network-manager 1.0.4-0ubuntu3
ProcVersionSignature: Ubuntu 4.2.0-11.13-generic 4.2.1
Uname: Linux 4.2.0-11-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Sep 25 14:09:20 2015
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2015-01-08 (259 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20150108)
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: network-manager
UpgradeStatus: Upgraded to wily on 2015-08-12 (43 days ago)
nmcli-nm: Error: command ['nmcli', '-f', 'all', 'nm'] failed with exit code 2: Error: Object 'nm' is unknown, try 'nmcli help'.

Bryan Quigley (bryanquigley) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Bryan Quigley (bryanquigley) wrote :

This has been fixed upstream as part of 1.0.6

Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in network-manager (Ubuntu):
importance: Undecided → High
Pasi Sjöholm (pasi-sjoholm) wrote :

This should get a fixed into 15.10 as it is basically killing IPv6 network connectivity.

nemith (bennetb) wrote :

I was able to rebuild the network-manager package with the following two upstream patches applied (applied cleanly)

http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=a92d8b0c678e17d1cc175c3aad50afb1443785d2
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=c44069c10a4a9c696910baf0dbbefc41528f6dbe

It seemed to have fixed the issue. (there are a bunch of build issues i have ran into as well, with both rebuilding as well as tests which fail even with zero patches applied) which made this even more of a huge pain. Without dedicating hours (days?) into learning how to build ubuntu packages properly I cannot help anyone else.

I would imagine this would be trivial to add the two patches and release a new version if you are already a package maintainer.

nemith (bennetb) on 2015-11-04
summary: - [ipv6] Network manager spews logs of Lowering IPv6 MTU (1480) to match
- device MTU (1280)
+ [ipv6] Network manager incorrectly lowers MTU when IPv6 is enabled

The fix for this has landed in xenial-proposed; and should transition to xenial-release shortly with the fix. Once that is done, we can SRU the update to the Wily release.

Changed in network-manager (Ubuntu):
status: Confirmed → Fix Committed
Changed in network-manager (Ubuntu Wily):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.0.4-0ubuntu7

---------------
network-manager (1.0.4-0ubuntu7) xenial; urgency=medium

  * debian/patches/lp1499827_device_avoid_undefined_mtu_c44069c1.patch
    Cherry-pick commit c44069c1 from upstream: avoid changing the MTU if it's
    undefined in NM code. (LP: #1499827)
  * debian/patches/lp1499827_dont_change_unset_mtu_a92d8b0c.patch:
    Cherry pick upstream commit a92d8b0c: don't change the MTU if we have a
    value of 0 for it; it means "default", not "0 size packets". (LP: #1499827)

 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 24 Nov 2015 16:13:37 -0500

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released

Uploaded network-manager 1.0.4-0ubuntu5.2 to wily-proposed for review and approval by the SRU team.

description: updated

Hello Bryan, or anyone else affected,

Accepted network-manager into wily-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.0.4-0ubuntu5.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in network-manager (Ubuntu Wily):
status: Triaged → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Pedro Morales (pedratan) wrote :

The package in proposed is working for me.
I no longer need to set MTU by hand for the wireless to connect

The verification of the Stable Release Update for network-manager has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.0.4-0ubuntu5.2

---------------
network-manager (1.0.4-0ubuntu5.2) wily; urgency=medium

  * debian/patches/lp1499827_device_avoid_undefined_mtu_c44069c1.patch
    Cherry-pick commit c44069c1 from upstream: avoid changing the MTU if it's
    undefined in NM code. (LP: #1499827)
  * debian/patches/lp1499827_dont_change_unset_mtu_a92d8b0c.patch:
    Cherry pick upstream commit a92d8b0c: don't change the MTU if we have a
    value of 0 for it; it means "default", not "0 size packets". (LP: #1499827)

 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 27 Nov 2015 14:03:32 -0500

Changed in network-manager (Ubuntu Wily):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.