Incorrect MTU on VPN connect

Bug #1498474 reported by David Burrows on 2015-09-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
network-manager (Ubuntu)
High
Mathieu Trudel-Lapierre

Bug Description

On update to wily, vpnc vpn connects, but MTU is incorrectly set to 1500, instead of default value which is 1412. This results in connectivity issues (packet loss).

Gnomezilla bug report: https://bugzilla.gnome.org/show_bug.cgi?id=754781

I have attached the included patch from above for convenience, and tested that this indeed resolves the issue for me.

It might be worth mentioning that I had to disable the built in tests (--enable-tests=no), or pakage generation with "debuild -us -uc -b" fails on 2 of the tests relating to ipv6.

David Burrows (snadge) wrote :
description: updated
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → In Progress

The attachment "upstream patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in network-manager (Ubuntu):
importance: Undecided → High
tags: added: rls-w-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
Changed in network-manager:
status: In Progress → Fix Released
Changed in network-manager (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)

Already committed to the n-m packaging branch, will upload shortly.

Changed in network-manager (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.0.4-0ubuntu5

---------------
network-manager (1.0.4-0ubuntu5) wily; urgency=medium

  * debian/patches/git_set_vpn_mtu_9736327b.patch: set the MTU for the VPN
    interface. (LP: #1498474)
  * debian/patches/lp1446689_git_use_kernel_pppoe_6fdfb031.patch: use the
    kernel-provided pppoe interfaces rather than requiring the use of rp-pppoe
    to use PPPoE; we switched to rp-pppoe some time ago to workaround a bug in
    detecting disconnects which has seen been fixed and could be worked around
    fairly simply with the right configuration. (LP: #1446689)
  * debian/rules: don't pass --with-pppoe to configure; the option is removed
    by the above patch.

 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 14 Oct 2015 12:33:53 -0400

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.