nmcli crashed with SIGSEGV in show_device_info()

Bug #1155139 reported by Daniel Aleksandersen on 2013-03-14
176
This bug affects 21 people
Affects Status Importance Assigned to Milestone
NetworkManager
New
Undecided
Unassigned
network-manager (Ubuntu)
Critical
Mathieu Trudel-Lapierre
Raring
Critical
Unassigned
Saucy
Critical
Mathieu Trudel-Lapierre

Bug Description

During checkbox system testing.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: network-manager 0.9.8.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
CRDA:
 country NO:
  (2402 - 2482 @ 40), (N/A, 20)
  (5170 - 5250 @ 40), (N/A, 20)
  (5250 - 5330 @ 40), (N/A, 20), DFS
  (5490 - 5710 @ 40), (N/A, 27), DFS
CrashCounter: 1
Date: Thu Mar 14 14:35:48 2013
ExecutablePath: /usr/bin/nmcli
IfupdownConfig:
 # interfaces(5) file used by ifup(8) and ifdown(8)
 auto lo
 iface lo inet loopback
InstallationDate: Installed on 2013-01-03 (69 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
IpRoute:
 default via 192.168.10.1 dev wlan1 proto static
 169.254.0.0/16 dev wlan1 scope link metric 1000
 192.168.10.0/24 dev wlan1 proto kernel scope link src 192.168.10.24 metric 9
MarkForUpload: True
NetworkManager.state:
 [main]
 NetworkingEnabled=true
 WirelessEnabled=true
 WWANEnabled=true
 WimaxEnabled=true
ProcCmdline: nmcli dev list
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SegvAnalysis:
 Segfault happened at: 0x41331e: mov 0x8(%r13),%edi
 PC (0x0041331e) ok
 source "0x8(%r13)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: network-manager
StacktraceTop:
 ?? ()
 g_ptr_array_foreach () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 do_devices ()
 ?? ()
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: nmcli crashed with SIGSEGV in g_ptr_array_foreach()
UpgradeStatus: Upgraded to raring on 2013-03-13 (1 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
mtime.conffile..etc.NetworkManager.NetworkManager.conf: 2013-01-04T09:39:07.434361
nmcli-dev:
 DEVICE TYPE STATE DBUS-PATH
 wlan1 802-11-wireless connected /org/freedesktop/NetworkManager/Devices/1
 eth0 802-3-ethernet unavailable /org/freedesktop/NetworkManager/Devices/0
nmcli-nm:
 RUNNING VERSION STATE NET-ENABLED WIFI-HARDWARE WIFI WWAN-HARDWARE WWAN
 running 0.9.8.0 connected enabled enabled enabled enabled disabled

Daniel Aleksandersen (da2x) wrote :

StacktraceTop:
 show_device_info (data=<optimized out>, user_data=<optimized out>) at devices.c:912
 g_ptr_array_foreach (array=array@entry=0x10530a0, func=func@entry=0x412a30 <show_device_info>, user_data=user_data@entry=0x7fff03ff12d0) at /build/buildd/glib2.0-2.35.8/./glib/garray.c:1456
 do_devices_list (argv=0x7fff03ff1500, argc=0, nmc=0x7fff03ff12d0) at devices.c:1097
 do_devices (nmc=0x7fff03ff12d0, argc=<optimized out>, argv=<optimized out>) at devices.c:2161
 do_cmd (argv=0x7fff03ff14f0, argc=2, argv0=0x7fff03ff3706 "dev", nmc=0x7fff03ff12d0) at nmcli.c:121

Changed in network-manager (Ubuntu):
importance: Undecided → Medium
summary: - nmcli crashed with SIGSEGV in g_ptr_array_foreach()
+ nmcli crashed with SIGSEGV in show_device_info()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in network-manager (Ubuntu):
status: New → Confirmed
tags: added: saucy
tags: added: bugpattern-needed
Changed in network-manager (Ubuntu):
status: Confirmed → Triaged
importance: Medium → High
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
tags: added: nm-fix-upstream
information type: Private → Public
Changed in network-manager (Ubuntu Raring):
status: New → Triaged
importance: Undecided → High
Changed in network-manager (Ubuntu Raring):
importance: High → Critical
Changed in network-manager (Ubuntu Saucy):
importance: High → Critical
Andrew Woodward (xarses) wrote :

Is this not merged? Still getting cores on 'nmcli d l'

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 0.9.8.4-0ubuntu3

---------------
network-manager (0.9.8.4-0ubuntu3) trusty; urgency=low

  * Set "allow-stderr" for debian/tests/apparmor_workaround to avoid failure
    on AppArmor warnings.
 -- Martin Pitt <email address hidden> Tue, 05 Nov 2013 09:48:28 +0100

Changed in network-manager (Ubuntu):
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in network-manager (Ubuntu Raring):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in network-manager (Ubuntu Saucy):
status: Triaged → Won't Fix
To post a comment you must log in.