XPCOM error after updating to Wine-Compholio 1.7.9

Bug #1265367 reported by Mateus Mello Garrute on 2014-01-01
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Netflix Desktop
Critical
Erich E. Hoover
Wine
Fix Released
Low
Wine "Compholio" Edition
Critical
Erich E. Hoover

Bug Description

Hello,

I try install the netflix-desktop on my Ubuntu 12.10 following the instructions of this link: http://www.techrepublic.com/blog/linux-and-open-source/how-to-get-netflix-streaming-on-ubuntu-1210/, but a problem was born: the XPCOM error. the netflix-desktop doesn't open.

I try to use the rm -rf on my ~/.wine-browser directory, and when I loaded netflix-desktop again it reconfigured wine, but the same error resulted.

Thoughts? Help?

Created attachment 46927
Terminal log wine-1.7.8-127-g6d30d6b

After

6d30d6be78a49e1add6d8c7886484a2ceb950c71 is the first bad commit
commit 6d30d6be78a49e1add6d8c7886484a2ceb950c71
Author: Alexandre Julliard <email address hidden>
Date: Thu Dec 19 17:02:11 2013 +0100

    msvcp100: Share the source code with msvcp90.

:040000 040000 8472290a57eeeb332f2c3a29c629baaabc438bf3 4ead5763a482e786809844f7b8f55d5ccbc829ea Mdlls

game stalls early on launch.

To install the game without waiting for hours, you can use patch from bug 33146
(http://www.winehq.org/pipermail/wine-patches/2013-June/124884.html; didn't get committed, though)

Technically not a regression, the bug has always been present. The difference is that it's using builtin by default now.

*** Bug 35189 has been marked as a duplicate of this bug. ***

In , Wine-5 (wine-5) wrote :

Well, from my perspective (as a user) it is a regression for the overall wine system: It worked before (because of automatic overrides) and it doesn't work now.

That the functionality was not provided by a builtin dll is a technical detail, unknown to the normal user (since it doesn't show up in the config).

What I take from this: Adding a dll override for msvcp100 (native then builtin) is the workaround that should be chosen starting with wine 1.7.9, even though it did work without explicitely specifying an override with wine 1.7.8.

I tested this workaround and it seems to work (It opens up the window again).

(In reply to comment #3)
> Well, from my perspective (as a user) it is a regression for the overall
> wine system: It worked before (because of automatic overrides) and it
> doesn't work now.
>
> That the functionality was not provided by a builtin dll is a technical
> detail, unknown to the normal user (since it doesn't show up in the config).
>
>
> What I take from this: Adding a dll override for msvcp100 (native then
> builtin) is the workaround that should be chosen starting with wine 1.7.9,
> even though it did work without explicitely specifying an override with wine
> 1.7.8.
>
> I tested this workaround and it seems to work (It opens up the window again).

Confirming that vcrun2010 works around the issue.

Affects the Battle.net agent.

summary: - XPCOM error on ubuntu 12.10
+ XPCOM error after updating to Wine-Compholio 1.7.9
Changed in netflix-desktop:
status: New → Triaged
importance: Undecided → Critical
Changed in wine-compholio:
status: New → Triaged
importance: Undecided → Critical
Changed in netflix-desktop:
assignee: nobody → Erich E. Hoover (ehoover)
Changed in wine-compholio:
assignee: nobody → Erich E. Hoover (ehoover)
Sebastian Lackner (slackner) wrote :

*** TEMPORARY WORKAROUND ***

The problem is caused by a change of the default MSVCR library in wine 1.7.9. You can workaround this problem by entering the following command. Just open a terminal and copy&paste the following command (as a regular user, NOT root!):

(echo "REGEDIT4";echo "";echo "[HKEY_CURRENT_USER\\Software\\Wine\\DllOverrides]";echo "\"*msvcr100\"=\"builtin\"";) > "/tmp/winefix.reg";WINEPREFIX=~/.wine-browser /opt/wine-compholio/bin/wine regedit "/tmp/winefix.reg"

After this it should work again. We'll push out a new netflix-desktop version soon which contains the fix above.

Changed in netflix-desktop:
status: Triaged → Fix Committed
milestone: none → 0.8.7

These fixes are not working. Tried the cut and past but the same XPCOM
issue is happening?

Sincerely,

coskibum

On Wed, Jan 1, 2014 at 2:05 PM, Erich E. Hoover
<email address hidden>wrote:

> ** Bug watch added: Wine Bugzilla #35181
> http://bugs.winehq.org/show_bug.cgi?id=35181
>
> ** Also affects: wine via
> http://bugs.winehq.org/show_bug.cgi?id=35181
> Importance: Unknown
> Status: Unknown
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1265367
>
> Title:
> XPCOM error after updating to Wine-Compholio 1.7.9
>
> Status in Netflix Desktop:
> Fix Committed
> Status in Wine:
> Unknown
> Status in Wine "Compholio" Edition:
> Triaged
>
> Bug description:
> Hello,
>
> I try install the netflix-desktop on my Ubuntu 12.10 following the
> instructions of this link: http://www.techrepublic.com/blog/linux-and-
> open-source/how-to-get-netflix-streaming-on-ubuntu-1210/, but a
> problem was born: the XPCOM error. the netflix-desktop doesn't open.
>
> I try to use the rm -rf on my ~/.wine-browser directory, and when I
> loaded netflix-desktop again it reconfigured wine, but the same error
> resulted.
>
> Thoughts? Help?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/netflix-desktop/+bug/1265367/+subscriptions
>

Darin B (darinb6-w) wrote :

I installed the netflix-desktop that just came throught the update manager via you ppa. netflix opens but it says it is missing silverlight and netflix is asking to install it. i tried installing it via the wine browser but i still have the same error no silverlight and can't past that netflix window.

Erich E. Hoover (ehoover) wrote :

Hi Darin, yeah - I made a mistake in the build file, making a new netflix-desktop now.

Darin B (darinb6-w) wrote :

I then tried the command above in the terminal as user not as root and it did not change anything. netflix opens but it claims it is missing silverlight plug in. which I can't seem to install.
Unless i don't know how to do that properly. Please explain.

Erich E. Hoover (ehoover) wrote :

Hi Darin, it complains about the plugin because the package I built is broken - the new one should be available shortly.

Erich E. Hoover (ehoover) wrote :

Hi Darin, if you update now the new package should work for you.

Changed in netflix-desktop:
status: Fix Committed → Fix Released
coskibum (1coskibum) wrote :

Erich:

Everything is working again! Thank you very much... You're a good egg ;-)

coskibum

On Wed, Jan 1, 2014 at 4:23 PM, Erich E. Hoover
<email address hidden>wrote:

> ** Changed in: netflix-desktop
> Status: Fix Committed => Fix Released
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1265367
>
> Title:
> XPCOM error after updating to Wine-Compholio 1.7.9
>
> Status in Netflix Desktop:
> Fix Released
> Status in Wine:
> Unknown
> Status in Wine "Compholio" Edition:
> Triaged
>
> Bug description:
> Hello,
>
> I try install the netflix-desktop on my Ubuntu 12.10 following the
> instructions of this link: http://www.techrepublic.com/blog/linux-and-
> open-source/how-to-get-netflix-streaming-on-ubuntu-1210/, but a
> problem was born: the XPCOM error. the netflix-desktop doesn't open.
>
> I try to use the rm -rf on my ~/.wine-browser directory, and when I
> loaded netflix-desktop again it reconfigured wine, but the same error
> resulted.
>
> Thoughts? Help?
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/netflix-desktop/+bug/1265367/+subscriptions
>

As of wine-1.7.9-165-g0ae7b5f, no more stalling but a crash.

No backtrace available though, but a "winedbg: Internal crash at 0x<address>" message.

Changed in wine:
importance: Unknown → Medium
status: Unknown → Confirmed

Confirmed crash at startup on Wine 1.7.9 .

(In reply to comment #6)
> As of wine-1.7.9-165-g0ae7b5f, no more stalling but a crash.
>
> No backtrace available though, but a "winedbg: Internal crash at
> 0x<address>" message.

Affects several apps, technically a regression, bumping to major.

(In reply to comment #8)
> Affects several apps, technically a regression, bumping to major.

http://bugs.winehq.org/show_bug.cgi?id=35181#c1

(In reply to comment #9)

http://bugs.winehq.org/page.cgi?id=fields.html#importance

> Major loss of functionality for a wide range of applications

(In reply to comment #10)
> http://bugs.winehq.org/page.cgi?id=fields.html#importance
>
> > Major loss of functionality for a wide range of applications

Actually it's minor since there is an easy workaround: 'winetricks vcrun2010'.

Hello,

Sorry. I'm begginer in Ubuntu.

How can I put the netflix-desktop to works?

Thank you!

I used these command in terminal:

sudo apt-get update

and the netflix-desktop works normally, whitout the XPCOM error.

Thank you so much!

The XPCOM error don't exist anymore. I did enter in my account on netflix.

But the movies don't start. When I click on the movie, one black screen appear, but nothing happens.

Why I need to do?

Sebastian Lackner (slackner) wrote :

Hi,

black screen most probably is related to problems with GPU acceleration. For a first test you can try to run:
wine-browser --disable-hw-acceleration

If the problem doesn't occur then you should check if your graphic card drivers are installed correctly.
Please attach the following logs so we can check that:

wine-browser --showdebug &> wine-browser.log
glxinfo &> glxinfo.log

Afterwards upload both logs wine-browser.log and glxinfo.log to this bug report.

Sebastian

Changed in wine:
importance: Medium → Low

The game starts with builtin msvcp100. Marking as fixed.

In , Wine-5 (wine-5) wrote :

Sorry, but I don't understand this at all.

According to http://wiki.winehq.org/Bugs
you are not even supposed to create tickets when using *any* DLL overrides (when to report: clean wine directory) and now an issue is closed because an override "fixes" it?

Either overrides are completely supported or the goal is to run stuff without any overrides. Not some weird kind of mixture.

I do understand that an override is a good workaround and there might be more important things for now, but I don't think this is "works as intended".

(In reply to comment #13)
"builtin" means Wine's. An override would be called "native".

(In reply to comment #13)
> According to http://wiki.winehq.org/Bugs
> you are not even supposed to create tickets when using *any* DLL overrides
> (when to report: clean wine directory) and now an issue is closed because an
> override "fixes" it?
Your bug report is valid. It's ok to submit bugs when application uses native dlls shipped with it. The bug is marked fixed because the issue is resolved in git version of wine. It was not yet released so you can compile it yourself or wait for next unstable release to see the fix.

In , Wine-5 (wine-5) wrote :

(In reply to comment #14)
> (In reply to comment #13)
> "builtin" means Wine's. An override would be called "native".

I always get that wrong.. because it is *wine* builtin, but *windows* native, changing the POV. I always try to say "override" or "no override" for this exact reason and the comment didn't sound like something new was happening.

Anyways, I tested again for Bug 35189 (duplicate I reported for Battle.net) and it seems to be fixed in latest git (not sure which commit).
There is another problem, but that is because of the new version of the battle.net client.

(In reply to comment #16)
> (In reply to comment #14)
> > (In reply to comment #13)
> > "builtin" means Wine's. An override would be called "native".
>
> I always get that wrong.. because it is *wine* builtin, but *windows*
> native, changing the POV. I always try to say "override" or "no override"
> for this exact reason and the comment didn't sound like something new was
> happening.

builtin = built in Wine, comes with Wine
native = from Windows, since native apps run in Windows

Changed in wine:
status: Confirmed → Fix Released

Closing bugs fixed in 1.7.12.

Changed in wine-compholio:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.