required new silverlight

Bug #1164453 reported by Edvinas on 2013-04-04
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Netflix Desktop

Bug Description

Cant play anymore anything on netflix, as required to update in to new silverlight.

bjfcom (bjfcom) wrote :

I have the same error.

Netflix-desktop has been working until last night. Neflix prompted me to install a new version of Silverlight. I attempted to install it, but after the attempt, the content will still not play. Instead, I am just re-prompted to install a new version of Silverlight.

I'm using Ubuntu 12.04 LTS.

Erich E. Hoover (ehoover) wrote :

I'm not having this problem, even with a fresh profile. It might be that you started with a profile from before when I had the installer disable automatic updates. So, I would suggest wiping the profile folder to see if that fixes it:
rm -Rf ~/.wine-browser

Edvinas (ikonitas) wrote :

Your solution worked well for me. Cheers

Amir Heidari (amir-hdrz) wrote :

wiping the profile folder worked for me too. I wonder what caused all of us to have this problem.

summary: - required new silverligh
+ required new silverlight
bjfcom (bjfcom) wrote :

That seems to have done it. Thanks Erich!

Kevin Zekis (kevin-zekis) wrote :

Worked for me. Was there some setting that required automatic updates or something? Whatever it was it's gone for now.

Erich E. Hoover (ehoover) wrote :

Kevin: Yes, a while back I changed the install process for Silverlight to launch with the "/noupdate" flag - so anyone that started with a profile from before that change would periodically be prompted to update. I ensure that the installed version for the initial profile is compatible with Wine, so far that means using the latest version of Silverlight 4.x (as I cannot support Silverlight 5.x at this time).

Changed in netflix-desktop:
status: New → Fix Released

The fix worked for me, except now I'm stuck in fullscreen mode. F11 got me out of it before, but no more. I'd really love not to be in fullscreen all the time.

Erich E. Hoover (ehoover) wrote :

Christon, Please try restarting the app and leaving fullscreen mode before you launch a movie.

That worked. Perfect!

Eric Hegeman (miracleofmagick) wrote :

I tried this fix and I am still getting a blank screen with sound. Now, before finding this fix I had tried updating silverlight, is it possible that is the cause of my problems? If so, how do I rectify that?

Erich E. Hoover (ehoover) wrote :

Eric, which fix are you talking about? Wiping the profile folder (rm -Rf ~/.wine-browser) will reset your profile with the correct version of Silverlight the next time you launch the app. The blank screen w/ sound issue is a different problem (bug #1104373).

Eric Hegeman (miracleofmagick) wrote :

I was talking about wiping the profile folder as everything worked fine for me until the update silverlight bug. I tried to update silverlight (I know prob a bad move) then tried the wiping the profile fix. Now I get a black screen with audio, which hadn't happened before. I will check out thatt other issue. thank you

pablo (soundtech) wrote :

I have issued the rm -Rf ~/.wine-browser command, but I'm still getting the must upgrade silverlight message.
I did do the silverlight upgrade as well, but I think I was able to remove the new version, as it wants to upgrade again.
I'm using Mepis 11 64-bit.

AngloCuencano (tristan77573) wrote :

I have also issued the command rm -Rf ~/.wine-browser, and this works until I restart the computer.

After a restart, upon launching Netflix Desktop the browser update add-on check dialog appears and I get the Silverlight update message when I try to watch a video. Is there a way to make this change permanent?

Shisui (kajatidew-231) wrote :

If "rm -Rf ~/.wine-browser" doesn't work properly try a manual delete of folder.

pablo (soundtech) wrote :

Curiously, I do not seem to have a .wine-browser on either my laptop or desktop running Netflix. And I have indeed chosen to view hidden files.

My desktop has yet to ask for the Silverlight upgrade.

My laptop did, I tried the upgrade, and broke Netflix. After un-installing netflix-desktop and compholio-wine, and many manual deletions, I re-installed the netflix packages, and all was well for a while. But after a few episodes of a show, it was once again asking that I upgrade Silverlight.

There might be a solution forthcoming for Mepis users, I'll let you know.

rootkowski (rootkowski) wrote :

Hi everyone!

I have the same problem with netflix desktop. It started only two days ago, that suddenly I was getting the silverlight upgrade screen when I wanted to watch a film. I removed the wine-browser folder and could watch netflix again. But every time I close netflix and start again I bump into the same silverlight upgrade screen. Quite tiring having to remove the folder every time you close the app. I even re-installed netflix desktop but nothing changed.

Have been using netflix desktop for months now, but this is the first problem I've had with it.

My system is Linux Mint 14 KDE.

AngloCuencano (tristan77573) wrote :

Thanks Shisui - manually deleting the .wine-browser folder seems to have made the change persistent across restarts.

I'm using Ubuntu 12.10.

Robbie Eginton (rainspeaker) wrote :

Could anyone explain what is meant by "manually deleting"? Do you mean going in in the file browser?

pablo (soundtech) wrote :

Shishui: The .wine-browser folder does not appear to be on either of the two machines I have netflix on. I have enabled the hidden folder view, it just isn't there!

rainspeaker: That is exactly it. Un-installing netflix-desktop leaves a lot behind, so I manually removed all that. And when I treid the upgrade to Silverlight 5.x, that had to be removed manually as well. I couldn't find an un-istall for that through wine.

Erich E. Hoover (ehoover) wrote :

If you delete the profile folder then any version of netflix-desktop newer than 0.2.0 (0.3.0+) should create a new profile folder where the auto-update is disabled. Alternatively, you can manually disable the auto-updater:
1) right-click on the Silverlight plugin once you've launched a movie (or anything that uses Silverlight)
2) choose "Silverlight" (the only option)
3) click the "Updates" tab
4) choose "Never check for updates"
5) click "OK"

If you don't have a ~/.wine-browser folder after running netflix-desktop then you're using an old release that placed everything in the folder ~/.netflix-desktop. Updating to the latest version will move the profile to the new location, though if you're having this update problem you would probably want to just delete it.

This worked for me:

1. Open your file manager and go into your Home folder.
2. Make hidden files and folders visible.
3. You should now be able to see the ".wine-browser" folder. Make a backup copy of it just in case Murphy's law comes into play.
4. Delete the ".wine-browser" folder completely--the entire thing, "drive_c" folder and all. No software or vital system files will actually be lost.
5. Restart Netflix Desktop. Wine will detect the absence of the ".wine-browser" directory, quickly recreate and rebuild it, and then promptly open Netflix Desktop. The Silverlight update issue should then be resolved.
6. You may not run into this last issue (bug #1104373, sound but no video), but I did. After I made it past the Silverlight update roadblock, I heard the movie playing but the screen was black. All I did was estimate where the play/pause button would be on the screen and clicked on that spot twice. Boom...picture back.
7. Once you are satisfied that everything is functioning normally, don't forget to delete the temporary backup of the ".wine-browser" folder created in Step 3.

rootkowski (rootkowski) wrote :

I've tried Silverlight update settings as suggested above by Erich, but no luck. Next time I started netflix, the browser ran it's checks and I was presented with the hated Silverlight upgrade screen again.

So removing the wine-browser folder and changing silverlight settings don't work. I think I'll try removing everything netflix completely from my system, restart, install again and hope for the best.

I wonder though, if there's a way of upgrading silverlight in the netflix package via the ppa?

rootkowski (rootkowski) wrote :

I completely removed all netflix related packages via synaptic and re-installed after a reboot and it seems all is well now! :)

Vipul (vipul-bhandari) wrote :

I don't think it is the silverlight update which does it. It is Firefox update. So press F11 to get into window mode. Then press F10. Go to Options/Preferences ->Advanced-> updates, then disable the automatic browser update.

I was deleting wine-browser everytime, but this fixed it.

gary hastings (g-hastings) wrote :

rm-Rf~/wine- browser

jamie Dixon (brookd2010) on 2013-06-23
Changed in netflix-desktop:
assignee: nobody → jamie Dixon (brookd2010)

Umm... I don't know if something changed recently, but this fix isn't working for me. Has something new come up? I don't have a .wine-browser folder in my home, and I tried turning off auto updates, but none of that has made any difference.

Update: I went ahead and did a apt-get remove netflix-desktop and tried reinstalling, but was not able to get it working. Le sad...

Erich E. Hoover (ehoover) wrote :

Christopher, have you updated to the latest version (0.7.0)? The scripts should automatically create a .wine-browser hidden folder the first time you launch netflix-desktop, but old versions used ".netflix-desktop". If you use Alt+H to open the help menu and choose "About Firefox" you can check the version number to see if it auto-updated Firefox, the correct version for working with Netflix is 18.0.1.

Realized I wan't being careful in reading the bug description here. In my case, it wasn't showing up as needing an upgrade, but that Silverlight actually wasn't installed. This thread gave me a fix -

richard_ (lurwas) wrote :

I had the same problem with the silverlight update.
I solved it by removing the ~/.wine-browser folder like suggested above.
Then I restarted netflix-desktop.
I then clicked on the silverlight update link in the netflix-desktop browser.
My default browser in Ubuntu opened the link.
I copied that link from my default Ubuntu browser and pressed Ctrl+T followed by Ctrl+L.
I pasted the address in the dialog that came up.
I could then follow the instructions to update the Silverlight Plugin.

richard_ (lurwas) wrote :

To clarify, the Ctrl+T and Ctrl+L part (and what follows), I did inside the netflix-desktop browser.

I just installed netflix-desktop on my Zorin OS 6 and it does not launch. It says "Starting Netflix Desk...." and then nothing happens.
It installed correctly. I tried uninstalling and reinstalling but I get the same thing. Please help.

Erich E. Hoover (ehoover) wrote :

Bongythupod, could you please try wiping the profile folder (rm -Rf ~/.wine-browser) and see if that fixes the problem?

Kody (armstrongkodyd) on 2013-09-29
Changed in netflix-desktop:
assignee: jamie Dixon (brookd2010) → Kody (armstrongkodyd)
Dennis Mansell (dennmans) wrote :

Just to confirm that this bug started to occur for me today after upgrading to compholio 1.7.9 today, and that the suggested workaround by Erich solves it. Thanks Erich, many people appreciate being able to watch Netflix due to your hard work, I am one of them!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers