Netflix Desktop has choppy video (18 FPS instead of 24 FPS)

Reported by Erich E. Hoover on 2012-11-28
176
This bug affects 35 people
Affects Status Importance Assigned to Milestone
Netflix Desktop
High
Erich E. Hoover
Wine
Fix Released
Medium

Bug Description

Some users are experiencing problems where the video playback in Netflix is choppy and makes watching videos unbearable. This problem even occurs on some high-end systems where such problems should not be expected.

meldroc (meldroc-gmail) wrote :

I'm noticing a moderate amount of choppiness on my system, though the videos are mostly watchable.

I'm currently running Kubuntu 12.10, with the proprietary nVidia drivers, version 310.14 (from the Ubuntu repos, version 310.14-0ubuntu1).

The system has an AMD Phenom II X4 965, running at 3.4GHz, 8GB of RAM, an nVidia GeForce GTX 550Ti. The hardware seems to work just fine for about everything else - I can run games, watch movies natively using apps like VLC, watch Youtubes in my native web browser, all silky-smooth.

meldroc (meldroc-gmail) wrote :

Also, when I ran top, I noticed the process named "plugin-container" seemed to be consuming a lot of CPU cycles.

Sudhir Khanger (donniezazen) wrote :

I have i7-2620M board, 8GB RAM, Intel HD 3000 and Nvidia NVS 4200. Video is little bit choppy.

Dave Vree (hdave) wrote :

I am running on a System76 Gazelle laptop with Pentium i7 3.4GHz, integrated Intel video, OSS video driver, and 16GB RAM. Like meldroc, everything on this system runs smooth as silk, Compiz, Flash, Video games, even running netflix from within a Windows XP VirtualBox VM.

I also noticed "plugin-container" being at the top of top.

I have Asus M4N78 motherboard with NVIDIA nForce 720D chipset and nvidia GTS250 as display adapter. Video driver version is nvidia 310.14 and I am running Ubuntu 12.10 in twinview mode (hdmi output with spdif audio to television). Video is quite choppy with netflix. Yesterday I tried to play a little bit with ccsm and nvidia-settings (vsync, composite plugin options, etc.) without any luck. Putting vsync to disabled seemed to add some tearing also. All other videos are playing just fine, including full screen 1080p flash.

wine is saying somethin about buffer switching when playing video: fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.

not sure if this is important or not, but this notice is logged couple of times within a second..

Erich E. Hoover (ehoover) wrote :

The wined3d_swapchain_present FIXME is just about the D3DPRESENT_FORCEIMMEDIATE flag being ignored (D3DPRESENT_INTERVAL_IMMEDIATE bit). This shouldn't really be a problem on any of the described systems. Has everyone tried removing PulseAudio and switching to normal ALSA ( http://www.iheartubuntu.com/2012/11/ppa-for-netflix-desktop-app.html#comment-721077163 )? I'm thinking this issue might be a result of an audio synchronization problem since Wine doesn't play well with PulseAudio.

I have tried without pulseaudio. No effect.

Erich E. Hoover (ehoover) wrote :

I can't believe I forgot to ask this before, are people using 32-bit or 64-bit installations? I doubt it makes a difference, but it's worth establishing that that's the case.

64-bit Ubuntu

also some other info which might be relevant or not:

$ pulseaudio --version
pulseaudio 2.1

$ cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.25.

$ cat /proc/asound/cards
 0 [NVidia ]: HDA-Intel - HDA NVidia
            HDA NVidia at 0xf7f78000 irq 21

$ aplay -l
**** Luettelo PLAYBACK laitteista ****
kortti 0: NVidia [HDA NVidia], laite 0: ALC887 Analog [ALC887 Analog]
  Alalaitteet: 1/1
  Alalaite #0: subdevice #0
kortti 0: NVidia [HDA NVidia], laite 1: ALC887 Digital [ALC887 Digital]
  Alalaitteet: 1/1
  Alalaite #0: subdevice #0

$ unity --version
unity 6.12.0

$ glxinfo | grep "OpenGL version"
OpenGL version string: 3.3.0 NVIDIA 310.14

Nilabja Roy (nilabjar) wrote :

I am having the same problem. And I also see the 'plugin-container' at the top of top.

My system is ubuntu 12.10 (32 bit) running on a Intel Core dual core chip with 3 GB ram. I have checked this on KDE and also on Gnome fallback. It seems to be worse in unity.

 The graphics card is Intel integrated. My laptop is old but youtube, hi-def movies on vlc, everything works fine.

 Fixing this would be outstanding.
 Thanks,

Erich E. Hoover (ehoover) wrote :

From jason saunders (article comment):
The computer im using is an Acer Aspire 5315-2326 dual booted with the OS listed and Ubuntu 12.04 LTS 64 bit.

OS Provided Microsoft Windows Vista Home Basic
Wireless capabilities IEEE 802.11b,
IEEE 802.11g
Processor / Chipset
CPU Intel Celeron 550 / 2.0 GHz
Cache L2 cache - 1.0 MB
Front Side Bus 533.0 MHz
Chipset Mobile Intel GL960 Express

Memory
RAM 1.0 GB ( 1 x 1 GB )
Max RAM Supported 2.0 GB
Technology DDR2 SDRAM
Hard Drive 160.0 GB HDD / 5400.0 rpm
Audio & Video
Graphics Processor Intel GMA X3100
Memory Allocation Technology Dynamic Video Memory Technology 4.0
Max Allocated RAM Size 358.0 MB

Doug (courtjestr) wrote :

Erich,

Are you saying that with the above system, video is smooth?

On all the systems I have tried, 32 bit, 64 bit, pulseaudio, or just alsa, the video is always choppy. Some systems have AMD processors, some Intels. Even an Intel i7 with 8 gigs of memory, the video is choppy.. The only common denominator is that they are all running nVidia graphics cards.

Doug.

Erich E. Hoover (ehoover) wrote :

Doug,

No, that person apparently couldn't get Launchpad to take their comment. It seems to work fine on my system though: 64-bit Ubuntu 12.04 w/ PulseAudio, Intel i7-2760QM CPU @ 2.40GHz, and nVidia GeForce GTX 560M (driver 310.14). What nVidia driver version are you using?

Doug (courtjestr) wrote :

driver 310.19 from xedgers

My system has the following specs:

Intel(R) Core(TM) i7 CPU 870 @ 2.93GHz
8 Gb Mem.
NVIDIA Corporation GF108 [GeForce GT 430]
pulseaudio

The interesting thing is that when netflix running (with choppy video), my CPU is far from being maxed out. plugin-container is the top processes, but it never goes over 60% of CPU usage.

Erich E. Hoover (ehoover) wrote :

Doug,

Could you try "sudo iotop" to monitor what your disk is doing? (you may need to install iotop) It's possible that this isn't related to the CPU or GPU at all. It could be that the reason that _I_ don't see the issue is that I have a 7200 rpm hybrid SSD hard drive.

jz-train (josh-zackeroff) wrote :

I too can confirm that video is choppy. I tried resizing the player to a minimal window and the video was still choppy. I also ran iotop and it didn't indicate the hard drive was being pegged. Plugin-container infact does produce high cpu usage according to top.

Games and HD video do run flawlessly.

Tested on linux mint 13 x64 with an amd phenom II x6 1105T cpu and 8gb ram, nvidia 460 gtx with latest nvidia drivers.

Doug (courtjestr) wrote :

Hi Erich,

Just ran iotop. Like Josh, nothing indicated high hd strain. Also ran htop, and the plugin-container never pegged more than 33% of cpu usage. htop shows the load on all 8 cores of my I7 and none of them were ever above 35% usage. So I don't think it can be a CPU bottleneck either.

Doug.

Jay Foster (jayf0ster) wrote :

Erich,
I also have the choppy video playback issue. I'm running Ubuntu 12.04 LTS on the following:

Intel(R) Core(TM) i7 CPU 930 @ 2.80GHz
8GB RAM
Linux tornado 3.2.0-33-generic #52-Ubuntu SMP Thu Oct 18 16:29:15 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Nvidia driver version 295.40
VGA compatible controller: NVIDIA Corporation GT216 [GeForce GT 220] (rev a2)

CMM (mercier-christopher) wrote :

Same problem here:

Kernel Linux 3.5.0-19-generic
Ubuntu 12.10 64 bit
Intel Core 2 Duo @ 2.00 GHZ
3GB Ram
VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
Using Gnome fallback with compiz

plugin-container up to 123% cpu usage while video playing, wineserver is around 20%

After playing for a couple minute, video gets extremely choppy and plays videp at less than 1 fps

maybe its a firefox bug?

Same here:

Linux * 3.2.0-32-generic-pae #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012 i686 i686 i386 GNU/Linux
Intel Core i5 2500K (using integrated graphics)
8GB Ram
SSD disk
plugin-container about 60% cpu

I found this MS site to test Silverlight framerate; I get 15-20 fps regardless of resolution
http://www.iis.net/media/experiencesmoothstreaming

Erich E. Hoover (ehoover) wrote :

Tancred,

What kind of performance did you get on that test site in Windows? It looks like I might be able to reproduce the issue on that site, so that should help me track this down.

Nilabja Roy (nilabjar) wrote :

Hi Erich,

  I tried the above IIS streaming site. I ran the video on both Windows and Ubuntu on the same machine. (Both OSs are dual boot on my machine).

  In ubuntu,

     I was getting Downloading bit rate around 350k (upper right bit rate bar) . FPS was ranging between 15-18. And the video was played at 350k (lower left graph).

   In Windows,

       Downloading rate - 2040 kbps
       FPS - 23-25 fps
       Video played at 2.04M

   So is it a downloading problem ? Anyway let me know if you need me to do any other kind of tests.

   My machine is a Intel pentium dual-core T3400 @ 2.16 GHz, 3 GB ram, 32 bit.

   I did the same experiment on my Mac which is a i7 dual core with 8 GB ram. It had the same numbers as the Windows test given above.

Doug (courtjestr) wrote :

My download rate is pegged at 350 as well. However, the video does play smoothly for the most part. It is blocky.

Doug

Doug (courtjestr) wrote :

I just ran netflix in in a Windows XP ViritualBox VM under the same instannce of Ubuntu I used to test netflix-desktop. It was smooth as silk and the silverlight streaming test worked perfectly... download rate @ 2 mbs 25 fps, and clear video. So there is something specific to netfix-desktop that is preventing smooth video.

Hi Eric,

Unfortunately (from a debugging perspective, not otherwise :) ) I
don't have a Windows machine / VM that I could compare to. I'm
basically assuming the uneven and low (<25) fps I'm seeing on Ubuntu
is not what is intended.

- Tancred

On 2 December 2012 19:46, Erich Hoover <email address hidden> wrote:
> Tancred,
>
> What kind of performance did you get on that test site in Windows? It
> looks like I might be able to reproduce the issue on that site, so that
> should help me track this down.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1083858
>
> Title:
> Netflix Desktop has choppy video on some systems
>
> Status in Netflix Desktop:
> New
>
> Bug description:
> Some users are experiencing problems where the video playback in
> Netflix is choppy and makes watching videos unbearable. This problem
> even occurs on some high-end systems where such problems should not be
> expected.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/netflix-desktop/+bug/1083858/+subscriptions

I just tried netflix-desktop on another machine. This one is a 2.8Ghz quad core with 8GB of RAM, also with Intel integrated video adapter and still the same choppy low framerate. This one and my other one are 64 bit installations of Ubuntu 12.10 with integrated Intel graphics. So the problem has nothing to do with Intel vs nVidia graphics.

I ran the smoothstreaming site and am seeing 14 to 19 fps in netflix-desktop which accounts for the choppiness.

On these same 2 machines, I am seeing 25 fps from within Virtualbox WinXP.

Dave Vree (hdave) wrote :

I should add that in Windows VM and in netflix-desktop, my download rate was pegged at 350Kbps, so I do not believe it is a download speed problem. It is a silverlight on Wine fps problem.

Erich E. Hoover (ehoover) wrote :

Did you use Silverlight 4.x or 5.x on the Windows VM? Silverlight 5.x supports GPU acceleration, so I want to make sure we compare to 4.x.

Nilabja Roy (nilabjar) wrote :

Hi Erich,

  I checked the silverlight versions for the Windows test. It is 5.1.10411.0

  Nilabja

Dave Vree (hdave) wrote :

My Windows XP VM Silverlight is 4.1.10329. Given this and the feedback from Nilarbja...its sounds like its not a Silverlight 4.x vs 5.x thing.

Dave Vree (hdave) wrote :

Here are some tips on increase performance of Wine and Silverlight:

http://wiki.winehq.org/Performance

http://msdn.microsoft.com/en-us/library/cc189071(v=vs.95).aspx

Nothing jumped right out at me....but I am not an expert on this stuff...

Geoff Brueggen (geoffbrueggen) wrote :

Okay, got it installed and working, but as many others have said, my video is choppy.

Wine threw alot of fixme warnings when i first ran it, but it isn't throwing them anymore.

I checked top and found that my plugin-container is pulling 120% of my CPU when playing a video.

here's the specs on my system:

Release: Ubuntu 12.04 32-bit

Processor: 1.60Ghz DualCore Intel CPU T2050
Memory: 2.0 Gb RAM
Graphics Card: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Anne Fairchild (amfairc) wrote :

I too am experiencing this problem. I've tried it on 3 different systems. The only thing they have in common is that they're on ext3 filesystems. I'm a bit of a newbie. Could this be the problem? Is this showing up on ext4 filesystems.

Dave Vree (hdave) wrote :

I'm 100% ext4 on my machines and it still happens. I think we can rule out:

a) nvidia or intel being the cause
b) silverlight 4.x being the cause
c) ext3 or ext4 being the cause
d) 32bit or 64bit being the cause

Perhaps there is some wine tweak?

omriasta (omriasta) wrote :

Just to chime in, didn't really expect it to play wonders on my machine but here are my specs, needless to say I have choppy video:
Using a Lenovo X120e (which has the AMD E350-fusion chip/ATI Radeon) with 4GB RAM and an SSD.
Ran the IE Fish tank in native chrome with 18 FPS while on the Wine/Mozilla I was getting around 6 FPS.
Hope this helps!

omriasta (omriasta) wrote :

Oh, also am on 64bit and ext4.

Doug (courtjestr) wrote :

Hardware acceleration in Silverlight 5 is also not a factor since I was running Netflix and the Silverlight streaming test in a virtual machine without hardware acceleration and getting good performance.

Doug.

gotsanity (gotsanity) wrote :

I also am getting choppy playback. Sound is fine but i am seeing what looks to be frame lag. My system is ubuntu 12.04 64 bit (unity), nvidia gtx460 running proprietary 310 drivers. AMD Phenom 970 Black edition (3.4) with 8gig ram and an SSD as my root drive. I am dual booted win7 and have no issues running netflix under that. I also currently run WoW and steam for linux under linux with no issue.

mback (mback) wrote :

I also have choppy vidio on HP EliteBook 8760 with this setup -- Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz with NVIDIA Corporation GF104 [Quadro 3000M] (rev a1). I am running 64-bit kernel 3.5.0-19, & nvidia proprietary graphics drivers with Gnome 3.6.0 (with extensions, I think Ilike it better than Unity now) on Ubuntu 12.10 (Quantal).

So, this is top-of-the-line 64Intel(R) Core(TM) i7-2640M CPU @ 2.80GHz-bit laptop with proprietary graphics... can't do a lot better than that... is "choppy."

meldroc (meldroc-gmail) wrote :

I've discovered a way to achieve a moderate improvement. Netflix isn't perfect, but the frame rate is better.

It turns out in my nVidia settings, I had Vertical Sync turned on. That prevents tearing effects, but also hurts the frame rate.

Turn that off, and make sure that's turned off in Compiz or KDE's Desktop Effects settings, and you'll see some improvement.

Still running Kubuntu 12.10 (64-bit version) on my AMD Phenom 2 X4 w/ an nVidia GeForce GTX 550TI, 8GB RAM, proprietary nVidia drivers.

Changed in netflix-desktop:
status: New → Triaged
Changed in netflix-desktop:
status: Triaged → In Progress
29 comments hidden view all 109 comments
Erich E. Hoover (ehoover) wrote :

Ok, the new package is ready for testing:
https://dl.dropbox.com/u/195059/netflix-desktop/wine-compholio_1.5.19%7Eprecise_i386.deb

(same link, updated package)

5 comments hidden view all 109 comments

Created attachment 42859
user32: SetTimer should respect the minimum and maximum timeout limits.

According to MSDN, SetTimer has a minimum timer value of 10 milliseconds. Currently, Wine uses a minimum timer value of 55 milliseconds. This behavior poses a problem for Silverlight, which uses SetTimer to handle redrawing the display. Since Silverlight expects to repaint the display at about 24 FPS (41.6 milliseconds), the 55 millisecond timer value is insufficient. By dropping the minimum timer value to 10 milliseconds Silverlight will then be able to repaint the display fast enough to show movies without having choppy playback.

Changed in netflix-desktop:
milestone: none → 0.5.0
4 comments hidden view all 109 comments
Dave Vree (hdave) wrote :

Erich -- YOU NAILED IT!

2750 download speed, a steady 24fps....all movies are smooth as silk now. Whatever you did in that last fixed totally resolved everything. Just send in my donation. You are a genius! Thank you very very very much.

That package just doesnt want to install for me for some reason. Cant wait till the patches are put in the next update. Hopefull these patches will fix it all for me too.

Erich E. Hoover (ehoover) wrote :

@Dave, glad I was able to help. I'm compiling a revised patch that complies with the documentation on MSDN for the relevant function, would you mind testing that once it's done and comparing the performance?

@silverhaze06, what kind of error do you see?

summary: - Netflix Desktop has choppy video on some systems
+ Netflix Desktop has choppy video (18 FPS instead of 24 FPS)

I dont get any messages at all. software center opens it, the loading bar pops up and it seems to start, then it disappears after a minute and changes back to the install button.

Erich E. Hoover (ehoover) wrote :

This is the "more likely to get accepted version" (new link, so it's easy to test both versions):
https://dl.dropbox.com/u/195059/netflix-desktop/wine-compholio_1.5.19%7Eprecise1_i386.deb

@silverhaze06, would you mind trying from the terminal?:
sudo dpkg -i <name_of_package>.deb

Changed in wine:
importance: Unknown → Medium
status: Unknown → Confirmed
1 comments hidden view all 109 comments

idk if it worked or not. it seemed to go pretty fast, (about 10 seconds) it gave me this output,

nate@nate-HP-Pavilion-g6-Notebook-PC:~$ sudo dpkg -i wine-compholio_1.5.19~precise1_i386.deb
[sudo] password for nate:
(Reading database ... 318280 files and directories currently installed.)
Preparing to replace wine-compholio 1.5.19~precise (using wine-compholio_1.5.19~precise1_i386.deb) ...
Unpacking replacement wine-compholio ...
Setting up wine-compholio (1.5.19~precise) ...
procps stop/waiting
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
nate@nate-HP-Pavilion-g6-Notebook-PC:~$

after that i opened the app again, the updating wine configuration window popped up first, but did not see any improvement on the frame rate for any HD content. when i tried to install the updated package through the software center, it did the same thing as the last one.

rrbrand (slbrando) wrote :

I was just looking at your patch,

Based on the MS documentation -> http://msdn.microsoft.com/en-us/library/windows/desktop/ms644906%28v=vs.85%29.aspx

Shouldn't the req->rate not look more like

req->rate = min( 0x7FFFFFFF, max(timeout, 0x000000A) );

I think the effect is the same, but the patch would be more aligned to the spec

m (91xmusic) wrote :

Erich Hoover: Things are running awesome now. I think it's fixed. Thank you! Both the patches you posted today appear to be working on my system.

silverhaze06: I had the same thing happen. After you click install and it stops, give it a minute and see if it magically starts "installing" again by itself. For me, it spent a couple minutes downloading and then installed for real, but still displayed "Install" after it was finished. So...my experience was that it appeared to be installing the patch twice but left no evidence that it was finished. When I ran the app though, things were very much improved.

@m Yeah thats exactly what its doing for me. After doing that and restarting, im getting zero improvement on frame rate.

Erich E. Hoover (ehoover) wrote :

@rrbrand, that behavior is identical - I chose to do it the way that I did for aesthetic reasons.

@silverhaze06, I'm surprised that you're still having trouble with the revised version. Does the test website work? It might be that you're having a different issue from everyone else.

Changed in netflix-desktop:
status: In Progress → Fix Committed
Dave Vree (hdave) wrote :

For those of you still having problems -- you should check your wine-compholio/bin directory to see if you have really the right version. Here's mine:

ls -l /opt/wine-compholio/bin/

total 1396
-rwxr-xr-x 1 root root 8187 Dec 19 15:27 function_grep.pl
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 msiexec
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 notepad
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 regedit
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 regsvr32
-rwxr-xr-x 1 root root 354904 Dec 19 15:27 widl
-rwxr-xr-x 1 root root 9616 Dec 19 15:27 wine
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 wineboot
-rwxr-xr-x 1 root root 99872 Dec 19 15:27 winebuild
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 winecfg
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 wineconsole
lrwxrwxrwx 1 root root 7 Dec 19 15:27 winecpp -> winegcc
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 winedbg
-rwxr-xr-x 1 root root 145216 Dec 19 15:27 winedump
-rwxr-xr-x 1 root root 1612 Dec 19 15:26 winefile
lrwxrwxrwx 1 root root 7 Dec 19 15:27 wineg++ -> winegcc
-rwxr-xr-x 1 root root 30172 Dec 19 15:27 winegcc
-rwxr-xr-x 1 root root 94258 Dec 19 15:27 winemaker
-rwxr-xr-x 1 root root 1612 Dec 19 15:27 winemine
-rwxr-xr-x 1 root root 1612 Dec 19 15:27 winepath
-rwxr-xr-x 1 root root 12704 Dec 19 15:27 wine-preloader
-rwxr-xr-x 1 root root 346180 Dec 19 15:27 wineserver
-rwxr-xr-x 1 root root 50776 Dec 19 15:27 wmc
-rwxr-xr-x 1 root root 208152 Dec 19 15:27 wrc

heres my output.

nate@nate-HP-Pavilion-g6-Notebook-PC:~$ ls -l /opt/wine-compholio/bin/
total 1396
-rwxr-xr-x 1 root root 8187 Dec 19 14:27 function_grep.pl
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 msiexec
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 notepad
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 regedit
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 regsvr32
-rwxr-xr-x 1 root root 354904 Dec 19 14:27 widl
-rwxr-xr-x 1 root root 9616 Dec 19 14:27 wine
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 wineboot
-rwxr-xr-x 1 root root 99872 Dec 19 14:27 winebuild
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 winecfg
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 wineconsole
lrwxrwxrwx 1 root root 7 Dec 19 14:27 winecpp -> winegcc
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 winedbg
-rwxr-xr-x 1 root root 145216 Dec 19 14:27 winedump
-rwxr-xr-x 1 root root 1612 Dec 19 14:26 winefile
lrwxrwxrwx 1 root root 7 Dec 19 14:27 wineg++ -> winegcc
-rwxr-xr-x 1 root root 30172 Dec 19 14:27 winegcc
-rwxr-xr-x 1 root root 94258 Dec 19 14:27 winemaker
-rwxr-xr-x 1 root root 1612 Dec 19 14:27 winemine
-rwxr-xr-x 1 root root 1612 Dec 19 14:27 winepath
-rwxr-xr-x 1 root root 12704 Dec 19 14:27 wine-preloader
-rwxr-xr-x 1 root root 346180 Dec 19 14:27 wineserver
-rwxr-xr-x 1 root root 50776 Dec 19 14:27 wmc
-rwxr-xr-x 1 root root 208152 Dec 19 14:27 wrc
nate@nate-HP-Pavilion-g6-Notebook-PC:~$

the test site is working flawlessly now. but still the same problems on netflix. what else could be causing this?

im thinking if im having any other problem, could it be the fglrx video drivers im using or my version of catylist? and when i tried the x.org drivers instead, im plagued with the no video, but audio bug.

tried this command, "LIBGL_DEBUG=verbose netflix-desktop --showdebug" watched some choppy video, and got this output,

fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing" 0x65fe384): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing\\goog-malware-shavar-1.sbstore" 0x65fe31c): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing\\goog-malware-shavar-1.cache" 0x65fe32c): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing\\goog-phish-shavar-1.sbstore" 0x65fe31c): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing\\goog-phish-shavar-1.cache" 0x65fe32c): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\safebrowsing-backup" 0x65fe394): stub
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000.
fixme:thread:GetThreadPreferredUILanguages 48, 0x7b5c940, (nil) 0x7b5c93c
fixme:thread:GetThreadPreferredUILanguages 48, 0x7b5c940, 0x2714f48 0x7b5c93c
fixme:thread:GetThreadPreferredUILanguages 48, 0x6e9cb48, (nil) 0x6e9cb44
fixme:thread:GetThreadPreferredUILanguages 48, 0x6e9cb48, 0x27acbb0 0x6e9cb44
fixme:thread:GetThreadPreferredUILanguages 48, 0x6e9c8a8, (nil) 0x6e9c8a4
fixme:thread:GetThreadPreferredUILanguages 48, 0x6e9c8a8, 0x609b470 0x6e9c8a4
err:d3d:context_clean_fbo_attachments >>>>>>>>>>>>>>>>> GL_INVALID_VALUE (0x501) from glFramebufferTexture2D() @ context.c / 95
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\sessionstore-1.js" 0xb7fe3ac): stub
fixme:advapi:TraceEvent 0 0x32f108
fixme:advapi:FileEncryptionStatusW (L"C:\\netflix-profile\\localstore-1.rdf" 0x32eb9c): stub
NOTE: child process received `Goodbye', closing down
err:ole:CoUninitialize Mismatched CoUninitialize
fixme:advapi:TraceEvent 0 0x32f128
nate@nate-HP-Pavilion-g6-Notebook-PC:~$

with this line"fixme:d3d:wined3d_swapchain_present Ignoring flags 0x80000000." being repeated hundreds and hundreds of times more than what i put here.

Dave Vree (hdave) wrote :

@silverhaze06 - I get roughly the same output when running the same command. And it looks like the patched wine has been installed correctly. The only other thing I could suggest to is to check your Compiz settings per the comments above.

Erich E. Hoover (ehoover) wrote :

Ok, I've got the fixed version released with the PPA now. @silverhaze06, if you're still having trouble with the new version then could you open a new bug?

Changed in netflix-desktop:
status: Fix Committed → Fix Released

yeah idk why, but im still getting only 2-3fps in HD when watching netflix with the new patch and with the suggested compiz settings. the test site now works flawlessly tho.

meldroc (meldroc-gmail) wrote :

Just tried the updated netflix-desktop and wine-compholio - FIXED IT!!!

Played a couple shows, they're running pretty smoothly on my system!

Thank you, Erich!!!

Confirmed to work great on my config (below). I have an el-cheapo highspeed camera, and using it was able to confirm that Netflix indeed plays at 25 fps (tested with LOTR Two Towers).

Thanks Erich for the awesome early Xmas present! :)

Ubuntu precise (Lubuntu and Unity)
Intel Core i5 2500K (using integrated graphics)
8GB Ram
SSD disk
2Mb connection
tested: wine-compholio_1.5.19%7Eprecise_i386.deb

TinCanFury (steve-adeff) wrote :

I believe I'm still having this issue, I have an Athlon 64 4000, w/ 1GB RAM, running 12.04
[582137.586] (II) NVIDIA(0): NVIDIA GPU GeForce GT 430 (GF108) at PCI:2:0:0 (GPU-0)
[582137.586] (--) NVIDIA(0): Memory: 1048576 kBytes

# apt-show-versions -a|grep wine-compholio
wine-compholio 1.5.20~precise install ok installed
# apt-show-versions -a|grep netflix
netflix-desktop 0.5.1~precise install ok installed

I'm not running any display manager (this is for my HTPC which runs a MythTV frontend)

I'm not sure how to display the frame rate but I would say I'm probably getting somewhere around 18fps, as he video looks choppy but is not horrible. sometimes it slows down more. audio seems fine, though every so often will "hiccup". I notice the same issues of plugin-container using a lot of CPU, as well as firefox.exe and wineserver

I also have to run 'rm -rf ~/.netflix-desktop' before running netflix-desktop almost every time otherwise it never runs. I think this problem is a separate issue for another ticket though.

Erich E. Hoover (ehoover) wrote :

@TinCanFury, we're keeping track of the remaining frame-rate issues in Bug #1092439.

Michael Stewart (mjstewart) wrote :

I'm using Ubuntu 12.10 64 bit. I notice the chopiness as well. And also that of my sound. That is because it is playing two seconds of the video for every one second; in other words, 2x the speed it should be playing.

SmartSuka (fane-jason) wrote :

Hi all,

I have installed the netflix-desktop application on MintOS and like many of you I was having issues with playback, the speed was playing 1.5 normal speed or 2x speed.

I was able to solve it by updating the kernel version I'm including the steps below (in the terminal):

// interactive sudo mode, so we don't have to keep typing sudo
# sudo -i
# apt-get dist-upgrade
# reboot

The reboot is necessary in order to upgrade the kernel, otherwise the change will not take effect. One the kernel is upgraded try running the application again hit alt + F2

type "netflix-desktop" and hit enter.

Hope this helps!!!

1 comments hidden view all 109 comments

Wine maintainers: please merge this patch into trunk ASAP. It's a prerequisite
for running Netflix under Wine.

nachokb (nachokb) wrote :

Running 12.10 64-bits under Gnome Shell, CPU is Core i7 i3610QM (Ivy Bridge) with Intel HD 4000 graphics (plus an nVidia 650M, not used for Netflix).

Video is unbearably choppy.

"plugin-container" is consistently consuming ~40% - ~110% of CPU load in top.

This is behavior is consistently reproduced watching e.g. BBC's Planet Earth (choppiness, dismal video quality -- it never switches to high quality, UI is unresponsive). I tried watching an episode of 24 (the TV show), and it happens but a lot less

1 comments hidden view all 109 comments

(In reply to comment #1)
> Wine maintainers: please merge this patch into trunk ASAP. It's a prerequisite
> for running Netflix under Wine.

It is necessary for me to finish fixing some regressions caused by the first Netflix patches before I can submit the rest of the patches, as soon as that is completed I'll submit the remainder of the patches.

Dave Dixon (ddixon-swcp) wrote :

I'm running 64 bit ubuntu 12.04 on Intel Core i5-2520M CPU @ 2.50GHz x 4 with 8GB RAM.
What I'm seeing is that Netflix will stream along just fine (for an hour or longer) then get choppy like it's in fast-forward. Restarting the film doesn't help, and exiting Netflix Desktop doesn't help, but rebooting the computer does. Is this likely to be related?

Adam Rigg (adamrigg) wrote :

The bug is not necessarily specific to WINE--I started experiencing this within a virtual machine of Windows XP after getting a service upgrade from my ISP. That said, I noticed a few particulars to WINE and the netflix-desktop package. Mostly though, improvements came from things that I could do with any setup on any OS/environment.

Closing anything that generates significant and constant clock cycles for the CPU improves things, but plugin-container and wineserver were the big ones, so I wanted to stray away from things like pulseaudio or compiz, which use up about 2-3% of my CPU in a worst case scenario. Limiting plugin-container before it got up into the 70-100+% CPU usage was the real challenge.

2 things helped: First, I noticed that wine-compholio recommends wine-gecko1.8 and wine-mono0.0.8, but I had different versions installed from the Wine PPA or the standard Ubuntu repositories. Uninstalling other versions and making sure to have wine-gecko1.8:i386 to accompany the wine-compholio:i386 package for Precise made the "wine-browser" a little more stable--Notably keyboard shortcuts to Silverlight are more responsive, and even the Esc key kinda works for leaving full-screen now.

The most important change I could make though came when I figured out that Netflix has a bandwidth cap referred to in its troubleshooting page for choppy video: https://account.netflix.com/VideoQuality
http://support.netflix.com/en/node/97

If I set the Quality to the middle option, "better," I pretty much get locked into a 1050 buffering rate. Otherwise, it would switch around between 1050 and the next one up (1750?), and after around 20 minutes of watching a video, I would have to either X out right away or wait for the the frame to lock up completely before dropping out of X11 and killing plugin-container from a shell. The severity of the issue did get better after uninstalling wine-gecko-1.9 and adding 1.8:386 to an existing install of the 1.9, 64 bit wine-gecko, but manually selecting a bitrate helped a lot more.

For me, adjusting the Netflix VideoQuality settings is a lot easier than clicking into the black space and holding down ctrl+alt+shift+s everty time a video starts up. Now CPU usage is between 30 and 40% and I don't have to worry as much about leaving a few dozen other applications or tabs running in Linux.

HARDWARE: Laptop with 2Ghz Core2 Duo, 4 GB RAM, integrated Intel graphics & sound w/ VGA out to 720p TV, 1360x768@60Hz.

SOFTWARE: LXDE w/ Compiz (for video, falling back on OpenBox for everything else) on Ubuntu Precise, CPU usage drawn from KDE's System Monitor (ksysguard), netflix-desktop 0.6.1~precise (with related depends & recommends).

Adam Rigg (adamrigg) wrote :

Ugh.... "to an existing install of the 1.9" should be "to an existing install of the 1.8:amd64" for the wine-gecko package mentioned above in §5, 2 paragraphs up from HARDWARE (1.8, not 1.9--got rid of 1.9).

Adam Rigg (adamrigg) wrote :

My main workaround above (i386 mono & gecko packages + Netflix VideoQuality settings at "better") only worked for around 3 hours before I had to shutdown the system and restart. Maybe I could have just use wineboot, but shutting down is often the easiest thing to do when a process goes completely haywire.

Maybe it'll work for more than 3 hours at a stretch if I turn off compiz or pulseaudio, but compiz doesn't really seem to hurt much if any and pulseaudio seems to just be about compounding Silverlight buffer errors with the sync issues it brings in to play (e.g., click/crackle = frame stall, skip or speedup). Anyway, 3 hours is good enough for me. Probably Silverlight playback will get more consistent as audio in WINE improves though.

Changed in wine:
status: Confirmed → Fix Released

Closing bugs fixed in 1.5.30.

hongouru (hongouru) wrote :

I came to the solution, check my post for it...
(pulseaudio consumes much of the cpu resources, just by slowing it down, it will fix it)

http://hongouru.blogspot.com/2013/06/solved-netflix-desktop-has-choppy-video.html

Hi, everyone.

I hadn't read all the comments yet, but I've come up with a solution:

On Ubuntu's sound settings (All Settings, Sound), on the Output tab, when "Simultaneous output to built-in Audio Analog Stereo" is selected, Netflix video is choppy.
But if I select "Speakers" or "Headphones", the video gets back to normal, instantly and on the fly.

I wanted to share this now, as I just (accidently) found this solution; but I'll try to read the rest of the posts.
Hope it works for you.

Eli (esaxon) wrote :

I have found the solution to the lagging/frame dropping playback of Netflix under Ubuntu 13.10 (using native Firefox under Ubuntu with pipeline enabled for Silverlight) withe the help of the the following thread:

https://wiki.archlinux.org/index.php/PulseAudio#Realtime_scheduling

This seems to be a Pulseaudio issue. Following the thread, issue the following command:

sudo gedit /etc/pulse/default.pa

Search for the following line:

load-module module-udev-detect tsched=0

and replace it to:

load-module module-udev-detect tsched=1

Save the file in the editor, and playback will be perfect, even with full HD.

Erich E. Hoover (ehoover) wrote :

Hi Eli, did you report your graphics card to the http://pulseaudio.org/wiki/BrokenSoundDrivers page like it said? It's possible that other people are encountering the same problem you have.

Eli (esaxon) wrote :

One more thing needed at the end to have it working instantly:

Restart the Pulseaudio server with the following commands:

pulseaudio -k
pulseaudio --start

Eli (esaxon) wrote :

Hi Erich,

Not yet, maybe I can do it later. Nevertheless the sollution I found is perfect for me now on my system.

Displaying first 40 and last 40 comments. View all 109 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.