wqy-microhei font missing in 20100208's daily build

Bug #519104 reported by ZhengPeng Hou on 2010-02-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
High
Unassigned
Ubuntu Translations
High
Unassigned

Bug Description

due to miss chinese fonts, chinese characters can't be displayed correctly in ubiquity. in Ubuntu, at least ttf-wqy-microhei being used, so hope we can pull the same into ubuntu netbook's seed.

Package: ttf-wqy-microhei
Priority: optional
Section: x11
Installed-Size: 5184
Maintainer: Zhengpeng Hou <email address hidden>
Architecture: all
Version: 0.2.0-beta-1
Recommends: x-ttcidfont-conf (>= 10), fontconfig (>= 2.3.1-1)
Filename: pool/main/t/ttf-wqy-microhei/ttf-wqy-microhei_0.2.0-beta-1_all.deb
Size: 2375872
MD5sum: e8425005d216d9d50de3170c0318bf26
SHA1: 3512b1b86bf66613fc4b0f4abf5deba2a4ac0d6c
SHA256: a55b23dbd66c8db0c237af7adf005ef5c887c392cc336b63b0a9d01dea4515a6
Description: A droid derived Sans-Seri style CJK font
 WenQuanYi Micro Hei font family is a Sans-Serif style (also known as Hei,
 Gothic or Dotum among the Chinese/Japanese/Korean users) high quality
 CJK outline font. It was derived from "Droid Sans Fallback", "Droid
 Sans" and "Droid Sans Mono" released by Google Corp. This font package
 contains two faces, "Micro Hei" and "Micro Hei Mono", in form of a
 True-Type Collection (ttc) file. All the unified CJK Han glyphs, i.e.
 GBK Hanzi, in the range of U+4E00-U+9FC3 defined in Unicode Standard 5.1
 are covered, with additional support to many other international
 languages such as Latin, Extended Latin, Hanguls and Kanas. The font
 file is extremely compact (~5M) compared with most known CJK fonts.
 As a result, it can be used for hand-held devices or embedded systems, or
 used on PC with a significantly small memory footprint. Because both
 font faces carry hinting and kerning instructions for Latin glyphs,
 they are the excellent choices for desktop fonts.
Homepage: http://wqy.sourceforge.net/
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Origin: Ubuntu
Supported: 3y
Task: ubuntu-desktop, kubuntu-desktop, kubuntu-netbook, edubuntu-desktop, edubuntu-desktop-kde

Aron Xu (happyaron) on 2010-02-10
tags: added: fonts ubuntu-unr
Changed in ubuntu-translations:
status: New → Confirmed
importance: Undecided → High
Aron Xu (happyaron) wrote :

This problem will also affect Japanese and Korean users other than Chinese, so the importance has been set to High in ubuntu-translations.

summary: - chinese font missed in 20100208's daily build
+ wqy-microhei font missing in 20100208's daily build
Changed in netbook-remix:
status: New → Confirmed
Changed in netbook-remix:
importance: Undecided → High
assignee: nobody → Arne Goetje (arnegoetje)
ZhengPeng Hou (zhengpeng-hou) wrote :

the size of 20100327 daily build is about 690M, which should be fine to include this font. otherwise the user experience for CJK users will be too bad, since if users choose corresponding language, those characters can't be rendered in ubiquity's UI, because of lack of proper fonts.

Arne Goetje (arnegoetje) on 2010-03-27
Changed in netbook-remix:
assignee: Arne Goetje (arnegoetje) → nobody

Is this still a problem? Please respond if you're still affected.

Changed in netbook-remix:
status: Confirmed → Incomplete
Changed in ubuntu-translations:
status: Confirmed → Incomplete
Aron Xu (happyaron) wrote :

Having look at manifest file of 20100824's daily-live of ubuntu-netbook, this bug has been fixed.

Changed in ubuntu-translations:
status: Incomplete → Fix Released
Changed in netbook-remix:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers