Cheese isn't maximized

Bug #348494 reported by Loïc Minier on 2009-03-25
2
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
Low
Unassigned
ubuntu-netbook-remix-default-settings (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

When launching Cheese in Jaunty UNR live image in virtualbox, it isn't maximized like the other applications, but is in a window instead.

Bye

Tobin Davis (gruemaster) wrote :

I can verify this on my Acer Aspire One as well.

Changed in netbook-remix:
status: New → Confirmed
Bill Filler (bfiller) wrote :

this is the intended behavior. Cheese is one of the appications in the maximus exclude list (apps listed will not be maximized), which is a gconf key set by the package ubuntu-netbook-remix-default-settings package in Jaunty:
/apps/maximus/exclude_class [Totem,Cheese]

The reasoning for this may be legacy. In hardy, cheese UI layout did not fill available space in full screen mode, iirc. Also one of the oem customers asked for it to not be fullscreen. This can be revisted for Jaunty if people feel it should be fullscreen by default.

Changed in netbook-remix:
importance: Undecided → Wishlist
Paul Larson (pwlars) wrote :

in gconf, /apps/maximus, cheese and totem seem to be excluded. Were they excluded for a reason?

Matt Zimmerman (mdz) on 2009-03-25
Changed in netbook-remix:
importance: Wishlist → Low
Loïc Minier (lool) wrote :

Are there open bugs for making cheese and totem scale better when maximized?

Neil J. Patel (njpatel) wrote :

The decision not to maximise totem is so because totem normally opens at the correct size for the video it's displaying. When maximus used to force it to maximise, smaller videos would end up being scaled up with the window size, and they would look horrible (like the ones that were/are shipped in Examples).

I think there was a bug against totem for this, but it was closed won't fix because that is the way totem was made to work (don't quote me on this, I'll try and find the bug report and add it here).

I'm not sure about a corresponding bug report for cheese, but I've just been playing with Cheese on a netbook with the exception removed from gconf, and it seems to scale fine when maximised.

So, maybe we should remove cheese from the netbook-remix-defaults and just keep totem?

Loïc Minier (lool) wrote :

Sounds good to me; perhaps totem could have a GConf knob to select "video size doesn't follow window size"? Or perhaps specific knobs for downscaling and upscaling?

Loïc Minier (lool) wrote :

Debdiff and FFE in bug #349598

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-netbook-remix-default-settings - 0.5.0

---------------
ubuntu-netbook-remix-default-settings (0.5.0) jaunty; urgency=low

  * UI tweaks; FFE LP: #349598.
    - Only blacklist maximization of Totem, not of Cheese as it seems to scale
      up properly now; thanks Neil J. Patel; LP: #348494.
    - Tweak evolution's layout to fit in screen as small as 576 pixels; set
      /apps/evolution/shell/view_defaults/buttons_style to icon and
      /apps/evolution/shell/view_defaults/folder_bar/width to 266; thanks
      Bill Filler.

 -- Loic Minier <email address hidden> Fri, 27 Mar 2009 13:59:59 +0100

Changed in ubuntu-netbook-remix-default-settings:
status: New → Fix Released
Paul Larson (pwlars) wrote :

This bug was already fixed in the Ubuntu Distribution

Changed in netbook-remix:
status: Confirmed → Won't Fix
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers