Mobile Broadband configuration wizard does not fit on 480px vertical resolution

Bug #333359 reported by Bruno Girin
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix
Undecided
Unassigned
libmbca (Ubuntu)
Wishlist
Unassigned

Bug Description

Release: Jaunty
CD/DVD Variant: UNR nightly USB image
Image build: 20090223, 20090312

Symptoms:
When plugging using a mobile broadband modem for the first time, Ubuntu starts a wizard that asks for country and mobile broadband provider, in order to configure the device. The wizard screens don't fit on a 480px vertical resolution screen, as on EeePC 701 and other 7", 800x480 netbooks. As a result, the wizard buttons are not displayed fully and sometimes none at all making them difficult or impossible to click. See attached screenshots for details.

Steps to reproduce:
- Plug in a mobile broadband modem in a USB port
- Wizard appears, displaying intro text; wizard buttons are barely visible at the bottom
- Click button on the right to go to next screen; next screen is too tall and no button can be clicked

Revision history for this message
Bruno Girin (brunogirin) wrote :
description: updated
Revision history for this message
Bill Filler (bfiller) wrote :

I believe this bug is due to the fact that the DPI on your system did not get set correctly. Your screenshots validate this (the fonts are quite big). This was a know bug that should be fixed now. You test by manually setting the following gconf key and restarting:
/desktop/gnome/font_rendering/dpi 96.0
New unr builds should have this gconf setting set by default.

Changed in libmbca:
status: New → Invalid
Changed in netbook-remix:
status: New → Invalid
Revision history for this message
Bruno Girin (brunogirin) wrote :

This is still a problem with the UNR build from 12th March (today).

Revision history for this message
Bruno Girin (brunogirin) wrote :

Also, here is the output of gconftool:
$ gconftool -g /desktop/gnome/font_rendering/dpi
96

Therefore I take it that it means the DPI is set correctly to 96dpi. Despite this, the mobile broadband setup wizard doesn't fit the EeePC's 600px vertical resolution.

Changed in libmbca:
status: Invalid → New
Revision history for this message
Bruno Girin (brunogirin) wrote :

Setting it back to 'new' as the problem still exist on UNR build from 12th March, even though the DPI is correctly set to 96 by default.

Changed in netbook-remix:
status: Invalid → New
Bruno Girin (brunogirin)
description: updated
Revision history for this message
Bill Filler (bfiller) wrote :

Not sure why this is happening, I'm not seeing it. Can you try using gconf-editor and manually edit the key /desktop/gnome/font_rendering/dpi and make sure it's type is "Float" and it's value is 96.0. Then restart X (ctrl-alt-delete).

Also verify the file /usr/share/gconf/defaults/30_ubuntu-netbook-remix-default-settings exists and contains the line
/desktop/gnome/font_rendering/dpi 96.0

what version of the package ubuntu-netbook-remix-default-settings is installed on your system?

Revision history for this message
Alexander Sack (asac) wrote :

could you please try if the following patch helps: http://pastebin.ubuntu.com/140639/ ... you can apply it directly to /usr/share/libmbca/mbca.glade

Revision history for this message
Alexander Sack (asac) wrote :

i think its understood that libmbca needs to be improved to properly work on small screens. We are not sure what the best way is though.

Changed in libmbca (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Revision history for this message
Bruno Girin (brunogirin) wrote :

@Alexander,

The patch you provided above resolves the issue on the latest nightly UNR (7th April).

Also note that there is a slightly different behaviour depending on whether you connect the 3G dongle when running on a full install or directly from a live CD / USB key: on a full install, the country in the second screen is pre-selected according to your locale which helps reduce the vertical space required by the wizard.

Revision history for this message
Francois Thunus (thunus) wrote :

I have the same problem using the jaunty jack dated 27 april.
I could not set the broadband connection because I can't see the bottom of the screen. Unfortunately, the problem does not affect the dsl wizzard only.
I have been looking around the system (i'm a debian user) to get a look and feel, and bumped into several (gnome ?) applications which exhibit the same behavior. I'll get back to you when I have more hard data. I'll start by installing a copy of JJ on a spare partition so I can test it and get acquainted with its utilities. It took me ages to find the network configuration by the way. Why isn't it under internet, simply ?
Otherwise great job.
Cheers

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments