No sound with new kernel

Reported by Yannick Palanque on 2008-11-16
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Payson
High
Unassigned
Ubuntu Netbook Remix
Medium
Jouston Huang

Bug Description

Computer is Toshiba NB100.

# lspci|grep Audio
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)

Sound doesn't work since upgrade to new kernel.

Dmesg says:
[ 43.270178] snd_page_alloc: disagrees about version of symbol struct_module
[ 43.305028] snd: disagrees about version of symbol struct_module
[ 43.305896] snd_timer: disagrees about version of symbol struct_module
[ 43.306561] snd_pcm: disagrees about version of symbol struct_module
[ 43.308400] snd_hda_intel: disagrees about version of symbol struct_module

It doesn't work with linux-image-2.6.24-19-lpia -- 2.6.24-19.41netbook11

Sound is fine with linux-image-2.6.24-19-lpia_2.6.24-19.41netbook3_lpia.deb

Bug fix: Please download this package and install it:
https://edge.launchpad.net/%7Ejouston-huang/+archive/ppa/+files/nb100-sound_1.09_lpia.deb

Related branches

Thank you for reporting this bug. Please add the output of this command
to the bug report:

$ modinfo snd-hda-intel

  • modinfo Edit (3.8 KiB, application/octet-stream; name=modinfo)
  • dmesg.gz Edit (9.8 KiB, application/x-gzip; name=dmesg.gz)

2008-11-16T19:36:44-0000, Torsten Spindler <email address hidden>:

> Thank you for reporting this bug. Please add the output of this
> command to the bug report:
>
> $ modinfo snd-hda-intel

Here it is. I add also the entire output of dmesg, it seems to say a
little more than I said.

Greetings,
--
Yannick Palanque

Please try to move the updates/sound directory out of the way. For
example

$ sudo mv /lib/modules/2.6.24-19-lpia/updates/sound ~/sound
$ sudo depmod -a

Reboot and see if the sound problem is gone.

2008-11-17T03:51:39-0000, Torsten Spindler <email address hidden>:

> Please try to move the updates/sound directory out of the way. For
> example
>
> $ sudo mv /lib/modules/2.6.24-19-lpia/updates/sound ~/sound
> $ sudo depmod -a
>
> Reboot and see if the sound problem is gone.

Sound works! \o/

--
Yannick Palanque

Changed in netbook-remix:
assignee: nobody → tspindler
importance: Undecided → Medium
status: New → Triaged
Bill Filler (bfiller) wrote :

what is the upgrade path? from what to what? sounds works correctly with latest payson image, not sure what you are upgrading.

2008-11-18T17:57:49-0000, Bill Filler <email address hidden>:

> what is the upgrade path? from what to what?

probably (?) [linux-image-2.6.24-19-lpia_2.6.24-19.41netbook3_lpia.deb]
 |
 v
# aptitude update ; aptitude dist-upgrade
linux-image-2.6.24-19-lpia (2.6.24-19.41netbook11)
and probably (?)
linux-ubuntu-modules-2.6.24-19-lpia_2.6.24-19.29netbook7_lpia
 |
 v
no sound
 |
 v
I find linux-image-2.6.24-19-lpia_2.6.24-19.41netbook3_lpia.deb and
linux-ubuntu-modules-2.6.24-19-lpia_2.6.24-19.29netbook7_lpia.deb in
my /var/cache/apt/archives repertory
# dpkg -i linux-image-2.6.24-19-lpia_2.6.24-19.41netbook3_lpia.deb
linux-ubuntu-modules-2.6.24-19-lpia_2.6.24-19.29netbook7_lpia.deb
# reboot
 |
 v
sound
 |
 v
# aptitude dist-upgrade
linux-image-2.6.24-19-lpia (2.6.24-19.41netbook11)
linux-ubuntu-modules-2.6.24-19-lpia_2.6.24-19.29netbook7_lpia

no sound
# mv /lib/modules/2.6.24-19-lpia/updates/sound /home/yannick/sound
# depmod -a
# reboot
 |
 v
sound

Hope this helps...

--
Yannick Palanque

Ian Davey (unapersson) wrote :

Upgrade path is doing a standard OS Update from the pre-installed version of the Netbook Remix on the NB100. It seems to affect everyone that does the recommended updates.

The laptop has an Ubuntu Certified sticker so it doesn't look too good that sound gets broken by one of the first updates, especially as for quite a few users this may be their first exposure to Ubuntu.

It may be worth posting in this forum thread when it is fixed:
http://forums.computers.toshiba-europe.com/forums/thread.jspa?threadID=38079&tstart=0

Torsten Spindler (tspindler) wrote :

Thank you for the link to the forum, when a fix is available we will
post it in the thread.

Torsten Spindler (tspindler) wrote :

Please give this package a try and see if it resolves the issue:
https://edge.launchpad.net/%7Etspindler/+archive/+files/nb100-sound_1.03_lpia.deb

Yannick Palanque (acephale) wrote :

2008-12-02T05:51:03-0000, Torsten Spindler <email address hidden>:

> Please give this package a try and see if it resolves the issue:
> https://edge.launchpad.net/%7Etspindler/+archive/+files/nb100-sound_1.03_lpia.deb
>

I have "Sound modules have been modified".

$ SOUNDDIR=/lib/modules/2.6.24-19-lpia/updates/sound
$ find $SOUNDDIR | cpio -o | md5sum
1827 blocks
b8cb955c9dcea114c9866d90f10ffa0d -

--
Yannick Palanque

Tom Halchuk (tomhal) wrote :

The script did not fix the sound problem

Changed in netbook-remix:
status: Triaged → Confirmed
Ian Davey (unapersson) wrote :

I did a factory install, applied all the updates and tried running the script. It didn't work at first.

There are two MDSUMs at the top of the file though, one of which is commented out. If I uncomment the first and run the script then it works.

So in a stock factory install with all updates applied the first MDSUM is the correct one.

Torsten Spindler (tspindler) wrote :

It seems there are multiple versions of the sound modules around. The
script either needs to check for several of them or provide another
method. Maybe querying the user if deletion should be done even when
md5sums don't match is a good option.

Jouston Huang (jouston-huang) wrote :
Changed in netbook-remix:
assignee: tspindler → jouston-huang
status: Confirmed → Fix Committed
Yannick Palanque (acephale) wrote :

2008-12-08T10:15:14-0000, Jouston Huang <email address hidden>:

> Please try if this package fixes the sound problem.
>
> https://edge.launchpad.net/%7Ejouston-
> huang/+archive/+files/nb100-sound_1.06_lpia.deb

Yes, this package fixed the problem.

--
Yannick Palanque

marie (marie-j-newman) wrote :

Jouston huang

my god thank you so much, i had same problem as everyone else on my nb100, i have tried so many things on advice from others but you link mended it all for me, i could kiss you thank you!!!!!!!!

Merry Christmas xxxxx

Jouston Huang (jouston-huang) wrote :

The package again updated since the old one didn't have sufficient description. Please install this updated on. User previously installed do not need to upgrade. This is a one shot fix, once you fixed it you won't need it anymore. Feel free to purge this package after it fixes your problem.

https://edge.launchpad.net/%7Ejouston-huang/+archive/+files/nb100-sound_1.09_lpia.deb

ekawahyu (ekawahyu) wrote :

Hi Jouston Huang,

I didn't manage to install the package

ekawahyu@TOSHIBA-User:~/Documents$ sudo dpkg -i /home/ekawahyu/Documents/nb100-sound_1.09_lpia.deb
dpkg-deb: `/home/ekawahyu/Documents/nb100-sound_1.09_lpia.deb' is not a debian format archive
dpkg: error processing /home/ekawahyu/Documents/nb100-sound_1.09_lpia.deb (--install):
 subprocess dpkg-deb --control returned error exit status 2
Errors were encountered while processing:
 /home/ekawahyu/Documents/nb100-sound_1.09_lpia.deb

Did I do something wrong?

Eka

ekawahyu (ekawahyu) wrote :

But manually remove the module as:

> $ sudo mv /lib/modules/2.6.24-19-lpia/updates/sound /home/ekawahyu
> $ sudo depmod -a

works just fine for me. What did I do wrong with the .deb package installation?

Eka

Adilson Oliveira (agoliveira) wrote :

Your package seems to be corrupted. I suggest that Jouston to add a md5sum of the package so you can check if this is the case.

Jouston Huang (jouston-huang) wrote :

The newest package and it's md5sum is here:

https://edge.launchpad.net/%7Ejouston-huang/+archive/ppa/+files/nb100-sound_1.09_lpia.deb
800c10f7214614dc95bb3b2820c22cd2 nb100-sound_1.09_lpia.deb

Kurt (kurtx71) wrote :

Hi guys, please go easy with me I'm a complete Linux noob but have seen the light and trying my best...

I have tried various different scripts version 1.03, 1.06, and the one just above 1.09 with no luck.

i just get the message "deprecated sound modules not installed"

At the start of this thread it says to try:

 $ sudo mv /lib/modules/2.6.24-19-lpia/updates/sound ~/sound
 $ sudo depmod -a

from what I have read (and tried to understand so far) it's trying to remove the "sound" directory from "updates" but my "updates" directory is already empty (tried viewing hidden files too) so what's the next step to reinstall the correct drivers?

any help would be appreciated, Kurt

p.s. I have rebooted at each stage ;-)

Kurt (kurtx71) wrote :

just a quick update...... after doing some searches in to the "depmod -a" command it tried that after the 1.09 script and it seems so be working.

if anyone else is not having any luck with the scripts it might be worth a try?

Kurt.

p.s. hey, can I drop the noob tag now?

Talilah (angela-kutschke) wrote :

Yes, you can it do, I hope - we can that do :-D

I have clicked of the bugfix-file and my system run with sound... o, my god I am so happy.

PS. mein Englisch ist nicht weniger schlecht, als meine Linux- und Ubuntu/ Ubuntu-Remix-Kenntnisse,

description: updated
Bill Filler (bfiller) wrote :

not a UNR bug, but bug with payson pre-mp image

Changed in payson:
importance: Undecided → High
milestone: none → mp
status: New → Fix Released
Changed in netbook-remix:
status: Fix Committed → Invalid
Ken Bradshaw (bradshawkg) wrote :

I am a real newbie. I have tried the 1.09 patch above and got the same error message as Kurt: "deprecated sound modules not installed". I have no idea what to do next. I still have no sound. Can anyone please help

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments