Ubuntu Netbook Remix Launcher

Karmic RC: No way to log out, shut down or switch user

Reported by Stephen Warren on 2009-10-24
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Undecided
Unassigned

Bug Description

I'm not sure if this is a netbook-launcher issue, or a general UNR/Gnome integration/configuration issue. Still, netbook-launcher was what contained this functionality in Jaunty...

I had Jaunty UNR installed, then upgraded to Karmic RC using "update-manager -d". After this, I can't see any on-screen mechanism to log out, switch user, nor shut down.

In Jaunty, the launcher had a panel with some form of logout/shutdown button that could be clicked. This panel is no longer present in Karmic. I've search all options in the launcher, and I can't see any logout/shutdown/quit option. The classic desktop allows access to these functions from a "button" on the top menu-bar.

Luckily, google shows that pressing the power button or CTRL-ALT-DEL will pop up a menu allowing shutdown etc. But still, there's no logout option on that menu.

How am I supposed to logout or switch user in Karmic UNR?

David Barth (dbarth) wrote :

Thanks for your feedback. Was there something specific in the user session you migrated from? In particular, were you using "stock" UNR in Jaunty? or had you customized the mienu a bit? like adding some application launchers or additional applets? Cna you also indicate if you had used desktop-switcher recently, or as part of this migration to Karmic?

Last, if you can reproduce the bug, and provide a testcase for that, that would be very helpful.

Changed in netbook-remix-launcher:
status: New → Incomplete
Stephen Warren (srwarren) wrote :

I just had a regular Jaunty UNR install and upgraded to Karmic.

In Jaunty I think I might have used desktop-switcher once just to check it out, but then switched right back. I certainly didn't do any customization in classic mode. I didn't do any customization in netbook mode, since I don't think there's any that can be done?

I image the repro steps are as simple as: Install Jaunty UNR, upgrade to Karmic.

Changed in netbook-remix-launcher:
status: Incomplete → New
mdyn (tamerlaha-gmail) wrote :

i has a some problem but also it says, that a "some problem while loading applet (fast_Switch_user etc) delete applet from current config y\n" ,(i have a russian language) i pressing a no and its shows unr-launcher, but without a top-menu button and logout button. installed und from flash to formated ssd. sorry my english )

mdyn (tamerlaha-gmail) wrote :

but after logoff log on all work fine

riban (brian-riban) wrote :

I also observed this issue the first time I tried to shutdown / reboot after my upgrade from Jaunty UNR to Karmic UNR.

The new user interface has a single column of page selectors on the left. The old interface also had a column on the right which included file system access (now moved to the "Files & Folders" page) and the shutdown, reboot, suspend, hibernate options. These options have disappeared (or been moved to somewhere I can not find them).

So the question remains, how do we shutdown, reboot, suspend and hibernate using the new interface?

Ashley Hooper (ash-hooper) wrote :

I had this problem with Gnome on Karmic Koala.

It was caused by using KDM as the display manager instead of GDM.

To switch to GDM:

sudo dpkg-reconfigure gdm

riban (brian-riban) wrote :

I am running GDM with the problem so that is not the cause.

Didier Roche (didrocks) wrote :

Do you still have this issue on karmic? Lucid is using another way to display panel and so, it should be fixed now.

Didier Roche (didrocks) wrote :

I push it as incomplete for our bug tracking system. Do not hesitate to put it again as confirmed if the issue is still valid for you on Karmic.

Changed in netbook-remix-launcher:
status: New → Incomplete
Stephen Warren (srwarren) wrote :

Well, if nothing has been done to address this, then the bug is obviously still present.

I personally worked around it somehow. I don't recall how. Perhaps deleting my home directory, or perhaps manually adding the missing applet back or similar.

Same for me - fixed manually.
I hope it will not raise again after the lucid upgrade.

Didier Roche (didrocks) wrote :

Should not. I'll test upgrade as soon as possible (post alpha3)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers