Use ne gnome-session 2.24 features to include netbook-launcher in GNOME session

Bug #270905 reported by Luca Ferretti
2
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Medium
Neil J. Patel
netbook-launcher (Ubuntu)
Medium
Neil J. Patel

Bug Description

Gnome Session 2.24 provides new cool features to add client to a session and manage it. See [1] for full description.

In order to make netbook-launcher a good gnome-session citizen, we should/could:

 1. provide a netbook-launcher.desktop file installed under $prefix/share/applications with relevant keys (see below)
 2. provide a /desktop/gnome/session/required_components/launcher GConf key (value: netbook-launcher) to include
    netbook-launcher as required session component.
 3. add "launcher" to /desktop/gnome/session/required_components_list GConf key and remove "filemanager" when the user switchs to Netbook mode
 4. change netbook-launcher code in order to set RestartStyleHint=GSM_CLIENT_RESTART_IMMEDIATELY.

Note that point 3 should be perfomed by Switch Desktop Mode capplet, not by netbook-launcher itself.

Currently the window type is yet _NET_WM_WINDOW_TYPE_DESKTOP.

If I'm right, the netbook-launcher.desktop file should be something like:
#################################
[Desktop Entry]
Type=Application
_Name=Netbook Launcher
_Comment=UI to launch application in netbbooks
Exec=netbook-launcher
Icon=netbook-launcher
NoDisplay=true
X-GNOME-Autostart-Phase=Desktop
X-GNOME-Provides=launcher
X-GNOME-Autostart-Notify=true
X-GNOME-Autorestart=true
#################################(

Of course I'm not totally sure about this, I've to read [1] again and again, but I think this is the best and proper way to include netbook-launcher in gnome-session.

PS the same approach should be used in maximus, I'll open a similar bug

[1] http://live.gnome.org/SessionManagement/GnomeSession

Revision history for this message
Neil J. Patel (njpatel) wrote :

Stop reading my mind Luca :-). Tagged as "intrepid" as that's when we'll get the new gnome-session.

Regarding Maximus, it already talks to the desktop session to do the same thing. However, at the moment it uses the old method using GnomeClient. When we branch after 0.1, I'll update trunk to target Intrepid & the new gnome-session.

Changed in netbook-remix-launcher:
assignee: nobody → njpatel
importance: Undecided → Medium
milestone: none → 2.0
status: New → Confirmed
Revision history for this message
Neil J. Patel (njpatel) wrote :

Added extra autostart flags to both launcher and maximus. Not making them a part of the gconf session (using autostart files instead) because they remain optional and desktop-switcher expects the autostart files to be in place to do it's job. Maybe switch over to full gconf for Jaunty+1.

Changed in netbook-remix-launcher:
status: Confirmed → Fix Committed
Revision history for this message
Neil J. Patel (njpatel) wrote :

Commited to trunk.

Changed in netbook-launcher:
status: New → Fix Committed
Neil J. Patel (njpatel)
Changed in netbook-launcher:
status: Fix Committed → Fix Released
Revision history for this message
Paul Larson (pwlars) wrote :

This bug has been moved to Ubuntu distribution

Changed in netbook-launcher (Ubuntu):
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Medium
Changed in netbook-remix-launcher:
status: Fix Committed → Won't Fix
tags: added: ubuntu-unr
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers