Should use Gnome's font configuration

Bug #237373 reported by probono
18
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Medium
Neil J. Patel

Bug Description

Ubuntu Netbook Remix Launcher should use Gnome's font configuration. For example, if I change the face and size of the UI fonts, the Launcher should also use these. Also the icon-sizes should follow the icon_view of nautilus or should be configurable in another way.

Revision history for this message
Glenn (glenn-v) wrote :

Agreed, the font sizes are too small in many places.

Changed in netbook-remix-launcher:
status: New → Confirmed
Revision history for this message
Neil J. Patel (njpatel) wrote :

I'm currently working on better integration between the launcher and the desktop, and this is definitely on the TODO list.

Changed in netbook-remix-launcher:
assignee: nobody → njpatel
Revision history for this message
Stani (stani) wrote : Re: Should use Gnome's font & icons configuration

I added icons to it as the icons are far too small. Even the emblems are bigger than the icons! Look at evolution in my attached screenshot.

I first filed a question for it, but now i see it should be part of this bug:
https://answers.launchpad.net/netbook-remix-launcher/+question/35302

description: updated
Revision history for this message
Matteo Collina (matteo-collina) wrote :

I think that is another problem because in the screenshots done by Neil the icons are big.
Are you running ume on an eeepc 701? It's stated that ume targets 1024x600 resolution and so it hasn't been tested on the 701 resolution.

Revision history for this message
Stani (stani) wrote :

Yes, I am using it on an eeepc 701. I understand that it is targeted at a 1024x768 resolution, but I guess it would be better to be more flexible. If you look at my screenshot you can see that there is place for bigger icons (especially if you compare it with the text). So it is not that my screen is too small for it.

I don't mind that is misconfigured out of the box, as long as I can correct the size myself in a configuration file or gconf. Right now the value seems to be hardcoded in C, which might be fine for a temporary solution, but it is not a long term solution. So why not just calculate the value for 1024x600 and store it in gconf (/apps/nautilus/icon_view/thumbnail_size)?

Revision history for this message
Pau Oliva (poliva) wrote :

I have an HTC Shift, screen resolution is 800x480 and I have the problem with small icons.

As a temporary workaround, here's a patch that will increase the icon size.

Here's a screenshot *before* applying the patch:
http://pof.eslack.org/HTC/shift/ume-launcher/shift-netbook-remix-02a.png

And here's a screenshot *after* applying the patch:
http://pof.eslack.org/HTC/shift/ume-launcher/shift-netbook-remix-02.png

Revision history for this message
Stani (stani) wrote :

Thanks a lot! I hope this fix can be included upstream.

Revision history for this message
Pau Oliva (poliva) wrote :

Not as it is, because this will break other screen resolutions. I only posted this to show the problem with 800x480, where with the default calculations the icon size is extremely small. By default the ume-launcher window takes 95% of the screen, increasing it to 98% makes the icon size calculations to step to the next higher available size, but you have to use 3 icon rows instead of 4 to have them fit on the window properly.

Hopefully this patch, and the screenshots will help Neil to figure out how to properly implement a better icon size / total rows based on the screen resolution.

Revision history for this message
Pete Goodall (pgoodall) wrote :

The reason that UNR doesn't support resolutions below 1024x600 (not 768) is that many applications do not work well with such a small vertical space. It isn't so much just the launcher but the knock on effect of all the other applications that will need to be fixed to fit in that resolution. I agree that we want the product to be flexible, but the machines on which UNR will be certified to run will have all have a resolution of at 1024x600. Therefore, I would put this at a very low priority.

Changed in netbook-remix-launcher:
importance: Undecided → Wishlist
Revision history for this message
Pete Goodall (pgoodall) wrote :

Very sorry. I downgraded the priority based on a side issue of screen resolution. The original topic of using the GNOME font configuration is still valid.

Changed in netbook-remix-launcher:
importance: Wishlist → Medium
Revision history for this message
Stephen H (psychis-med) wrote :

Sorry for my cluelessness, but how do I apply this patch?

Revision history for this message
Pau Oliva (poliva) wrote :

Get the source and the build time dependencies:

$ sudo apt-get source ume-launcher
$ sudo apt-get build-dep ume-launcher

extract the source from the tarball and patch it:

$ tar xvfp ume-launcher-whatever.tar.gz
$ patch -p0 < file.patch

then recompile again:

$ cd ume-launcher-source-dir
$ sudo debuild -us -uc

and install the debian package you've just built:

$ dpkg -i ume-launcher-whatever-patched.deb

Revision history for this message
Stephen H (psychis-med) wrote :

Thank you, both for creating the patch and for your wonderfully clear instructions. I notice that they're also on the Ubuntu Eee page as well, that's very helpful.

Revision history for this message
Neil J. Patel (njpatel) wrote :

I've just committed a fix for the grid-size issue (commit #64). I'm leaving this bug open for the gnome font settings bug. Please continue discussion of the gird size bug at https://bugs.edge.launchpad.net/netbook-remix-launcher/+bug/240645. Thanks!

Neil J. Patel (njpatel)
Changed in netbook-remix-launcher:
status: Confirmed → Fix Committed
Neil J. Patel (njpatel)
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
Revision history for this message
Hassan Dibani (hassan-maroc-linux) wrote :

Any updates on the font size issue?
I am having the same problem on an Asus eee 901.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers