File System Properties reports 128 TB of use

Reported by outpost520@gmail.com on 2010-05-25
168
This bug affects 29 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned
Precise
Low
Jeremy Bicha
Quantal
Low
Jeremy Bicha
Raring
Low
Unassigned

Bug Description

[Impact]
Nautilus and Baobab
This is relatively low impact but it is annoying for Nautilus or Baobab to report incorrect information for file size and file count. In the case of /, the information reported is off by ~100 terabytes.

[Test Case]
There may be a simpler test case, but I have way too many small files on my computer in my Ubuntu development folders for me to want to wait for Nautilus to count everything in /
1. mkdir -p nautilus-test/proc
2. cd nautilus-test
3. Create a file named hello.txt with the text "Hello, world!"
4. sudo mount --bind /proc proc
5. Open nautilus to the nautilus-test directory
6. Right-click and select Properties.
7. Nautilus should say there are 2 files taking up a few bytes. If it says there is several TB of files in the folder, this bug isn't fixed.

[Regression Potential]
The patch, which has been accepted into nautilus master, only affects filesize and file count information.

Original report
---------------
Ubuntu 10.04 LTS

When you open up Computer, and right click on the File System and click Properties, under the Basic tab, the Contents subheading reports 128.0 TB of use. This happens on another desktop and laptop that have 10.04 installed.

Thanks for taking the time to report this bug and helping to make Ubuntu better. I can see the used space increasing then it jumped to 128.2 TB.

The recommended tool to visualize disk usage is the Disk Usage Analyzer (in Applications > Accessories menu).

affects: ubuntu → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

what does gvfs-info says about the filesystem? you can use it as : gvfs-ls computer:/// to see which filesystem are there and then choose the one showing the TB and use it as : gvfs-info computer:///NameOfFileSystem could you paste the output of that to the report? thanks.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
tags: added: likely-dup
philinux (philcb) wrote :

This also happens using pcmanfm so it's not confined to nautilus.

$ gvfs-info computer:///root.link
display name: Système de fichiers
name: root.link
type: mountable
attributes:
  standard::type: 6
  standard::name: root.link
  standard::display-name: Système de fichiers
  standard::icon: drive-harddisk
  standard::target-uri: file:///
  standard::sort-order: 0
  id::filesystem: computer:
  access::can-write: FALSE
  access::can-delete: FALSE
  access::can-trash: FALSE
  mountable::can-mount: FALSE
  mountable::can-unmount: FALSE
  mountable::can-eject: FALSE
  mountable::can-start: FALSE
  mountable::can-start-degraded: FALSE
  mountable::can-stop: FALSE
  mountable::start-stop-type: 0
  mountable::can-poll: FALSE
  mountable::is-media-check-automatic: FALSE

Pedro Villavicencio (pedro) wrote :

This bug is an upstream one and it would be quite helpful if somebody experiencing it could send the bug the to the people writing the software. You can learn more about how to do this for various upstreams at https://wiki.ubuntu.com/Bugs/Upstream/GNOME Thanks in advance!

Thibault Févry (thibaultfevry) wrote :

 Ok sending with aditional info > The file who makes that bug is proc/kcore, if you don't select it, size displays normally.

 So perhaps the problem is with the proc/kcore file and not nautilus, don't really know.

 Anyway, gonna send that as you said.

Thibault Févry (thibaultfevry) wrote :

 Ok sending with aditional info > The file who makes that bug is proc/kcore, if you don't select it, size displays normally.

 So perhaps the problem is with the proc/kcore file and not nautilus, don't really know.

 Anyway, gonna send that as you said.

It seems that you are right about nautilus but in my case folders
proc/media causing the problem.

On 07/07/2010 04:40 PM, Thibault Fevry wrote:
> Ok sending with aditional info> The file who makes that bug is
> proc/kcore, if you don't select it, size displays normally.
>
> So perhaps the problem is with the proc/kcore file and not nautilus,
> don't really know.
>
> Anyway, gonna send that as you said.
>
>

Thibault Févry (thibaultfevry) wrote :

Since it also happends to pacmanfm I'm not sure where I need to report this...

 Oh, an esay fix would be to use the same thing as DTU, that means not including /proc when calculating total size.

Sent to upstream aniway, we should get this fixed. (It could also be marked as a papercut, but I'm not completly sure it's a trivial fix.)

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged

This bug has caused problems with me installing wine apps, because my apps report not enough disk space to install.

-Denny

philinux (philcb) wrote :

This is still happening in Natty 11.04 clean install.

I'm also having the same issue with Natty 11.04 clean install

iskidoyou (troy-v) wrote :

Same issue on both of my systems (11.04 64 bit). /proc/kcore is 128TB. A quick search says that the file is just a virtual file for how much RAM the system can allocate. On a 64-bit OS, that size is 128TB (wow, imagine that much ram). Perhaps a simple fix would just be to tell nautilus to ignore all virtual files or at least ignore that specific file. I don't know if virtual files have some sort of signature that it could recognize and ignore.

abhijit (tijybba) wrote :

I am having the same issue in Ubuntu 12.04 64-bit system showing 140.8 TBs of memory , as posted here in [AskUbuntu.](http://askubuntu.com/questions/156395/my-right-click-properties-option-in-root-file-system-shows-140-8-tb-memory-of-co)

Phillip Susi (psusi) wrote :

Please use the "affects me too" button at the top rather than adding more unhelpful comments.

Phillip Susi (psusi) on 2012-07-08
Changed in nautilus (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Phillip Susi (psusi)
Changed in nautilus:
status: New → Fix Released
Phillip Susi (psusi) wrote :

Looks this this will make it into 3.7.3.

Jeremy Bicha (jbicha) on 2013-01-15
Changed in nautilus (Ubuntu Quantal):
importance: Undecided → Critical
Changed in nautilus (Ubuntu Precise):
importance: Undecided → Low
Changed in nautilus (Ubuntu Quantal):
importance: Critical → Low
status: New → Triaged
Changed in nautilus (Ubuntu Precise):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.6.3-0ubuntu5

---------------
nautilus (1:3.6.3-0ubuntu5) raring; urgency=low

  * debian/patches/git_single_filesystem_count.patch:
    - Limit filesystem content and size count to a single filesystem.
      Thanks Phillip Susi for the patch! (LP: #585472)
 -- Jeremy Bicha <email address hidden> Mon, 14 Jan 2013 22:22:01 -0500

Changed in nautilus (Ubuntu Raring):
status: In Progress → Fix Released
Jeremy Bicha (jbicha) on 2013-01-15
description: updated
Jeremy Bicha (jbicha) on 2013-01-15
Changed in nautilus (Ubuntu Raring):
assignee: Phillip Susi (psusi) → nobody
Changed in nautilus (Ubuntu Quantal):
status: Triaged → In Progress
Changed in nautilus (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Changed in nautilus (Ubuntu Quantal):
assignee: nobody → Jeremy Bicha (jbicha)
description: updated

Hello <email address hidden>, or anyone else affected,

Accepted nautilus into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.5.90.really.3.4.2-0ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
manos (gkmanos21) wrote :

Hello gentlemen :)

I tried preinstalled nautilus 3.4.2 in Ubuntu 12.10 in a virtualbox machine and the problem was solved. It displays the correct file size and file count. See the attached picture. Thank you all very much

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

Hello <email address hidden>, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/nautilus/1:3.4.2-0ubuntu7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
tags: added: verification-done-quantal
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.90.really.3.4.2-0ubuntu4.2

---------------
nautilus (1:3.5.90.really.3.4.2-0ubuntu4.2) quantal-proposed; urgency=low

  * debian/patches/git_single_filesystem_count.patch:
    - Limit filesystem content and size count to a single filesystem.
      Thanks Phillip Susi for the patch! (LP: #585472)
 -- Jeremy Bicha <email address hidden> Tue, 15 Jan 2013 01:30:41 -0500

Changed in nautilus (Ubuntu Quantal):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

could somebody verify the fix on precise as well? the SRU needs to be validated to move to updates (it's current blocking further SRUs to be accepted for nautilus)

SRU from proposed works as expected on precise. Marked as verification-done-precise.

tags: added: verification-done-precise
tags: added: verfication-done-precise
tags: removed: verfication-done-precise
tags: removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu7

---------------
nautilus (1:3.4.2-0ubuntu7) precise-proposed; urgency=low

  * debian/patches/git_single_filesystem_count.patch:
    - Limit filesystem content and size count to a single filesystem.
      Thanks Phillip Susi for the patch! (LP: #585472)
 -- Jeremy Bicha <email address hidden> Tue, 15 Jan 2013 01:36:22 -0500

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.