nautilus search always starts from home in spatial mode

Reported by delvalle26 on 2006-01-14
96
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
One Hundred Papercuts
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I'm on the amd64 dapper version. I noticed the nautilus search always starts in home, regardless of directory I've navigated to...

Isn't this a tad counter-intuitive? It has a nice option to choose location (after entering my search terms), but why would someone want to navigate a 2nd time to the current folder.

Is this planned? A bug? Does it affect other architectures...

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=325086

Please don't set the milestone, that's a tools for the distro team to know what bug are to fix for what version. This bug would be nice to fix but not a blocker

Changed in nautilus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
delvalle26 (bassaf) wrote :

Ok thanks, sorry about setting the milestone. New to this. :)

Sebastien Bacher (seb128) wrote :

No problem :)

Changed in nautilus:
status: Unconfirmed → Confirmed
Changed in nautilus:
status: Unconfirmed → Confirmed
Florian Boucault (fboucault) wrote :

I have just written this patch which corrects nautilus' behaviour. Searches are now started from the _current directory_.

Shall this patch be forwarded upstream ?

Daniel Holbach (dholbach) wrote :

It'd be nice if you could attach it to http://bugzilla.gnome.org/show_bug.cgi?id=325086 to get comments on it.

Florian Boucault (fboucault) wrote :

Done.

Note that the patch is rather trivial. I am wondering what was the rationale behind starting the search in the home folder.

Mark Florian (markrian) wrote :

I sincerely hope this patch is applied to edgy sources. Any heroes around?

Chris Lord (cwiiis) wrote :

Now there's a patch for it, maybe it should be applied in Ubuntu, in case this doesn't make it for 2.16? Also, opening a new window for a search is a bit annoying too, but not such a big deal if this is fixed.

Mark Florian (markrian) wrote :

Yes, I'd definitely like to see this fixed before edgy is released. It's only low priority, but it's such a simple patch it should be quick to apply.

-JojoMan- (jojoman02) wrote :

Why not provide an option in options leave the default as is (searches in HOME, unless more people want current dir) and then provide an option to search the current working directory to be searched. that way everyone is happy, this bugs me all the time when i open up mounted partitions and try to do a search only to have to stop it select my mounted partition and hit reload. i would love it if i went to my mp3 folder hit ctrl+f and typed in britney (joking) and pulled up all her songs, sadly not the case.

Florian Boucault (fboucault) wrote :

The patch has been submitted to the nautilus mailing list.

Florian Boucault (fboucault) wrote :

and accepted.

Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

This upload fixes the issue:

" nautilus (2.16.1-0ubuntu1) edgy; urgency=low
 .
   * New upstream version:
     - Default to search in current directory for non-indexed search
       (Ubuntu: #28537)
     - Fix clash with symbol names in gtk+
   * debian/control.in:
     - Build-Depends on libselinux1-dev
     - don't Build-Depends on libpopt-dev (>= 1.5), libgsf-1-dev
     - make libnautilus-extension-dev Depends only on libnautilus-extension1,
       libgtk2.0-dev and libgnomevfs2-dev
   * debian/patches/02_autoconf.patch:
     - updated
   * debian/patches/02_umask.patch:
     - fix from the Debian package "use & operator on umask, not ^"
   * debian/patches/90_from_cvs_corba_errors_handling.patch:
     - fixed with the new version
"

Changed in nautilus:
status: Confirmed → Fix Released
Mark Florian (markrian) wrote :

Unless I'm mistaken, I don't believe this patch is complete. The behaviour is fixed for nautilus in browser mode, but in spatial, searches still start from the Home directory regardless!

Open up a spatial nautilus window, navigate to any directory other than Home, and press Ctrl-F - the new search window that appears starts the search from Home.

Chris Lord (cwiiis) wrote :

I can confirm that this doesn't fix the issue in spatial mode.

Changed in nautilus:
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

I've reopened the upstream bug

Changed in nautilus:
status: Fix Released → Confirmed
Paolo Benvenuto (donpaolo) wrote :

Another aspect of this bug:

Edgy's nautilus correctly begin search in the current folder, but if you hit the "+" button to specify another folder, the correponding option defalts to home page, and the search is actualized to the home page.

I think the "place" option should present the current directory.

Adam Niedling (krychek) wrote :

Bug still exists in updated Gutsy beta! Nautilus search tool is useless. If I make a search for "Adam" in any directory it finds "issue5_en.pdf", the latest issue of Full Circle magazine which is currently located in my Desktop. This is an annoying bug and should be fixed.

Sebastien Bacher (seb128) wrote :

the code is open source and patches are welcome

Changed in nautilus:
status: Confirmed → Triaged

this bug was fixed before for edgy and feisty, i don't know why it
resurfaced, didn't the code make it upstream, i believe it did, i have
been following this (because it's very annoying) very puzzling...

On 10/1/07, Sebastien Bacher <email address hidden> wrote:
> the code is open source and patches are welcome
>
> ** Changed in: nautilus (Ubuntu)
> Status: Confirmed => Triaged
>
> --
> nautilus search always starts from home in spatial mode
> https://bugs.launchpad.net/bugs/28537
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
عباس

Sebastien Bacher (seb128) wrote :

The bug has been fixed for the browser mode, not the spacial one

Adam Niedling (krychek) wrote :

I don't know that spatial mode means.. I click on Places->Pictures and try to make a search it won't work. It makes the search in the wrong place and finds random files like I've explained it above.

Chris Lord (cwiiis) wrote :

That's because of the new nautilus tracker integration - The nautilus tracker search is completely useless and I've no idea why its been added to replace the genuinely useful search-in-folder capability you get when you don't have tracker/beagle installed...

(this isn't a comment on tracker btw, which I like and is useful with its own search interface, but the integration of it in nautilus)

Fabus (fabian-gebert-hh) wrote :

It should really be fixed since it's rather trivial problem, isn't it?

Sebastien Bacher (seb128) wrote :

you are welcome to work on this trivial problem and sending a patch fixing the issue

This bug was fixed in version 7.04, but is present again in 7.10.

Chris Lord (cwiiis) wrote :

No, this bug was never fixed - search has never defaulted to the folder it was initiated in in spatial mode, only in browser mode.

Adam Niedling (krychek) wrote :

Bug still exists in Hardy Alpha 3..

Adam Niedling (krychek) wrote :

Maybe bug #148701 and bug #154692 are dupes.

alexroat (alexroat) wrote :

Wow,
it is 2 years that this bug has not been solved :).

Changed in nautilus:
assignee: desktop-bugs → seb128
Sebastien Bacher (seb128) wrote :

the spatial mode is not the default mode on ubuntu so not really a good hundredpapercut issue since those should rather be issues impacting the default user experience

Mat Tomaszewski (mat.t.) wrote :

Agree with Seb here

Changed in hundredpapercuts:
status: New → Invalid
Changed in nautilus (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
David Futcher (bobbo) wrote :

As far as I understand it, a patch was accepted upstream that has fixed part of this bug. As yet, there have been no patches submitted here to fully fix this bug. I will therefore mark this as patch-accepted-upstream to keep this out of the way of the Patch Review team for now.

If a new patch is submitted, please remove the 'patch-accepted-upstream' tag and replace it with the 'patch' tag. This will put it back on the review team's radar, so someone will check it out.

tags: added: patch-accepted-upstream
Changed in nautilus:
importance: Unknown → Medium
Sebastien Bacher (seb128) wrote :

setting patch-needworks since the patch is in the current version but there is still an issue

tags: added: patch-needswork
removed: patch-accepted-upstream
Changed in nautilus:
status: Confirmed → Fix Released
Changed in nautilus (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.