"connect to server" feature don't manage NFS shares

Bug #24430 reported by Didier Conchaudron on 2005-10-22
156
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Nautilus
Won't Fix
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I think it's more a gnome feature but I can't figure out which exact package
give those abilities. Well the fact is that the "connect to server" feature
don't manage NFS shares.

Martin Bergner (martin-bergner) wrote :

Probably a nautilus issue.

Martin Bergner (martin-bergner) wrote :

Is this still a problem with Dapper or Edgy?

Changed in nautilus:
status: Unconfirmed → Needs Info
Robert Tuck (robt-majormajor) wrote :

Hi,

I have this problem too, my system is Ubuntu 6.10 Edgy PowerPc.

I've installed the required packages (nfs-common, nfs-kernel-server (although server packages shouldn't be required for client support?))

When I Select Places->Connect to server from GNOME desktop, I only get the following options in the drop-down:
SSH, FTP (login), Public FTP, Windows Share, WebDAV, Secure WebDAV, Custom Location
I believe I should also get Unix Networking (NFS) as an option.

Also I believe there should be a corresponding NFS networking icon from Places->Network Servers, which is also missing

Daniel Holbach (dholbach) wrote :

Does this work with other clients? Can you try gnomevfs-ls <url> in the terminal and see what it says?

scananza (scananza) wrote :

I have the same problem and, for what I've found out, it is related to NFS protocol not being supported by current version of gnomevfs2.
I read somewhere that NFS got dropped switching from gnomevfs to gnomevfs2 and that support is now available only through a patch. I think ubuntu package lacks that patch.
This is really annoying since it forces user to browse NFS shares in nautilus via fstab and you have to change it by hand if you connect your laptop to different LANs.
I think NFS support should be enable back again in feisty in order to surf Unix networks in nautilus like we can actually surf SMB shares at the time.

Florian M. (flomar) wrote :

I'm using Ubuntu 7.04 "Feisty Fawn". The problem still didn't chance. no way to skip manual mounting of the nfs-share.

Changed in nautilus:
importance: Medium → Low
status: Needs Info → Unconfirmed
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Gutsy Gibbon. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Incomplete
Mark (nix4me) wrote :

Has this been worked on? I am running gutsy and there is still no way to browse nfs shares on the network.

Sebastien Bacher (seb128) wrote :

No, that has not been worked, I've sent the request upstream on http://bugzilla.gnome.org/show_bug.cgi?id=479944

Changed in nautilus:
status: Incomplete → Triaged
Changed in nautilus:
status: Unknown → New
Raul Ortega (darth-debian) wrote :

Hi, I have I have Gutsy Gibbon and can't connect to NFS shares using nautilus(Connect to a server). Network Places too can't detect Linux/UNIX network/shares. What can I do?

Andrew (andrew-ramage) wrote :

Upgrading my laptop from Kubuntu 7.10 to 8.04 I lost the ability to connect to the server.

Marcin (martii) wrote :

It doesn't work in Hardy is there any chance to get it fixed ASAP?

burgwinkel (burgwinkel) wrote :

I believe it's been a problem since 6.06. Posting here instead of bug #48213 since this bug report seems more up-to-date and includes other instances of this bug in Hardy.

I can confirm this for Hardy. In Nautilus, Location, network:///, nothing shows but 'Windows Network'. In 'Places > Connect to Server...' choices for service type do not include 'Unix Network (NFS)', or anything similar.

pschroth (philip-schroth) wrote :

Under 8.10 I have the same compliants. Please fix this bug.

I suppoirt the request to solve this issue. Gnome Places/Connect to Server should definitely offer NFS shares!

Noel J. Bergman (noeljb) wrote :

As I noted in Bug 43363, now marked as a duplicate:

Still broken, even if I publish the NFS shares via AVAHI, which probably ought to be the connection. My SAMBA shares are shown, and my SSH shares (published by AVAHI) are shown, but NOT the NFS shares, despite being published by AVAHI as well.

If NFS shares are published via AVAHI, they ought to be shown. Ironically, NFS shared published by AVAHI do appear on the Mac, just not on Gnome, q.v., http://ubuntuforums.org/showthread.php?t=523928

Peter Bell (peter-bellfamily) wrote :

If I browse 'Network' with the file manager on my Eee PC (running Xandros, also Debian-based?) all machines on my local network hosting NFS shares are shown, and I can navigate to any of those shares. I have not created any mounts on the Eee PC, so it is truly capable of browsing for shares.

I presumed that Nautilus, in Ubuntu (I'm running 9.04), should be capable of behaving in the same way, especially since the Help system tells me : "To access UNIX shares, double-click on the Unix Network (NFS) object. A list of the UNIX shares available to you is displayed in the file manager window."

This is what I do under Xandros, but Ubuntu doesn't show an NFS object.

Bryan (bryan-you-2705) wrote :

Maybe this is the solution?

https://bugzilla.gnome.org/show_bug.cgi?id=536292

as [David Zeuthen] and all the discussion in the thread said
there was a regression on the NFS-related function
so we can't see NFS mount-point

and now David added it back in the GVfs release for GNOME 2.28

Is there anything we can do? Or I just get this in the wrong way?

Bryan (bryan-you-2705) on 2010-07-21
Changed in nautilus:
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Noel J. Bergman (noeljb) wrote :

Why is this marked as fix released when it is still a bug in Maverick, et al?

Eugene Crosser (crosser) wrote :

The bug https://bugzilla.gnome.org/show_bug.cgi?id=536292 is about a different problem; as it is indeed fixed we now have a workaround for the problem described in this report, not a soulution to this problem.

This complaint is about NFS shares not being covered by the same Gnome infrastructure that covers SMB, SSHFS and FTP shares, i.e. when you try to "Connect to server", there is no selection for NFS type server, and when you browse network:///, there is "Windows Network" for SMB servers no "Unix Network" for NFS server in the list.

The problem still exists as of maverick.

Omer Akram (om26er) wrote :

could someone facing this issue please send the bug upstream to nautilus developers following this procedure https://wiki.ubuntu.com/Bugs/Upstream/ if you have done so already please leave a link here.

Changed in nautilus (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Incomplete
Changed in nautilus:
importance: Medium → Undecided
status: Fix Released → New
clayzermk1 (clayzermk1) wrote :

It seems someone has already sent this upstream to GNOME Bugzilla.
https://bugzilla.gnome.org/show_bug.cgi?id=479944

It has not been resolved yet.

Eugene Crosser (crosser) on 2011-02-08
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Jochen Fahrner (jofa) wrote :

In comment #20 Eugene wrote there is a workaround for this problem. I have read the thread at bugzilla.gnome.org but don't understand what exactly the workaround is? Please can someone describe how this workaround works?

Eugene Crosser (crosser) wrote :

@jofa: the workaround is to create a line in /etc/fstab for your NFS share, with the 'user,noauto' options. That will let you mount and unmount it, usually by just clicking on and icon. (If you need more information, please seek it in the 'questions' section or in the forums because it's outside the scope of this ticket.)

Changed in nautilus:
status: New → Won't Fix
Sebastien Bacher (seb128) wrote :

Upstream marked it as wontfix, doing the same here

Changed in nautilus (Ubuntu):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.