Nautilus using more and more memory (depending on the system up-time)

Bug #174809 reported by Ivan Jekic on 2007-12-08
162
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

The more my system stays up, the more memory Nautilus uses.
Currently, nautilus uses 145mb of RAM. Two hours ago it was 142. More than 10 hours ago, it was less than 120.
Even when I don't use the system, the memory goes up. Currently I'm running Deluge (bittorrent), firefox and Pidgin. And that's it.

After "killall nautilus", it goes back to _just_ 9.6mb!!

My system is up-to-date Gutsy, I have 2gb of ram and 540mb swap.

Ivan Jekic (the-edge) wrote :

Quick update: I just noticed that Nautilus eats the memory when I open directories and folders. The more folders/files I see, the more memory it will use. However it will not revert back when I close everything. It's like it remembers everything I visit. Unfortunately, even if that's a "feature", I don't see it's good enough to suck +150mb of ram. Just imagine how much memory it will use after 3-5 or 7 days of work and no restart.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a valgrind log following the instructions at https://wiki.ubuntu.com/Valgrind and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
status: New → Incomplete
Ivan Jekic (the-edge) wrote :

Ok, thanks. I did like wiki told me. Although, Nautilus does not crash, it just fills up the memory space. I played with it for awhile. Seems like it pumps the memory usage when showing previews of picture/photo files. I managed it to go to 206mb.

Pedro Villavicencio (pedro) wrote :

It managed to use more ram because it was running with valgrind.

Ivan Jekic (the-edge) wrote :

Yeah ok, but no matter what, nautilus is acting like that, with less memory without valgrind.

Nautilus probably caches the previously seen previews of photo/picture files so it can display it faster the next time you visit those folders. That can be logical enough, but why doesn't it flush the cache, at least periodically? Also, there's no a single option that controls the cache. Hmm....

Changed in nautilus:
status: Incomplete → New
Matthew Woerly (nattgew) wrote :

In Hardy right now I'm at about 42. Can you test this on Hardy to see if you still have the issue?

Changed in nautilus:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in nautilus:
importance: Undecided → Medium
status: Incomplete → Invalid
Motin (motin) wrote :

I just moved around a lot of files between external hard drives, around 400 GB all in all. It took all night, and now I have unmounted all drives and thought I would be able to work as usual, but the system is slow and unresponsive. Nautilus takes up a whopping 1.6 gb resident, and 2.9gb all in all (so 1.3 gb in swap).

Extract from top:
  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 5247 motin 20 0 2957m 1.6g 4972 S 0 47.6 69:54.49 nautilus
 1115 motin 20 0 765m 473m 10m S 4 13.4 113:13.34 firefox

I guess nautilus somewhere has cached the file lists of all transferred files or similar, and hasn't released this memory even though even the drives are unmounted and disconnected.

Attaching the output of pmap `pidof nautilus`. I have saved a the contents of the files in /proc/`pidof nautilus`/ as well in case something else needs to be attached (Please tell me what else is needed)

Changed in nautilus (Ubuntu):
status: Invalid → New

Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: nautilus 1:2.26.2-0ubuntu2
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=sv_SE.UTF-8
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev pulse sambashare video www-data

Motin (motin) wrote :
Motin (motin) wrote :

I also have a core dump for nautilus in it's current state. Can't attach it since it is 2.9 gb... I'll run any necessary report tool on it if further information is needed.

Nautilus clearly has issues with memory hogging and there should now be enough debug information available for this bug to be considered confirmed.

Changed in nautilus (Ubuntu):
status: New → Confirmed
ticket (tickettothemoon2004) wrote :

I can confirm same experience as Motin.
Moving large folder trees causes Nautilus to consume large amounts of RAM that it doesn't release afterwards.
I don't have preview / thumbs enabled and my zoom is 50%, if that is relevant (but I doubt it).
This Nautilus bug has cropped up in all sorts of places and guises.

Intrepid 8.1
Nautilus 2.24.1 ( 1:2.24.1-0ubuntu2 )

"Motin wrote on 2009-06-06:
I just moved around a lot of files between external hard drives, around 400 GB all in all. It took all night, and now I have unmounted all drives and thought I would be able to work as usual, but the system is slow and unresponsive. Nautilus takes up a whopping 1.6 gb resident, and 2.9gb all in all (so 1.3 gb in swap)."

Confirmed on 64-bit Karmic. Now nautilus process occupies 280 MB of RAM!

I can easily get it to even 500 MB and more - it's enough to open a directory with a lot of multimedia inside. It seems it's caching a lot... But even cache should have limited size, I really don't want a file manager to eat up 1/2 GB of my RAM!

Reported upstream.

Thanks for sending this upstream. Setting to "triaged".

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Nicholas Platt (nicholasplatt) wrote :

I'm experiencing the same problem. i just killed nautilus because it has consumed 2.1G and causing my computer to be sluggish. Has there been any resolution?

etech (eric-amrita) wrote :

Hello,

I am also getting 800mb+ memory usage from nautilus after copying over 100 gigs of data from an external hard drive. I also viewed the properties of each folder, so nautilus had to count up the number of files and their size (not sure if this is part of the problem).

-etech

3ntix (francesco-3ntini) wrote :

I've just boot up the machine and nautilus uses about 300MB!!!
$ ps aux|grep nautilus
user 1643 29.3 8.1 806980 317532 ? S 15:39 2:26 nautilus --sm-client-id 10c0f6fff5d7048c93127272068344143100000014060038

Josef Fritzl (kladionica-city) wrote :

Check if you have ˝nautilus-clamscan˝ installed ,and if you have remove it .Nautilus was taking 250mb+ when booting up,then i remove this package and restarted nautilus and was back at 30mb

this isn't limited to nautilus-clamscan (never installed) :(

2010/5/28 Josef Fritzl <email address hidden>

> Check if you have ˝nautilus-clamscan˝ installed ,and if you have remove
> it .Nautilus was taking 250mb+ when booting up,then i remove this
> package and restarted nautilus and was back at 30mb
>
> --
> Nautilus using more and more memory (depending on the system up-time)
> https://bugs.launchpad.net/bugs/174809
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Nautilus: Unknown
> Status in “nautilus” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: nautilus
>
> The more my system stays up, the more memory Nautilus uses.
> Currently, nautilus uses 145mb of RAM. Two hours ago it was 142. More than
> 10 hours ago, it was less than 120.
> Even when I don't use the system, the memory goes up. Currently I'm running
> Deluge (bittorrent), firefox and Pidgin. And that's it.
>
> After "killall nautilus", it goes back to _just_ 9.6mb!!
>
> My system is up-to-date Gutsy, I have 2gb of ram and 540mb swap.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/nautilus/+bug/174809/+subscribe
>

description: updated
dart (dart-v85) wrote :

i am also facing this problem...its been so long that this bug is there...how it is not fixed yet....how come it is not critical....i think "the 10.10.10" will also have this bug....users will keep facing the problem and people will keep commenting on this...but it will not be fixed....i m struggling to keep my tone down...

Brian Crowell (brian-fluggo) wrote :

dartttt: I feel the same way. People have been reporting this bug for years now. The devs seem to pick up on the first "works for me" report and close the bugs.

Surely there's an alternative to nautilus we could be using.

Confirmed on Maverick.

Philip Muškovac (yofel) on 2010-07-25
tags: added: jaunty karmic maverick
UndiFineD (k.dejong) wrote :

top - 23:53:28 up 10:23, 2 users, load average: 0.22, 0.51, 0.65
Tasks: 242 total, 1 running, 241 sleeping, 0 stopped, 0 zombie
Cpu(s): 1.0%us, 0.7%sy, 0.0%ni, 97.6%id, 0.0%wa, 0.7%hi, 0.0%si, 0.0%st
Mem: 3539756k total, 3300664k used, 239092k free, 155348k buffers
Swap: 4000144k total, 40k used, 4000104k free, 1536720k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2424 undifine 20 0 1010m 248m 37m S 0.0 7.2 1:10.76 nautilus

Kip Warner (kip) wrote :

I can confirm the same symptoms under Lucid on amd64. The longer the system uptime, the more memory it uses. Right now Nautilus is using 397.1 MB of memory. If I kill it, I reclaim most of it, but then it will start to creep up again slowly.

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Dennis Fehr (cy-raid) wrote :

I can also say removing the nautilus-clamscan package dropped my Nautilus from 250~MB to 7.4MB. It does grow naturally, but with clamscan added it grows by an insane amount.. Is it then the plugin system that's not freeing memory?

Alecz20 (alexguzu) wrote :

I have a fresh install of Ubuntu 9.10 64-bit.

While copying a vew hundred GB of data from one partition to another, I noticed that Nautilus was using about 1 GB of RAM (out of 4 GB).

After the transfer finished the usage remained the same.

Note that this is a fresh install, the only additional things were the ATI proprietary driver, TrueCrypt, and VirtualBox, so no codecs, or plugins.

Alecz20 try nautilus 2.32 in Ubuntu 10.10

On Fri, Oct 8, 2010 at 1:10 AM, Alecz20 <email address hidden> wrote:

> I have a fresh install of Ubuntu 9.10 64-bit.
>
> While copying a vew hundred GB of data from one partition to another, I
> noticed that Nautilus was using about 1 GB of RAM (out of 4 GB).
>
> After the transfer finished the usage remained the same.
>
> Note that this is a fresh install, the only additional things were the
> ATI proprietary driver, TrueCrypt, and VirtualBox, so no codecs, or
> plugins.
>
> --
> Nautilus using more and more memory (depending on the system up-time)
> https://bugs.launchpad.net/bugs/174809
> You received this bug notification because you are subscribed to
> nautilus in ubuntu.
>
> Status in Nautilus: New
> Status in “nautilus” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: nautilus
>
> The more my system stays up, the more memory Nautilus uses.
> Currently, nautilus uses 145mb of RAM. Two hours ago it was 142. More than
> 10 hours ago, it was less than 120.
> Even when I don't use the system, the memory goes up. Currently I'm running
> Deluge (bittorrent), firefox and Pidgin. And that's it.
>
> After "killall nautilus", it goes back to _just_ 9.6mb!!
>
> My system is up-to-date Gutsy, I have 2gb of ram and 540mb swap.
>
>
>
>
>

Jimmy Merrild Krag (beruic) wrote :

I can confirm the issue on 10.10 with nautilus elementary, but as far as I remember I have had this issue for quite some time. at least the last 4 or 5 Ubuntu versions. Nautilus doesn't reclaim memory. This accounts for both file transfers and thumbnails.

Jimmy Merrild Krag (beruic) wrote :

Usually you can reclaim memory by logging out and in again.

Semen Ivanov (gmcg) wrote :

The same bug on 10.10 with nautilus (no nautilus-clamscan installed) on Amd64, nautilus used 345 Mb of RAM without any activity (just firefox was running), plus page file was up to 360 MB. Shutting down nautilus allowed to get memory usage down to below 50% (850 Mb) - before it was about 75%, and page file size down to 70 Mb. Restart of nautilus didn't cause the problem again ... it used only 11 Mb of RAM. This is weird.

Semen Ivanov (gmcg) wrote :

I have solver the problem completely - including slow downs and freezes - replacing nautilus with PCManFM 0.9.7 - now everything works as it should be! My memory is below 50% all the time. Woot!!!

Semen Ivanov (gmcg) wrote :

I mean solved - sorry for the typo

Also happens in natty
Package version: 1:2.32.2.1-0ubuntu8

Semen Ivanov (gmcg) wrote :

Natty is a bug collector, used 72% of my memory - idle status (2Gb in amd64 system) - all visible processes were at 21 Mb memory consuming postion (max), several kernel panic screens, hardware is OK. Went back to xubuntu 10.10 - Thunar works without any problem of nautilus. It is interesting that ristretto has the same memory leak issue as nautilus here in this thread, but it is easy to replace it.
I will wait white Natty will be matured anough to have no obvious bugs ...
PCManFM 0.9.7 definitely solves the problem with nautilus, but it is pretty old and inconvenient - Thunar is much better.

lal lop (lalop-lmao) wrote :

Still happens in lucid as well. Sometimes I get lucky, other times I come back to find nautilus is taking 1-2GB of memory. I think it also happens when you are viewing a folder that's updating a lot.

Vadim Rutkovsky (roignac) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. We are sorry that we do not always have the capacity to look at all reported bugs in a timely manner. There have been many changes in Ubuntu since that time you reported the bug and your problem may have been fixed with some of the updates. It would help us a lot if you could test it on a currently supported Ubuntu version.

Closing this as Invalid, as valgrind logs were not supported, upstream issue has not been updated. See bug 952108 for recent report on memory issue
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in nautilus (Ubuntu):
status: Triaged → Invalid
Changed in nautilus:
status: New → Confirmed
jvp (jvpgr) wrote :

ubuntu 16.04 lts and the bug still present

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.